aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-14 23:27:30 +0800
committerpav <pav@FreeBSD.org>2003-12-14 23:27:30 +0800
commitd1890d99f82fe1fc45666795246f884942e63115 (patch)
tree04e62e2936e16926b5b65c9edead8f7ae85e8700
parentccf06bccb5fe5b17c6aa7dc512f4819b27406e45 (diff)
downloadfreebsd-ports-gnome-d1890d99f82fe1fc45666795246f884942e63115.tar.gz
freebsd-ports-gnome-d1890d99f82fe1fc45666795246f884942e63115.tar.zst
freebsd-ports-gnome-d1890d99f82fe1fc45666795246f884942e63115.zip
- Conditionalise dependency on compat libraries
PR: ports/60231 Submitted by: Serge Negodyuck <petr@petrovich.kiev.ua> (maintainer)
-rw-r--r--graphics/xnview/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/xnview/Makefile b/graphics/xnview/Makefile
index dc9cbd566d28..dff20079bc45 100644
--- a/graphics/xnview/Makefile
+++ b/graphics/xnview/Makefile
@@ -15,14 +15,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= petr@petrovich.kiev.ua
COMMENT= An easy graphics viewer / converter
-LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/XnView-1.50-x86-unknown-FreeBSD4.x-static
INSTALL_SLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/xnview ${PREFIX}/bin/xnview
${INSTALL_PROGRAM} ${WRKSRC}/bin/nview ${PREFIX}/bin/nv
@@ -37,4 +41,4 @@ do-install:
${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>