aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-18 22:25:16 +0800
committeraz <az@FreeBSD.org>2013-08-18 22:25:16 +0800
commitd1ba17184cbf1990d10b312acd427dff1c5596df (patch)
tree83e469779da267ab5114aafd28b4f4cbe26df0f9
parenteb091bce96aff7552ed2c37846af746591d5ccaa (diff)
downloadfreebsd-ports-gnome-d1ba17184cbf1990d10b312acd427dff1c5596df.tar.gz
freebsd-ports-gnome-d1ba17184cbf1990d10b312acd427dff1c5596df.tar.zst
freebsd-ports-gnome-d1ba17184cbf1990d10b312acd427dff1c5596df.zip
- Convert to new perl framework
-rw-r--r--devel/p5-IO-BufferedSelect/Makefile3
-rw-r--r--misc/p5-Array-FileReader/Makefile3
-rw-r--r--misc/p5-Array-LineReader/Makefile3
-rw-r--r--net/p5-BBS-Client/Makefile3
-rw-r--r--textproc/p5-HTML-QRCode/Makefile3
-rw-r--r--textproc/p5-Text-QRCode/Makefile3
6 files changed, 12 insertions, 6 deletions
diff --git a/devel/p5-IO-BufferedSelect/Makefile b/devel/p5-IO-BufferedSelect/Makefile
index bd43183e0b08..eb911b1beb34 100644
--- a/devel/p5-IO-BufferedSelect/Makefile
+++ b/devel/p5-IO-BufferedSelect/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Line-buffered select interface
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::BufferedSelect.3
diff --git a/misc/p5-Array-FileReader/Makefile b/misc/p5-Array-FileReader/Makefile
index 73e9c43566f9..7043755301d3 100644
--- a/misc/p5-Array-FileReader/Makefile
+++ b/misc/p5-Array-FileReader/Makefile
@@ -13,7 +13,8 @@ COMMENT= Lazily tie files to arrays for reading
BUILD_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Array::FileReader.3
diff --git a/misc/p5-Array-LineReader/Makefile b/misc/p5-Array-LineReader/Makefile
index 5c0d1f504c8f..2c763738f87d 100644
--- a/misc/p5-Array-LineReader/Makefile
+++ b/misc/p5-Array-LineReader/Makefile
@@ -13,7 +13,8 @@ COMMENT= Access lines of a file via an array
BUILD_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Array::LineReader.3
diff --git a/net/p5-BBS-Client/Makefile b/net/p5-BBS-Client/Makefile
index e22bc7c6d593..9f41c0596d57 100644
--- a/net/p5-BBS-Client/Makefile
+++ b/net/p5-BBS-Client/Makefile
@@ -14,7 +14,8 @@ COMMENT= A Client Module For BBS Systems
BUILD_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::Client.3
diff --git a/textproc/p5-HTML-QRCode/Makefile b/textproc/p5-HTML-QRCode/Makefile
index 5cf72d1dba2c..d8429997a45e 100644
--- a/textproc/p5-HTML-QRCode/Makefile
+++ b/textproc/p5-HTML-QRCode/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Text-QRCode>0:${PORTSDIR}/textproc/p5-Text-QRCode \
libqrencode>=2.0.0:${PORTSDIR}/graphics/libqrencode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CFLAGS+= -I${LOCALBASE}/include
MAN3= HTML::QRCode.3
diff --git a/textproc/p5-Text-QRCode/Makefile b/textproc/p5-Text-QRCode/Makefile
index f3eb4fd163b5..531d30770047 100644
--- a/textproc/p5-Text-QRCode/Makefile
+++ b/textproc/p5-Text-QRCode/Makefile
@@ -14,7 +14,8 @@ COMMENT= Generate text based QR Code
BUILD_DEPENDS= libqrencode>=2.0.0:${PORTSDIR}/graphics/libqrencode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CFLAGS+= -I${LOCALBASE}/include
MAN3= Text::QRCode.3