aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-07-11 23:23:44 +0800
committermiwi <miwi@FreeBSD.org>2013-07-11 23:23:44 +0800
commitd2d1a3c289e07b55fce9ecc9973d6928459284a2 (patch)
treebd8b5daf712f7b97afefe9f6f7e98e41656fc2ba
parentbaa56acd107b9811125087338910a4620d43f583 (diff)
downloadfreebsd-ports-gnome-d2d1a3c289e07b55fce9ecc9973d6928459284a2.tar.gz
freebsd-ports-gnome-d2d1a3c289e07b55fce9ecc9973d6928459284a2.tar.zst
freebsd-ports-gnome-d2d1a3c289e07b55fce9ecc9973d6928459284a2.zip
Adds permission TICKET_ATTACHMENT_DELETE for exclusive right
to delete and replace attachments, regardless who added/changed it. Everybody who has permission TICKET_ATTACHMENT_DELETE can delete or replace attachments, regardless who added / changed it. WWW: http://trac-hacks.org/wiki/AttachmentPolicyPlugin PR: ports/177423 Submitted by: Hung-Yi Chen <gaod@hychen.org>
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-attachmentpolicy/Makefile31
-rw-r--r--www/trac-attachmentpolicy/distinfo2
-rw-r--r--www/trac-attachmentpolicy/pkg-descr7
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8b3e32f6001c..ec10ac8e1327 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1911,6 +1911,7 @@
SUBDIR += trac-addcomment
SUBDIR += trac-advancedticketworkflow
SUBDIR += trac-announcer
+ SUBDIR += trac-attachmentpolicy
SUBDIR += trac-autocomplete
SUBDIR += trac-batchmodify
SUBDIR += trac-bzr
diff --git a/www/trac-attachmentpolicy/Makefile b/www/trac-attachmentpolicy/Makefile
new file mode 100644
index 000000000000..eeb6046a872d
--- /dev/null
+++ b/www/trac-attachmentpolicy/Makefile
@@ -0,0 +1,31 @@
+# Created by: Hung-Yi Chen <gaod@hychen.org>
+# $FreeBSD$
+
+PORTNAME= attachmentpolicy
+PORTVERSION= 0.1.0.${SVN_REV}
+CATEGORIES= www devel python
+MASTER_SITES= http://distfiles.cse.tw/ \
+ http://trac-hacks.org/changeset/${SVN_REV}/attachmentpolicyplugin?old_path=/&format=zip&filename=/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-r${SVN_REV}
+
+MAINTAINER= gaod@hychen.org
+COMMENT= Provides delete permission to Trac normal user
+
+LICENSE= BSD
+
+SVN_REV= 12775
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.12
+USE_ZIP= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+PYDISTUTILS_PKGNAME= Attachment_Policy_Plugin
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:C/.${SVN_REV}//g}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/trac-attachmentpolicy/distinfo b/www/trac-attachmentpolicy/distinfo
new file mode 100644
index 000000000000..031eecd0439d
--- /dev/null
+++ b/www/trac-attachmentpolicy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (attachmentpolicyplugin-r12775.zip) = be8493552557ee027d708dd32debcd1b7ca1c08cdb610a1490ac1b03b59b02ba
+SIZE (attachmentpolicyplugin-r12775.zip) = 1731
diff --git a/www/trac-attachmentpolicy/pkg-descr b/www/trac-attachmentpolicy/pkg-descr
new file mode 100644
index 000000000000..3773c096012d
--- /dev/null
+++ b/www/trac-attachmentpolicy/pkg-descr
@@ -0,0 +1,7 @@
+Adds permission TICKET_ATTACHMENT_DELETE for exclusive right
+to delete and replace attachments, regardless who added/changed it.
+
+Everybody who has permission TICKET_ATTACHMENT_DELETE can delete
+or replace attachments, regardless who added / changed it.
+
+WWW: http://trac-hacks.org/wiki/AttachmentPolicyPlugin