aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-19 04:38:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-19 04:38:03 +0800
commitd30eaa4ef2c274bfa95ac5edbc085b14c4978d2c (patch)
tree25befe8e7fd2722c1b835cc3bd7f6ffc8624a8bd
parentee3191c3faeba9ca8f41da721f77c083bd289c7a (diff)
downloadfreebsd-ports-gnome-d30eaa4ef2c274bfa95ac5edbc085b14c4978d2c.tar.gz
freebsd-ports-gnome-d30eaa4ef2c274bfa95ac5edbc085b14c4978d2c.tar.zst
freebsd-ports-gnome-d30eaa4ef2c274bfa95ac5edbc085b14c4978d2c.zip
Add NODE10 option
-rw-r--r--devel/rubygem-execjs/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/rubygem-execjs/Makefile b/devel/rubygem-execjs/Makefile
index 31d37f146ddf..f57f0de12cf5 100644
--- a/devel/rubygem-execjs/Makefile
+++ b/devel/rubygem-execjs/Makefile
@@ -12,23 +12,25 @@ COMMENT= ExecJS lets you run JavaScript code from Ruby
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
-NO_ARCH= yes
-USE_RUBY= yes
USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE6 NODE8
+OPTIONS_SINGLE_BACKEND= NODE NODE6 NODE8 NODE10
OPTIONS_DEFAULT=NODE
-NODE_DESC= Use Node.js 9.x (www/node) as backend
+NODE_DESC= Use Node.js 11.x (www/node) as backend
NODE6_DESC= Use Node.js 6.x (www/node6) as backend
NODE8_DESC= Use Node.js 8.x (www/node8) as backend
+NODE10_DESC= Use Node.js 10.x (www/node10) as backend
NODE_RUN_DEPENDS= node>=0:www/node
NODE6_RUN_DEPENDS= node6>=0:www/node6
NODE8_RUN_DEPENDS= node8>=0:www/node8
+NODE10_RUN_DEPENDS= node10>=0:www/node10
post-patch:
- @${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#' \
- ${WRKSRC}/lib/${PORTNAME}/runtimes.rb
+ @${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#' ${WRKSRC}/lib/execjs/runtimes.rb
.include <bsd.port.mk>