aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2013-12-17 04:17:52 +0800
committerdemon <demon@FreeBSD.org>2013-12-17 04:17:52 +0800
commitd3536a2ba88f36cc7b4c017fa3d507513223d4d8 (patch)
tree297f6fc00b1db5c56a7551a5ec03d8693d22f98c
parent7f721f3718cec0f7616808386f9e2181b472a6c7 (diff)
downloadfreebsd-ports-gnome-d3536a2ba88f36cc7b4c017fa3d507513223d4d8.tar.gz
freebsd-ports-gnome-d3536a2ba88f36cc7b4c017fa3d507513223d4d8.tar.zst
freebsd-ports-gnome-d3536a2ba88f36cc7b4c017fa3d507513223d4d8.zip
More compact way to handle options.
Submitted by: mat
-rw-r--r--net-mgmt/nagios-plugins/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 60c7690df30c..cea2534a7ae7 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -32,6 +32,8 @@ JAIL_DESC= Compilation within jail(8) (see Makefile)
DBI_DESC= Check database using DBI
EXTRAOPTS_DESC= Parsing of plugins ini config files for extra options
+EXTRAOPTS_CONFIGURE_ENABLE= extra-opts
+
GNU_CONFIGURE= yes
NAGIOSUSER?= nagios
@@ -49,7 +51,7 @@ NEED_ROOT= yes # check_icmp, check_dhcp
.include <bsd.port.options.mk>
-CONFIGURE_ARGS= --with-nagios-user=${NAGIOSUSER} \
+CONFIGURE_ARGS+=--with-nagios-user=${NAGIOSUSER} \
--with-nagios-group=${NAGIOSGROUP} \
--with-cgiurl=${NAGIOSCGIURL} \
--sbindir=${PREFIX}/${NAGIOSWWWDIR}/cgi-bin \
@@ -149,10 +151,6 @@ CONFIGURE_ARGS+= --without-dbi
PLIST_SUB+= SUB_DBI="@comment "
.endif
-.if ${PORT_OPTIONS:MEXTRAOPTS}
-CONFIGURE_ARGS+= --enable-extra-opts
-.endif
-
.if ${OSVERSION} > 1000055
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-dig-to-drill.diff
CONFIGURE_ARGS+=--with-dig-command=/usr/bin/drill