aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-02-20 10:32:49 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-02-20 10:32:49 +0800
commitd3604c7f1cca3700704c745fea46e26d26679b01 (patch)
tree87457527639c9d687f79074cb20beb14418644f3
parent1d58138bdd8fc6afa8164ab24174be2fa9a70638 (diff)
downloadfreebsd-ports-gnome-d3604c7f1cca3700704c745fea46e26d26679b01.tar.gz
freebsd-ports-gnome-d3604c7f1cca3700704c745fea46e26d26679b01.tar.zst
freebsd-ports-gnome-d3604c7f1cca3700704c745fea46e26d26679b01.zip
Add p5-Test-Most 0.21, perl extension for most commonly needed test
functions and features.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Most/Makefile30
-rw-r--r--devel/p5-Test-Most/distinfo3
-rw-r--r--devel/p5-Test-Most/pkg-descr3
-rw-r--r--devel/p5-Test-Most/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 329241bae015..f81b481ae5ef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1822,6 +1822,7 @@
SUBDIR += p5-Test-MockObject
SUBDIR += p5-Test-MockRandom
SUBDIR += p5-Test-MockTime
+ SUBDIR += p5-Test-Most
SUBDIR += p5-Test-NoWarnings
SUBDIR += p5-Test-Number-Delta
SUBDIR += p5-Test-Object
diff --git a/devel/p5-Test-Most/Makefile b/devel/p5-Test-Most/Makefile
new file mode 100644
index 000000000000..1bd0bf4e014e
--- /dev/null
+++ b/devel/p5-Test-Most/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Test::Most
+# Date created: 20 Feb 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Most
+PORTVERSION= 0.21
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for most commonly needed test functions and features
+
+RUN_DEPENDS= \
+ p5-Exception-Class>=1.14:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Warn>=0.1:${PORTSDIR}/devel/p5-Test-Warn
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Most.3 \
+ Test::Most::Exception.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Most/distinfo b/devel/p5-Test-Most/distinfo
new file mode 100644
index 000000000000..4f183f8f5cef
--- /dev/null
+++ b/devel/p5-Test-Most/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Most-0.21.tar.gz) = 8066a15a40154d011296b33ce02a1cf8
+SHA256 (Test-Most-0.21.tar.gz) = ca54ab8e6ddfa8e33a66f6c27c33dca04f070e768c7f58efb457fba7226cc7f4
+SIZE (Test-Most-0.21.tar.gz) = 10732
diff --git a/devel/p5-Test-Most/pkg-descr b/devel/p5-Test-Most/pkg-descr
new file mode 100644
index 000000000000..72952e533886
--- /dev/null
+++ b/devel/p5-Test-Most/pkg-descr
@@ -0,0 +1,3 @@
+Most commonly needed test functions and features.
+
+WWW: http://search.cpan.org/dist/Test-Most/
diff --git a/devel/p5-Test-Most/pkg-plist b/devel/p5-Test-Most/pkg-plist
new file mode 100644
index 000000000000..92157421fe2b
--- /dev/null
+++ b/devel/p5-Test-Most/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Most/.packlist
+%%SITE_PERL%%/Test/Most.pm
+%%SITE_PERL%%/Test/Most/Exception.pm
+@dirrm %%SITE_PERL%%/Test/Most
+@dirrmtry %%SITE_PERL%%/Test
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Most