aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-24 22:40:18 +0800
committerswills <swills@FreeBSD.org>2014-03-24 22:40:18 +0800
commitd3756fed0216f3365447b87db0e7facfff852fac (patch)
treee92f51bd0934d589ecb8f83fdafe34f939c61fbf
parent29bcf6c839db78562ab971f6a52e51653537951a (diff)
downloadfreebsd-ports-gnome-d3756fed0216f3365447b87db0e7facfff852fac.tar.gz
freebsd-ports-gnome-d3756fed0216f3365447b87db0e7facfff852fac.tar.zst
freebsd-ports-gnome-d3756fed0216f3365447b87db0e7facfff852fac.zip
- Update to 3.4.6
- Stage - Fix startup scripts - Remove C/Python bindings, will be readded in separate ports hopefully soon - Update description and comment - Pet portlint PR: ports/185896 Submitted by: Bartek Rutkowski <ports@robakdesign.com> Approved by: Steven Kreuzer <skreuzer@freebsd.org> (maintainer)
-rw-r--r--devel/zookeeper/Makefile99
-rw-r--r--devel/zookeeper/distinfo4
-rw-r--r--devel/zookeeper/files/patch-src-c-src-zookeeper.c21
-rw-r--r--devel/zookeeper/pkg-descr18
-rw-r--r--devel/zookeeper/pkg-plist69
5 files changed, 58 insertions, 153 deletions
diff --git a/devel/zookeeper/Makefile b/devel/zookeeper/Makefile
index 10f47257e408..c0cfdc7e283d 100644
--- a/devel/zookeeper/Makefile
+++ b/devel/zookeeper/Makefile
@@ -2,22 +2,18 @@
# $FreeBSD$
PORTNAME= zookeeper
-PORTVERSION= 3.3.6
+PORTVERSION= 3.4.6
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= zookeeper/zookeeper-${PORTVERSION}
MAINTAINER= skreuzer@FreeBSD.org
-COMMENT= A Coordination Service for Distributed Applications
+COMMENT= Service for maintaining distributed configuration, naming and locks
LICENSE= APACHE20
LIB_DEPENDS= libcppunit.so:${PORTSDIR}/devel/cppunit
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
-OPTIONS_DEFINE= C PYTHON
-C_DESC= Build C library bindings and command line tool
-OPTIONS_DEFAULT= C PYTHON DOC
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_JAVA= yes
JAVA_VERSION= 1.7
@@ -26,14 +22,11 @@ JAVA_RUN= yes
USE_RC_SUBR= zookeeper
-ZOOKEEPER_LOGDIR= /var/log/${PORTNAME}
-ZOOKEEPER_RUNDIR= /var/run/${PORTNAME}
-
-PYTHON_BINDING_WRKSRC= ${WRKSRC}/src/contrib/zkpython
-PYDISTUTILS_PKGNAME= ZooKeeper
-PYDISTUTILS_PKGVERSION= 0.4
+OPTIONS_DEFINE= DOC
+DOC_DESC= Install documentation
+OPTIONS_DEFAULT= DOC
-CONFIGURE_WRKSRC= ${WRKSRC}/src/c
+NO_BUILD= yes
SCRIPTS= zkCleanup.sh \
zkCli.sh \
@@ -41,76 +34,28 @@ SCRIPTS= zkCleanup.sh \
zkServer.sh
PORTDOCS= *
-PLIST_SUB= PORTVERSION=${PORTVERSION}
-SUB_LIST= ZOOKEEPER_LOGDIR=${ZOOKEEPER_LOGDIR} \
- ZOOKEEPER_RUNDIR=${ZOOKEEPER_RUNDIR}
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2
-BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
-PLIST_SUB+= WITH_PYTHON=""
-.else
-PLIST_SUB+= WITH_PYTHON="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MC}
-USE_AUTOTOOLS= automake autoconf libtool
-USE_LDCONFIG= yes
-PLIST_SUB+= WITH_C=""
-.else
-PLIST_SUB+= WITH_C="@comment "
-.endif
+PLIST_SUB= PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ RESETPREFIX=${PREFIX}
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MC}
-#run-autotools: run-autotools-autoreconf
-
-#run-autotools-autoreconf:
-run-autotools:
- @cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -if
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|executable="python"|executable="${PYTHON_CMD}"|' \
- ${PYTHON_BINDING_WRKSRC}/build.xml
-
-do-build:
-.if ${PORT_OPTIONS:MC}
- cd ${CONFIGURE_WRKSRC} && \
- ${MAKE}
-.endif
-.if ${PORT_OPTIONS:MPYTHON}
- cd ${PYTHON_BINDING_WRKSRC} && \
- ant compile
-.endif
-
do-install:
- ${MKDIR} ${PREFIX}/${PORTNAME}
- ${MKDIR} ${PREFIX}/${PORTNAME}/bin
- ${MKDIR} ${ZOOKEEPER_LOGDIR}
- ${MKDIR} ${ZOOKEEPER_RUNDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin
.for f in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${PREFIX}/${PORTNAME}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin
.endfor
- cd ${WRKSRC} && ${COPYTREE_SHARE} conf ${PREFIX}/${PORTNAME}/
- cd ${WRKSRC} && ${COPYTREE_SHARE} lib ${PREFIX}/${PORTNAME}/
- ${INSTALL_DATA} ${WRKSRC}/*.jar ${PREFIX}/${PORTNAME}
-.if ${PORT_OPTIONS:MC}
- cd ${CONFIGURE_WRKSRC} && \
- ${MAKE} install
-.endif
-.if ${PORT_OPTIONS:MPYTHON}
- cd ${PYTHON_BINDING_WRKSRC} && \
- ant install
-.endif
+ cd ${WRKSRC} && ${COPYTREE_SHARE} conf ${STAGEDIR}${PREFIX}/${PORTNAME}/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} lib ${STAGEDIR}${PREFIX}/${PORTNAME}/
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${STAGEDIR}${PREFIX}/${PORTNAME}
+
+post-install:
.if ${PORT_OPTIONS:MDOC}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
+ @${MKDIR} ${STAGEDIR}/var/log/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}/var/run/${PORTNAME}
.include <bsd.port.post.mk>
diff --git a/devel/zookeeper/distinfo b/devel/zookeeper/distinfo
index 2cd6e02e4c0c..aa2648957de3 100644
--- a/devel/zookeeper/distinfo
+++ b/devel/zookeeper/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zookeeper-3.3.6.tar.gz) = eb311ec0479a9447d075a20350ecfc5cf6a2a6d9842d13b59d7548430ac37521
-SIZE (zookeeper-3.3.6.tar.gz) = 11833706
+SHA256 (zookeeper-3.4.6.tar.gz) = 01b3938547cd620dc4c93efe07c0360411f4a66962a70500b163b59014046994
+SIZE (zookeeper-3.4.6.tar.gz) = 17699306
diff --git a/devel/zookeeper/files/patch-src-c-src-zookeeper.c b/devel/zookeeper/files/patch-src-c-src-zookeeper.c
deleted file mode 100644
index ac1ed23b6051..000000000000
--- a/devel/zookeeper/files/patch-src-c-src-zookeeper.c
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: zookeeper.c
-===================================================================
---- src/c/src/zookeeper.c 2012-07-05 15:53:43.348806000 -0400
-+++ src/c/src/zookeeper.c 2012-07-05 15:55:12.800391000 -0400
-@@ -413,7 +413,6 @@
- static int getaddrinfo_errno(int rc) {
- switch(rc) {
- case EAI_NONAME:
-- case EAI_NODATA:
- return ENOENT;
- case EAI_MEMORY:
- return ENOMEM;
-@@ -546,7 +545,7 @@
- //EAI_BADFLAGS or EAI_ADDRFAMILY with AF_UNSPEC and
- // ai_flags as AI_ADDRCONFIG
- if ((hints.ai_flags == AI_ADDRCONFIG) &&
-- ((rc ==EAI_BADFLAGS) || (rc == EAI_ADDRFAMILY))) {
-+ (rc ==EAI_BADFLAGS)) {
- //reset ai_flags to null
- hints.ai_flags = 0;
- //retry getaddrinfo
diff --git a/devel/zookeeper/pkg-descr b/devel/zookeeper/pkg-descr
index ed9726d3753e..2aa588ca3075 100644
--- a/devel/zookeeper/pkg-descr
+++ b/devel/zookeeper/pkg-descr
@@ -1,16 +1,8 @@
-ZooKeeper: A Distributed Coordination Service for Distributed Applications
-
ZooKeeper is a distributed, open-source coordination service for
distributed applications. It exposes a simple set of primitives that
-distributed applications can build upon to implement higher level
-services for synchronization, configuration maintenance, and groups
-and naming. It is designed to be easy to program to, and uses a data
-model styled after the familiar directory tree structure of file
-systems. It runs in Java and has bindings for both Java and C.
-
-Coordination services are notoriously hard to get right. They are
-especially prone to errors such as race conditions and deadlock. The
-motivation behind ZooKeeper is to relieve distributed applications the
-responsibility of implementing coordination services from scratch.
+applications can build upon to implement higher level services
+for synchronization, configuration maintenance, and groups and naming.
+It is designed to be easy to program to, and uses a data model
+styled after the familiar directory tree structure of filesystems.
-WWW: http://zookeeper.apache.org/
+WWW: http://zookeeper.apache.org/
diff --git a/devel/zookeeper/pkg-plist b/devel/zookeeper/pkg-plist
index f59feb3da1fa..b3f7527af050 100644
--- a/devel/zookeeper/pkg-plist
+++ b/devel/zookeeper/pkg-plist
@@ -1,40 +1,29 @@
-%%WITH_C%%bin/cli_mt
-%%WITH_C%%bin/cli_st
-%%WITH_C%%bin/load_gen
-%%WITH_C%%include/c-client-src/recordio.h
-%%WITH_C%%include/c-client-src/zookeeper.h
-%%WITH_C%%include/c-client-src/zookeeper.jute.h
-%%WITH_C%%include/c-client-src/zookeeper_log.h
-%%WITH_C%%include/c-client-src/zookeeper_version.h
-%%WITH_C%%lib/libzookeeper_mt.a
-%%WITH_C%%lib/libzookeeper_mt.la
-%%WITH_C%%lib/libzookeeper_mt.so
-%%WITH_C%%lib/libzookeeper_mt.so.2
-%%WITH_C%%lib/libzookeeper_st.a
-%%WITH_C%%lib/libzookeeper_st.la
-%%WITH_C%%lib/libzookeeper_st.so
-%%WITH_C%%lib/libzookeeper_st.so.2
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/ZooKeeper-0.4-py2.7.egg-info
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/zookeeper.so
-zookeeper/bin/zkCleanup.sh
-zookeeper/bin/zkCli.sh
-zookeeper/bin/zkEnv.sh
-zookeeper/bin/zkServer.sh
-zookeeper/conf/configuration.xsl
-zookeeper/conf/log4j.properties
-zookeeper/conf/zoo_sample.cfg
-zookeeper/lib/cobertura/README.txt
-zookeeper/lib/jdiff/zookeeper_3.1.1.xml
-zookeeper/lib/jdiff/zookeeper_3.3.6.xml
-zookeeper/lib/jline-0.9.94.LICENSE.txt
-zookeeper/lib/jline-0.9.94.jar
-zookeeper/lib/log4j-1.2.15.LICENSE.txt
-zookeeper/lib/log4j-1.2.15.jar
-zookeeper/zookeeper-%%PORTVERSION%%.jar
-%%WITH_C%%@dirrm include/c-client-src
-@dirrm zookeeper/lib/jdiff
-@dirrm zookeeper/lib/cobertura
-@dirrm zookeeper/lib
-@dirrmtry zookeeper/conf
-@dirrm zookeeper/bin
-@dirrmtry zookeeper
+%%PORTNAME%%/bin/zkCleanup.sh
+%%PORTNAME%%/bin/zkCli.sh
+%%PORTNAME%%/bin/zkEnv.sh
+%%PORTNAME%%/bin/zkServer.sh
+%%PORTNAME%%/conf/configuration.xsl
+%%PORTNAME%%/conf/log4j.properties
+%%PORTNAME%%/conf/zoo_sample.cfg
+%%PORTNAME%%/lib/cobertura/README.txt
+%%PORTNAME%%/lib/jdiff/%%PORTNAME%%_3.1.1.xml
+%%PORTNAME%%/lib/jdiff/%%PORTNAME%%_3.4.6.xml
+%%PORTNAME%%/lib/jdiff/%%PORTNAME%%_%%PORTVERSION%%-SNAPSHOT.xml
+%%PORTNAME%%/lib/jline-0.9.94.LICENSE.txt
+%%PORTNAME%%/lib/jline-0.9.94.jar
+%%PORTNAME%%/lib/log4j-1.2.16.LICENSE.txt
+%%PORTNAME%%/lib/log4j-1.2.16.jar
+%%PORTNAME%%/lib/netty-3.7.0.Final.jar
+%%PORTNAME%%/lib/slf4j-api-1.6.1.jar
+%%PORTNAME%%/lib/slf4j-log4j12-1.6.1.jar
+%%PORTNAME%%/%%PORTNAME%%-%%PORTVERSION%%.jar
+@dirrm %%PORTNAME%%/lib/jdiff
+@dirrm %%PORTNAME%%/lib/cobertura
+@dirrm %%PORTNAME%%/lib
+@dirrm %%PORTNAME%%/bin
+@dirrmtry %%PORTNAME%%/conf
+@dirrmtry %%PORTNAME%%
+@cwd /
+@dirrmtry var/log/%%PORTNAME%%
+@dirrmtry var/run/%%PORTNAME%%
+@cwd %%RESETPREFIX%%