aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-04-05 21:43:59 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-04-05 21:43:59 +0800
commitd3a1a4ca90af8ad81373b7848342f7da7fb19141 (patch)
treeaf4c61f3f0d0fa508756151b17d92e5d8506270a
parenta7d9e0e6fc0809381722bd06ce9fc46f7b25d6da (diff)
downloadfreebsd-ports-gnome-d3a1a4ca90af8ad81373b7848342f7da7fb19141.tar.gz
freebsd-ports-gnome-d3a1a4ca90af8ad81373b7848342f7da7fb19141.tar.zst
freebsd-ports-gnome-d3a1a4ca90af8ad81373b7848342f7da7fb19141.zip
Plack handler to run PSGI apps on AnyEvent::HTTPD.
WWW: http://search.cpan.org/dist/Plack-Handler-AnyEvent-HTTPD/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile28
-rw-r--r--www/p5-Plack-Handler-AnyEvent-HTTPD/distinfo3
-rw-r--r--www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-descr3
-rw-r--r--www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1e1a5933eaf3..16bd7f1f0318 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1087,6 +1087,7 @@
SUBDIR += p5-Path-Class-URI
SUBDIR += p5-Plack
SUBDIR += p5-Plack-App-Proxy
+ SUBDIR += p5-Plack-Handler-AnyEvent-HTTPD
SUBDIR += p5-Plack-Handler-AnyEvent-ReverseHTTP
SUBDIR += p5-Plack-Middleware-Auth-Digest
SUBDIR += p5-Plack-Middleware-AutoRefresh
diff --git a/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile b/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile
new file mode 100644
index 000000000000..39b95ec68d7c
--- /dev/null
+++ b/www/p5-Plack-Handler-AnyEvent-HTTPD/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Plack::Handler::AnyEvent::HTTPD
+# Date created: 05 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Handler-AnyEvent-HTTPD
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for Plack handler to run PSGI apps on AnyEvent::HTTPD
+
+RUN_DEPENDS= \
+ p5-AnyEvent-HTTPD>0:${PORTSDIR}/www/p5-AnyEvent-HTTPD \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Plack>=0.9903:${PORTSDIR}/www/p5-Plack \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Handler::AnyEvent::HTTPD.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-Handler-AnyEvent-HTTPD/distinfo b/www/p5-Plack-Handler-AnyEvent-HTTPD/distinfo
new file mode 100644
index 000000000000..609d19fdec74
--- /dev/null
+++ b/www/p5-Plack-Handler-AnyEvent-HTTPD/distinfo
@@ -0,0 +1,3 @@
+MD5 (Plack-Handler-AnyEvent-HTTPD-0.01.tar.gz) = 69345129213ccb32297a33bf6cec0c32
+SHA256 (Plack-Handler-AnyEvent-HTTPD-0.01.tar.gz) = b5fb6b1b89681e7e86e741c05eac36864f72857b71194a63473c2838dfe3ca22
+SIZE (Plack-Handler-AnyEvent-HTTPD-0.01.tar.gz) = 43305
diff --git a/www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-descr b/www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-descr
new file mode 100644
index 000000000000..327a9f9b000e
--- /dev/null
+++ b/www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-descr
@@ -0,0 +1,3 @@
+Plack handler to run PSGI apps on AnyEvent::HTTPD.
+
+WWW: http://search.cpan.org/dist/Plack-Handler-AnyEvent-HTTPD/
diff --git a/www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-plist b/www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-plist
new file mode 100644
index 000000000000..fb310dcf5a8f
--- /dev/null
+++ b/www/p5-Plack-Handler-AnyEvent-HTTPD/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler/AnyEvent/HTTPD/.packlist
+%%SITE_PERL%%/Plack/Handler/AnyEvent/HTTPD.pm
+@dirrmtry %%SITE_PERL%%/Plack/Handler/AnyEvent
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler/AnyEvent/HTTPD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler/AnyEvent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler