aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-10-24 18:52:07 +0800
committerStanislav Sedov <stas@FreeBSD.org>2009-10-24 18:52:07 +0800
commitd4693481b1b12982a3168c95d39dac84ece5cf07 (patch)
tree4f662bd7635659f150ffede1b75ad4cdc99d834c
parent13e5aaa5677f813dcdd31b5028b7874fc53151eb (diff)
downloadfreebsd-ports-gnome-d4693481b1b12982a3168c95d39dac84ece5cf07.tar.gz
freebsd-ports-gnome-d4693481b1b12982a3168c95d39dac84ece5cf07.tar.zst
freebsd-ports-gnome-d4693481b1b12982a3168c95d39dac84ece5cf07.zip
- Fix issue when the handle of tempfile become closed when the file
was unlinked (see http://redmine.ruby-lang.org/issues/show/1494#note-10). - Bump PORTREVISION. PR: ports/139862 Submitted by: Ari Maniatis <ari@ish.com.au> Obtained from: Ruby SVN
-rw-r--r--Mk/bsd.ruby.mk2
-rw-r--r--lang/ruby19/files/patch-tempfile.rb10
2 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 927694d6bd64..858422e20fda 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -198,7 +198,7 @@ RUBY19= "@comment "
# Ruby 1.9
#
RUBY_RELVERSION= 1.9.1
-RUBY_PORTREVISION= 1
+RUBY_PORTREVISION= 2
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 243
diff --git a/lang/ruby19/files/patch-tempfile.rb b/lang/ruby19/files/patch-tempfile.rb
new file mode 100644
index 000000000000..196f01e417d4
--- /dev/null
+++ b/lang/ruby19/files/patch-tempfile.rb
@@ -0,0 +1,10 @@
+--- lib/tempfile.rb.orig 2009-07-15 21:57:41.000000000 +1000
++++ lib/tempfile.rb 2009-10-23 21:31:49.159715744 +1100
+@@ -137,7 +137,6 @@
+ # keep this order for thread safeness
+ begin
+ if File.exist?(@tmpname)
+- closed? or close
+ File.unlink(@tmpname)
+ end
+ @@cleanlist.delete(@tmpname)