aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-14 22:34:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-14 22:34:49 +0800
commitd4a21dd670d631810223f17515eca0c8733aad76 (patch)
treefb59b5964c0c8fe977de4e611bed53ba8b55c331
parentc5521b98835459fdb9aff3b7d33abbff2a69d11b (diff)
downloadfreebsd-ports-gnome-d4a21dd670d631810223f17515eca0c8733aad76.tar.gz
freebsd-ports-gnome-d4a21dd670d631810223f17515eca0c8733aad76.tar.zst
freebsd-ports-gnome-d4a21dd670d631810223f17515eca0c8733aad76.zip
- Use USES=gmake
- Convert to new LIB_DEPENDS format
-rw-r--r--textproc/p5-XML-Xerces/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/textproc/p5-XML-Xerces/Makefile b/textproc/p5-XML-Xerces/Makefile
index 02d8fa152707..5930369ad394 100644
--- a/textproc/p5-XML-Xerces/Makefile
+++ b/textproc/p5-XML-Xerces/Makefile
@@ -12,17 +12,16 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-0
MAINTAINER= perl@FreeBSD.org
COMMENT= The Perl API to the Apache project's Xerces XML parser
-BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
-LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= libxerces-c.so.27:${PORTSDIR}/textproc/xerces-c2
MAKE_JOBS_UNSAFE= yes
-USE_GMAKE= yes
-USES= perl5
+USES= gmake perl5
USE_PERL5= configure
CONFIGURE_ENV= XERCES_LIB="${LOCALBASE}/lib" \
XERCES_INCLUDE="${LOCALBASE}/include" \
XERCES_DEVEL="yes" \
- CXX="${CXX}" \
+ CXX="${CXX}"
.include <bsd.port.mk>