aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2014-11-24 06:31:25 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2014-11-24 06:31:25 +0800
commitd4ed81b80b462ceb619f5689eb2de34285599957 (patch)
tree2b18bec968292b0a3dbce845907c5e91a7988f45
parentcbc1f058e60fa5241f848df04b6f3cba840a26cb (diff)
downloadfreebsd-ports-gnome-d4ed81b80b462ceb619f5689eb2de34285599957.tar.gz
freebsd-ports-gnome-d4ed81b80b462ceb619f5689eb2de34285599957.tar.zst
freebsd-ports-gnome-d4ed81b80b462ceb619f5689eb2de34285599957.zip
Set perl5 as a build-only dependency.
-rw-r--r--lang/erlang-runtime15/Makefile3
-rw-r--r--lang/erlang-runtime16/Makefile3
-rw-r--r--lang/erlang-runtime17/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index cbc88883c412..8f7bec3f6410 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erlang
PORTVERSION= 15.b.03.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -46,6 +46,7 @@ ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
USES= gmake perl5
USE_AUTOTOOLS= autoconf:env
+USE_PERL5= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index 24fdce3514e9..124fbac2ea8f 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erlang
PORTVERSION= 16.b.03.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -46,6 +46,7 @@ ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
USES= gmake perl5
USE_AUTOTOOLS= autoconf:env
+USE_PERL5= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 63b36ce80ea0..2a9dcc81a482 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erlang
PORTVERSION= 17.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -46,6 +46,7 @@ ERL_RELEASE= ${PORTVERSION}
USES= gmake perl5
USE_AUTOTOOLS= autoconf:env
+USE_PERL5= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib