aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-07-26 03:09:50 +0800
committerswills <swills@FreeBSD.org>2018-07-26 03:09:50 +0800
commitd5136ca55a5eb2457c6c905866019b29bfb9b7c3 (patch)
treedb93df9d838577d0df3c7d8be599bb158944b6f8
parent7939d41d21eb2b8c462c81603bb2c589841a575a (diff)
downloadfreebsd-ports-gnome-d5136ca55a5eb2457c6c905866019b29bfb9b7c3.tar.gz
freebsd-ports-gnome-d5136ca55a5eb2457c6c905866019b29bfb9b7c3.tar.zst
freebsd-ports-gnome-d5136ca55a5eb2457c6c905866019b29bfb9b7c3.zip
security/py-fail2ban: Fix writing /etc/hosts.deny entries
PR: 227577 Submitted by: theis@gmx.at (maintainer) Reported by: Niels Bakker <niels=freebsd@bakker.net>
-rw-r--r--security/py-fail2ban/Makefile1
-rw-r--r--security/py-fail2ban/files/patch-config_action.d_hostsdeny.conf30
2 files changed, 31 insertions, 0 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 6c3c5b27d447..34bbcacef3f9 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fail2ban
PORTVERSION= 0.10.3.1
+PORTREVISION= 1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/files/patch-config_action.d_hostsdeny.conf b/security/py-fail2ban/files/patch-config_action.d_hostsdeny.conf
new file mode 100644
index 000000000000..c89474e85962
--- /dev/null
+++ b/security/py-fail2ban/files/patch-config_action.d_hostsdeny.conf
@@ -0,0 +1,30 @@
+--- config/action.d/hostsdeny.conf.orig 2018-04-18 16:05:22.844045000 +0200
++++ config/action.d/hostsdeny.conf 2018-04-18 16:06:30.930069000 +0200
+@@ -31,7 +31,7 @@
+ # Tags: See jail.conf(5) man page
+ # Values: CMD
+ #
+-actionban = printf %%b "<daemon_list>: <_ip_value>\n" >> <file>
++actionban = printf %%b "<daemon_list>: <ip_value>\n" >> <file>
+
+ # Option: actionunban
+ # Notes.: command executed when unbanning an IP. Take care that the
+@@ -39,7 +39,7 @@
+ # Tags: See jail.conf(5) man page
+ # Values: CMD
+ #
+-actionunban = IP=$(echo "<_ip_value>" | sed 's/[][\.]/\\\0/g') && sed -i "/^<daemon_list>: $IP$/d" <file>
++actionunban = IP=$(echo "<ip_value>" | /usr/bin/sed 's/\([][\.]\)/\\\1/g') && /usr/bin/sed -i "" "/^<daemon_list>: $IP$/d" <file>
+
+ [Init]
+
+@@ -56,7 +56,7 @@
+ daemon_list = ALL
+
+ # internal variable IP (to differentiate the IPv4 and IPv6 syntax, where it is enclosed in brackets):
+-_ip_value = <ip>
++ip_value = <ip>
+
+ [Init?family=inet6]
+-_ip_value = [<ip>]
++ip_value = [<ip>]