aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2005-05-17 11:27:42 +0800
committervanilla <vanilla@FreeBSD.org>2005-05-17 11:27:42 +0800
commitd51e857e4d863b0f9bf2cbee6fa0403cce8a7cff (patch)
tree490b6f588cb4e69903b5b5a32268a7650d92bac8
parent9523f81d86c12e115015b5f114404ddce037c7fe (diff)
downloadfreebsd-ports-gnome-d51e857e4d863b0f9bf2cbee6fa0403cce8a7cff.tar.gz
freebsd-ports-gnome-d51e857e4d863b0f9bf2cbee6fa0403cce8a7cff.tar.zst
freebsd-ports-gnome-d51e857e4d863b0f9bf2cbee6fa0403cce8a7cff.zip
- Update to 0.94.11
- Change knobs to OPTIONS - Update pkg-plist - Update Berkeley DB to 4.3 - Add support to Sqlite 3 PR: ports/80920 Submitted by: Marcus Grando <marcus@corp.grupos.comdotbr>
-rw-r--r--mail/bogofilter-current/Makefile105
-rw-r--r--mail/bogofilter-current/distinfo4
-rw-r--r--mail/bogofilter-current/files/ChangeLog.port36
-rw-r--r--mail/bogofilter-current/pkg-install2
-rw-r--r--mail/bogofilter-current/pkg-plist4
5 files changed, 65 insertions, 86 deletions
diff --git a/mail/bogofilter-current/Makefile b/mail/bogofilter-current/Makefile
index ae24f262d9c3..1de6a259f14c 100644
--- a/mail/bogofilter-current/Makefile
+++ b/mail/bogofilter-current/Makefile
@@ -6,41 +6,71 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.92.8
-PORTREVISION?= 1
-CATEGORIES?= mail
+PORTVERSION= 0.94.11
+CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -current
-MAINTAINER?= matthias.andree@gmx.de
+MAINTAINER= marcus@corp.grupos.com.br
COMMENT= "Fast, teachable, learning spam detector"
-LIB_DEPENDS?= db-4.2:${PORTSDIR}/databases/db42
-.if !defined(WITHOUT_GSL)
-LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
-.endif
-.if !defined(WITHOUT_BASH)
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
-.endif
-
-CONFLICTS?= bogofilter-tdb-[0-9]* bogofilter-qdbm-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
+CONFLICTS?= bogofilter-tdb-[0-9]* bogofilter-qdbm-[0-9]* [a-z][a-z]-bogofilter-[0-9]* \
+ bogofilter-[0-9]*
USE_BZIP2= yes
USE_REINPLACE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
-PATCH_STRIP= -p1
+
+OPTIONS= DB43 "Use Berkeley DB 4.3 backend" on \
+ TDB "Use TDB backend" off \
+ SQLITE3 "Use SQLITE 3 backend" off \
+ GSL "Use GSL library" on \
+ BASH "Include BASH Scripts" on \
+
+.include <bsd.port.pre.mk>
+
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-.if defined(WITHOUT_GSL)
+CONFIGURE_TARGET+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+INSTALL_TARGET= install-strip prefix=${PREFIX}
+
+MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
+
+.if !defined(WITHOUT_DB43)
+LIB_DEPENDS+= db-4.3:${PORTSDIR}/databases/db43
+CONFIGURE_ARGS+= --with-database=db
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/db43" LDFLAGS="-L${LOCALBASE}/lib/db43"
+.if defined(WITH_TDB) || defined(WITH_SQLITE3)
+BROKEN= "Please select only one DB"
+.endif
+.endif
+
+.if defined(WITH_TDB)
+LIB_DEPENDS+= tdb.1:${PORTSDIR}/databases/tdb
+CONFIGURE_ARGS+= --with-database=tdb
+.if !defined(WITHOUT_DB43) || defined(WITH_SQLITE3)
+BROKEN= "Please select only one DB"
+.endif
+.endif
+
+.if defined(WITH_SQLITE3)
+LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+CONFIGURE_ARGS+= --with-database=sqlite
+.if !defined(WITHOUT_DB43) || defined(WITH_TDB)
+BROKEN= "Please select only one DB"
+.endif
+.endif
+
+.if !defined(WITHOUT_GSL)
+LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
CONFIGURE_ARGS+= --with-included-gsl
.endif
-CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db42" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-ldb-4.2"
-CONFIGURE_ENV+= PERL="${PERL}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALL_TARGET= install-strip prefix=${PREFIX}
-MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
+.if !defined(WITHOUT_BASH)
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
+.endif
post-patch:
${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
@@ -58,23 +88,6 @@ post-patch:
PORTDOCS= *
.endif
-pre-everything::
- @${ECHO_CMD} ""
-.if !defined(WITHOUT_BASH)
- @${ECHO_CMD} "To install without bash dependency, you can use: make -DWITHOUT_BASH install"
- @${ECHO_CMD} "Note that installing without bash dependency will mean that some of the"
- @${ECHO_CMD} "${DOCSDIR}/contrib scripts will not be installed."
- @${ECHO_CMD} ""
-.endif
-.if !defined(WITHOUT_GSL)
- @${ECHO_CMD} "To have bogofilter link against its shipped GSL 1.4 statically,"
- @${ECHO_CMD} "you can use: make -DWITHOUT_GSL && make -DWITHOUT_GSL install"
-.if !defined(WITHOUT_BASH)
- @${ECHO_CMD} "or: make -DWITHOUT_GSL && make -DWITHOUT_GSL -DWITHOUT_BASH install"
-.endif
- @${ECHO_CMD} ""
-.endif
-
post-build::
cd ${WRKSRC} && make check SHELL=${SH}
@@ -85,18 +98,17 @@ post-install::
@${MKDIR} ${DOCSDIR}/${i}
.endfor
.for i in AUTHORS COPYING INSTALL NEWS README README.cvs \
- doc/README.validation TODO \
- CHANGES-* RELEASE.NOTES-* \
- doc/integrating-with-postfix doc/integrating-with-qmail \
- doc/bogofilter-tuning.HOWTO.html doc/bogofilter-SA-2002-01 \
- doc/README.tdb
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ doc/README.validation TODO RELEASE.NOTES GETTING.STARTED \
+ doc/integrating-with-postfix doc/integrating-with-qmail \
+ doc/bogofilter-tuning.HOWTO.html doc/bogofilter-SA-2002-01 \
+ doc/README.tdb
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/trio/AUTHORS ${DOCSDIR}/AUTHORS.trio
.for i in contrib/bogo.R contrib/bogofilter-qfe \
contrib/mime.get.rfc822 contrib/printmaildir.pl \
contrib/bogominitrain.pl contrib/README.contrib
- ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
.for i in contrib/dot-qmail-bogofilter-default
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
@@ -105,7 +117,6 @@ post-install::
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
${INSTALL_DATA} ${WRKSRC}/doc/*.xml ${DOCSDIR}/xml
${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
- ${INSTALL_DATA} ${FILESDIR}/ChangeLog.port ${DOCSDIR}
.endif
.if !defined(WITHOUT_BASH)
.for i in randomtrain scramble trainbogo.sh
@@ -115,4 +126,4 @@ post-install::
.endif
${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/bogofilter-current/distinfo b/mail/bogofilter-current/distinfo
index e1e0683058c1..d4a80c635128 100644
--- a/mail/bogofilter-current/distinfo
+++ b/mail/bogofilter-current/distinfo
@@ -1,2 +1,2 @@
-MD5 (bogofilter-0.92.8.tar.bz2) = dac06b6afcab0e36d17b1604216dc9bf
-SIZE (bogofilter-0.92.8.tar.bz2) = 637420
+MD5 (bogofilter-0.94.11.tar.bz2) = 89d9fe3f46c310fd7a436e69e2c0a0f3
+SIZE (bogofilter-0.94.11.tar.bz2) = 715241
diff --git a/mail/bogofilter-current/files/ChangeLog.port b/mail/bogofilter-current/files/ChangeLog.port
deleted file mode 100644
index 44cc11bb1025..000000000000
--- a/mail/bogofilter-current/files/ChangeLog.port
+++ /dev/null
@@ -1,36 +0,0 @@
-FreeBSD's port ChangeLog for mail/bogofilter
-------------------------
-
-0.92.7, 0.92.6, 0.92.5, 0.92.4
-- just building new upstream versions
-
-0.92.3
-- regression tests for %A, %I and %Q revised
-- internal cleanups
-- no longer depend on a particular gsl version, to avoid chasing the
- GSL library after future GSL updates
-
-0.92.2
-- drop patch-ac, merged upstream
-- %I is now really the Message-ID
-- %Q is the queue idea
-- %A is the message injector's IP address
-
-2004-07-07
-- add patch-ac to fix bogus test failure in bogofilter-tdb and bogofilter-qdbm
-
-0.92.1
-- pick up bugfixes, dropping patch-aa and patch-ab from 0.92.0_1
-- update GSL dependency to gsl.6 (GNU GSL v1.5)
-
-0.92.0_1
-- [patch-ab] fix SIGSEGV (NULL dereferenced pointer read) when %I is used
- and no IP address had been found (reported by Clemens Fischer)
-
-- [patch-aa] fix data base shutdown in multiple-wordlists mode
- when BOGOFILTER_CONCURRENT_DATA_STORE is set in the environment
-
-0.92.0
-- update to next stable release 0.92.0
-
--- Matthias Andree <matthias.andree@gmx.de>, port maintainer
diff --git a/mail/bogofilter-current/pkg-install b/mail/bogofilter-current/pkg-install
index c1fe0fc37f03..ff8e56e0cac8 100644
--- a/mail/bogofilter-current/pkg-install
+++ b/mail/bogofilter-current/pkg-install
@@ -5,7 +5,7 @@ cat - <<_EOF
The recent bogofilter versions have undergone substantial changes that can
affect compatibility and may require that you change your configuration.
-See the RELEASE.NOTES-* files that shipped with bogofilter for details.
+See the RELEASE.NOTES files that shipped with bogofilter for details.
--------------------------------------------------------------------------
_EOF
diff --git a/mail/bogofilter-current/pkg-plist b/mail/bogofilter-current/pkg-plist
index d82888eb7797..cdfeeddebeeb 100644
--- a/mail/bogofilter-current/pkg-plist
+++ b/mail/bogofilter-current/pkg-plist
@@ -1,3 +1,7 @@
+bin/bf_compact
+bin/bf_copy
+bin/bf_resize
+bin/bf_tar
bin/bogofilter
bin/bogolexer
bin/bogotune