aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2014-02-12 14:50:55 +0800
committerrm <rm@FreeBSD.org>2014-02-12 14:50:55 +0800
commitd53b03d585e3dfe1a11094623c66423b05da5dc9 (patch)
tree8fd75cb551e95f3961f7e32f034d8d445e7c7ca5
parent60175364374791804aa2663491b0b8ae78277b07 (diff)
downloadfreebsd-ports-gnome-d53b03d585e3dfe1a11094623c66423b05da5dc9.tar.gz
freebsd-ports-gnome-d53b03d585e3dfe1a11094623c66423b05da5dc9.tar.zst
freebsd-ports-gnome-d53b03d585e3dfe1a11094623c66423b05da5dc9.zip
- update to 0.8.8
while here: - fix submission a bit (include back qore-modules) - fix build with clang - support staging PR: 186496 Submitted by: Brett Estrade <estrabd@gmail.com> (maintainer)
-rw-r--r--lang/qore/Makefile7
-rw-r--r--lang/qore/distinfo4
-rw-r--r--lang/qore/files/patch-include__qore__common.h10
-rw-r--r--lang/qore/pkg-descr2
-rw-r--r--lang/qore/pkg-plist26
5 files changed, 36 insertions, 13 deletions
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
index 013a99238bf7..a82d5be993f0 100644
--- a/lang/qore/Makefile
+++ b/lang/qore/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= qore
-PORTVERSION= 0.8.7
+PORTVERSION= 0.8.8
CATEGORIES= lang
MASTER_SITES= SF/qore/qore/${PORTVERSION}/
@@ -16,8 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/bison:${PORTSDIR}/devel/bison
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pathfix iconv
+USES= gmake iconv pathfix
USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -28,10 +27,8 @@ CONFIGURE_ENV= LEX="${LOCALBASE}/bin/flex" \
CONFIGURE_ARGS= --disable-debug --disable-static --with-doxygen=no
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= qore.1
PLIST_SUB= PORTVERSION=${PORTVERSION}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "powerpc"
diff --git a/lang/qore/distinfo b/lang/qore/distinfo
index d2623d6d2e8c..9d994eb883e2 100644
--- a/lang/qore/distinfo
+++ b/lang/qore/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qore-0.8.7.tar.bz2) = 314c8c2a9394e8b366c8268183af959349b8d5eca0fcc456108a9efa71786ee7
-SIZE (qore-0.8.7.tar.bz2) = 8128234
+SHA256 (qore-0.8.8.tar.bz2) = d099bd7d14751a8d9529937116e0170b26dd431996b86bf2aa9568b661f89111
+SIZE (qore-0.8.8.tar.bz2) = 14351424
diff --git a/lang/qore/files/patch-include__qore__common.h b/lang/qore/files/patch-include__qore__common.h
new file mode 100644
index 000000000000..99aceee462ab
--- /dev/null
+++ b/lang/qore/files/patch-include__qore__common.h
@@ -0,0 +1,10 @@
+--- ./include/qore/common.h.orig 2013-10-03 11:33:33.000000000 +0400
++++ ./include/qore/common.h 2014-02-12 02:20:02.000000000 +0400
+@@ -33,6 +33,7 @@
+ #include <strings.h>
+ #include <stdarg.h>
+ #include <stddef.h>
++#include <stdlib.h>
+
+ #include <string>
+ #include <functional>
diff --git a/lang/qore/pkg-descr b/lang/qore/pkg-descr
index 00d07e3add13..bdb3be836353 100644
--- a/lang/qore/pkg-descr
+++ b/lang/qore/pkg-descr
@@ -1,4 +1,4 @@
Qore is a dynamically-typed, embeddabble programming
language designed for SMP scalability.
-WWW: http://www.qore.org
+WWW: http://www.qore.org/
diff --git a/lang/qore/pkg-plist b/lang/qore/pkg-plist
index e4264c2a95d4..a73f9a149253 100644
--- a/lang/qore/pkg-plist
+++ b/lang/qore/pkg-plist
@@ -73,17 +73,33 @@ include/qore/qore_bitopts.h
include/qore/qore_thread.h
include/qore/safe_dslist
include/qore/support.h
+include/qore/QoreHttpClientObject.h
+include/qore/QoreSocketObject.h
+include/qore/qlist
lib/libqore.la
lib/libqore.so
-lib/libqore.so.15
+lib/libqore.so.16
+lib/qore-modules/%%PORTVERSION%%/CsvUtil.qm
lib/qore-modules/%%PORTVERSION%%/HttpServer.qm
-lib/qore-modules/%%PORTVERSION%%/SmtpClient.qm
-lib/qore-modules/%%PORTVERSION%%/Mime.qm
-lib/qore-modules/%%PORTVERSION%%/TelnetClient.qm
lib/qore-modules/%%PORTVERSION%%/MailMessage.qm
+lib/qore-modules/%%PORTVERSION%%/Mime.qm
+lib/qore-modules/%%PORTVERSION%%/MysqlSqlUtil.qm
+lib/qore-modules/%%PORTVERSION%%/OracleSqlUtil.qm
+lib/qore-modules/%%PORTVERSION%%/PgsqlSqlUtil.qm
lib/qore-modules/%%PORTVERSION%%/Pop3Client.qm
-lib/qore-modules/%%PORTVERSION%%/CsvUtil.qm
+lib/qore-modules/%%PORTVERSION%%/Qorize.qm
+lib/qore-modules/%%PORTVERSION%%/RestClient.qm
+lib/qore-modules/%%PORTVERSION%%/RestHandler.qm
+lib/qore-modules/%%PORTVERSION%%/SmtpClient.qm
+lib/qore-modules/%%PORTVERSION%%/SqlUtil.qm
+lib/qore-modules/%%PORTVERSION%%/TelnetClient.qm
+lib/qore-modules/%%PORTVERSION%%/Util.qm
+lib/qore-modules/%%PORTVERSION%%/WebSocketClient.qm
+lib/qore-modules/%%PORTVERSION%%/WebSocketHandler.qm
+lib/qore-modules/%%PORTVERSION%%/WebSocketUtil.qm
+lib/qore-modules/%%PORTVERSION%%/WebUtil.qm
libdata/pkgconfig/qore.pc
+man/man1/qore.1.gz
@dirrm include/qore
@dirrm lib/qore-modules/%%PORTVERSION%%
@dirrm lib/qore-modules