aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 23:04:14 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 23:04:14 +0800
commitd5571d2d6e939f96ccb317684b6aa7dcf0638914 (patch)
treeff100abe9310b2e9b2e7badf6181bca5090f5ae6
parenta70fbd478088db66384055f0e1706858bbd85fba (diff)
downloadfreebsd-ports-gnome-d5571d2d6e939f96ccb317684b6aa7dcf0638914.tar.gz
freebsd-ports-gnome-d5571d2d6e939f96ccb317684b6aa7dcf0638914.tar.zst
freebsd-ports-gnome-d5571d2d6e939f96ccb317684b6aa7dcf0638914.zip
Support stage
-rw-r--r--math/ruby-numru_units/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/math/ruby-numru_units/Makefile b/math/ruby-numru_units/Makefile
index 7905fd68dda5..ae3031a9cce2 100644
--- a/math/ruby-numru_units/Makefile
+++ b/math/ruby-numru_units/Makefile
@@ -14,7 +14,9 @@ DIST_SUBDIR= ruby
MAINTAINER= murashin@gfd-dennou.org
COMMENT= A class to handle units of physical quantities for Ruby
-LICENSE= BSD
+OPTIONS_DEFINE= DOCS
+
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USE_RUBY= yes
@@ -22,16 +24,11 @@ NO_BUILD= yes
DOCS= ChangeLog LICENSE.txt doc/units.html doc/units.rd
-NO_STAGE= yes
do-install:
- @cd ${WRKSRC}/ && ${RUBY} ./install.rb
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
+ @cd ${WRKSRC}/ && ${RUBY} ./install.rb -d ${STAGEDIR}${RUBY_SITELIBDIR}
+ @${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}
.endfor
-.endif
.include <bsd.port.mk>