aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-08-13 01:22:56 +0800
committerpi <pi@FreeBSD.org>2017-08-13 01:22:56 +0800
commitd6ac31025129e19bbe7f0514fb0a8c28357b8074 (patch)
tree62ca9595bea19f3ff612051d3bec6db1fc20e6ce
parent151a0f778c2bdd3cc841135c71a3728ad4f2f284 (diff)
downloadfreebsd-ports-gnome-d6ac31025129e19bbe7f0514fb0a8c28357b8074.tar.gz
freebsd-ports-gnome-d6ac31025129e19bbe7f0514fb0a8c28357b8074.tar.zst
freebsd-ports-gnome-d6ac31025129e19bbe7f0514fb0a8c28357b8074.zip
math/dynare: added patches I missed in last commit
PR: 221316 Submitted by: Fernando Apesteguia <fernando.apesteguia@gmail.com> (maintainer)
-rw-r--r--math/dynare/Makefile2
-rw-r--r--math/dynare/files/patch-dynare++_kord_journal.cweb53
-rw-r--r--math/dynare/files/patch-dynare++_parser_cc_parser__exception.h10
-rw-r--r--math/dynare/files/patch-mex_build_octave_configure11
4 files changed, 75 insertions, 1 deletions
diff --git a/math/dynare/Makefile b/math/dynare/Makefile
index 46cf84969c1d..916fd4670036 100644
--- a/math/dynare/Makefile
+++ b/math/dynare/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dynare
PORTVERSION= 4.4.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= math
MASTER_SITES= http://www.dynare.org/release/source/
diff --git a/math/dynare/files/patch-dynare++_kord_journal.cweb b/math/dynare/files/patch-dynare++_kord_journal.cweb
new file mode 100644
index 000000000000..084946197a47
--- /dev/null
+++ b/math/dynare/files/patch-dynare++_kord_journal.cweb
@@ -0,0 +1,53 @@
+--- dynare++/kord/journal.cweb.orig 2013-11-08 16:37:59 UTC
++++ dynare++/kord/journal.cweb
+@@ -5,6 +5,8 @@
+ @c
+ #include "journal.h"
+ #include "kord_exception.h"
++#include <sys/types.h>
++#include <sys/sysctl.h>
+
+ #if !defined(__MINGW32__)
+ # include <sys/resource.h>
+@@ -72,7 +74,16 @@ long int SystemResources::onlineProcesso
+ @<|SystemResources::availableMemory| code@>=
+ long int SystemResources::availableMemory()
+ {
+- return pageSize()*sysconf(_SC_AVPHYS_PAGES);
++ long value;
++ size_t len;
++ char *path = "vm.stats.vm.v_free_count";
++
++ if (sysctlbyname(path, &value, &len, NULL, 0) == -1) {
++ return (-1);
++ }
++
++
++ return pageSize() * value;
+ }
+
+ @ Here we read the current values of resource usage. For MinGW, we
+@@ -84,6 +95,10 @@ void SystemResources::getRUS(double& loa
+ long int& idrss, long int& majflt)
+ {
+ struct timeval now;
++ long value;
++ size_t len;
++ char *path = "vm.stats.vm.v_free_count";
++
+ gettimeofday(&now, NULL);
+ elapsed = now.tv_sec-start.tv_sec + (now.tv_usec-start.tv_usec)*1.0e-6;
+
+@@ -107,7 +122,11 @@ void SystemResources::getRUS(double& loa
+ load_avg = -1.0;
+ #endif
+
+- pg_avail = sysconf(_SC_AVPHYS_PAGES);
++ if (sysctlbyname(path, &value, &len, NULL, 0) == -1) {
++ pg_avail = -1;
++ }
++
++ pg_avail = value;
+ }
+
+ @
diff --git a/math/dynare/files/patch-dynare++_parser_cc_parser__exception.h b/math/dynare/files/patch-dynare++_parser_cc_parser__exception.h
new file mode 100644
index 000000000000..03374438410f
--- /dev/null
+++ b/math/dynare/files/patch-dynare++_parser_cc_parser__exception.h
@@ -0,0 +1,10 @@
+--- dynare++/parser/cc/parser_exception.h.orig 2013-11-08 16:37:59 UTC
++++ dynare++/parser/cc/parser_exception.h
+@@ -6,6 +6,7 @@
+ #define OG_FORMULA_PARSER_H
+
+ #include <string>
++#include <stdio.h>
+
+ namespace ogp {
+ using std::string;
diff --git a/math/dynare/files/patch-mex_build_octave_configure b/math/dynare/files/patch-mex_build_octave_configure
new file mode 100644
index 000000000000..60ea228e4121
--- /dev/null
+++ b/math/dynare/files/patch-mex_build_octave_configure
@@ -0,0 +1,11 @@
+--- mex/build/octave/configure.orig 2014-07-31 12:31:10 UTC
++++ mex/build/octave/configure
+@@ -7076,7 +7076,7 @@ if ${ac_cv_lib_umfpack_umfpack_dl_defaul
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lumfpack $LIBS"
++LIBS="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+