aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-09-14 11:10:59 +0800
committeryuri <yuri@FreeBSD.org>2018-09-14 11:10:59 +0800
commitd6bc90dbd7b7bc979bf88037f04a1a46e8ca3c9c (patch)
tree7e402c159d0199596d45899c2b782e77f2bcd276
parentd82a17e38959531a5ebb65146c10b7065998040b (diff)
downloadfreebsd-ports-gnome-d6bc90dbd7b7bc979bf88037f04a1a46e8ca3c9c.tar.gz
freebsd-ports-gnome-d6bc90dbd7b7bc979bf88037f04a1a46e8ca3c9c.tar.zst
freebsd-ports-gnome-d6bc90dbd7b7bc979bf88037f04a1a46e8ca3c9c.zip
New port: science/py-molmod: Collection of molecular modelling tools for python
-rw-r--r--science/Makefile1
-rw-r--r--science/py-molmod/Makefile28
-rw-r--r--science/py-molmod/distinfo3
-rw-r--r--science/py-molmod/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index ace772c91dec..6c03b6cbab4d 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -209,6 +209,7 @@
SUBDIR += py-mdp
SUBDIR += py-mlpy
SUBDIR += py-mmtf-python
+ SUBDIR += py-molmod
SUBDIR += py-netCDF4
SUBDIR += py-obspy
SUBDIR += py-openpiv
diff --git a/science/py-molmod/Makefile b/science/py-molmod/Makefile
new file mode 100644
index 000000000000..975c1fb89cf5
--- /dev/null
+++ b/science/py-molmod/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= molmod
+DISTVERSION= 1.4.4
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collection of molecular modelling tools for python
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
+
+USES= python shebangfix
+SHEBANG_GLOB= *.py
+USE_PYTHON= distutils cython cython_run autoplist
+
+do-test: # Tests fail: https://github.com/molmod/molmod/issues/27
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} nosetests-${PYTHON_VER} -v molmod
+
+.include <bsd.port.mk>
diff --git a/science/py-molmod/distinfo b/science/py-molmod/distinfo
new file mode 100644
index 000000000000..3a3f259cad29
--- /dev/null
+++ b/science/py-molmod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536893478
+SHA256 (molmod-1.4.4.tar.gz) = ca0e461fe42fc8b7e0b481cda33aac247d86b5fb817b5076e20abc90dd577797
+SIZE (molmod-1.4.4.tar.gz) = 1692687
diff --git a/science/py-molmod/pkg-descr b/science/py-molmod/pkg-descr
new file mode 100644
index 000000000000..391394ea753e
--- /dev/null
+++ b/science/py-molmod/pkg-descr
@@ -0,0 +1,4 @@
+MolMod is a collection of molecular modelling tools for python. It is used by
+other software developed at the CMM, including Yaff, TAMkin and Zeobuilder.
+
+WWW: https://github.com/molmod/molmod