diff options
author | bdrewery <bdrewery@FreeBSD.org> | 2014-11-03 04:01:31 +0800 |
---|---|---|
committer | bdrewery <bdrewery@FreeBSD.org> | 2014-11-03 04:01:31 +0800 |
commit | d6eb88969e348e9b6127a63f6dab4d2ff6e34f5a (patch) | |
tree | fff6797e92d48b34bf98661d511e5bfa6e44715b | |
parent | eaac974dfb471f8653eda7827b8b6f32d5932792 (diff) | |
download | freebsd-ports-gnome-d6eb88969e348e9b6127a63f6dab4d2ff6e34f5a.tar.gz freebsd-ports-gnome-d6eb88969e348e9b6127a63f6dab4d2ff6e34f5a.tar.zst freebsd-ports-gnome-d6eb88969e348e9b6127a63f6dab4d2ff6e34f5a.zip |
- Enable SSP by default.
This is the culmination of years of work and testing including work by jlh@.
This will enable SSP by default for all amd64 releases, and i386 releases
10.0 and over.
With hat: portmgr
Tested by: multiple exp-runs, CFT package repository, CFT ports
Discussed with: bapt, antoine
-rw-r--r-- | CHANGES | 8 | ||||
-rw-r--r-- | Mk/bsd.port.mk | 7 | ||||
-rw-r--r-- | Mk/bsd.ssp.mk | 2 |
3 files changed, 13 insertions, 4 deletions
@@ -10,6 +10,14 @@ in the release notes and/or placed into UPDATING. All ports committers are allowed to commit to this file. +20141102: +AUTHOR: bdrewery@FreeBSD.org + + SSP is now default. This can be disabled with WITHOUT_SSP. + SSP_CFLAGS defaults to -fstack-protector. + SSP will be used on all amd64 releases. It will only be used on i386 + releases over 10.0. + 20141007: AUTHOR: mat@FreeBSD.org diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk index bcd1ef6ac109..84d38c2fb0a1 100644 --- a/Mk/bsd.port.mk +++ b/Mk/bsd.port.mk @@ -317,8 +317,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org # # WITH_DEBUG_PORTS - A list of origins for which WITH_DEBUG will be set # -# WITH_SSP_PORTS -# - If set, SSP_FLAGS (defaults to -fstack-protector) +# WITHOUT_SSP - Disable SSP. +# +# SSP_CFLAGS - Defaults to -fstack-protector. This value # is added to CFLAGS and the necessary flags # are added to LDFLAGS. Note that SSP_UNSAFE # can be used in Makefiles by port maintainers @@ -1636,7 +1637,7 @@ INSTALL_TARGET:= ${INSTALL_TARGET:S/^install-strip$/install/g} .endif .endif -.if defined(WITH_SSP) || defined(WITH_SSP_PORTS) +.if !defined(WITHOUT_SSP) .include "${PORTSDIR}/Mk/bsd.ssp.mk" .endif diff --git a/Mk/bsd.ssp.mk b/Mk/bsd.ssp.mk index a62f898a82f7..5e944c0e0b21 100644 --- a/Mk/bsd.ssp.mk +++ b/Mk/bsd.ssp.mk @@ -16,7 +16,7 @@ SSP_UNSAFE= yes SSP_NEED_NONSHARED= yes .endif -.if !defined(WITHOUT_SSP) && !defined(SSP_UNSAFE) && \ +.if !defined(SSP_UNSAFE) && \ (${ARCH} == i386 || ${ARCH} == amd64) # Overridable as a user may want to use -fstack-protector-all SSP_CFLAGS?= -fstack-protector |