aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-01-10 01:30:33 +0800
committerSteve Wills <swills@FreeBSD.org>2012-01-10 01:30:33 +0800
commitd796409950e3be0bf88ae7f30455fa2392e064c9 (patch)
treedd67c4d2c0450e28eebe22f4437305768ebc4aeb
parentc207bf6a9aa0be8b9c4ad135521f42ae96e863c7 (diff)
downloadfreebsd-ports-gnome-d796409950e3be0bf88ae7f30455fa2392e064c9.tar.gz
freebsd-ports-gnome-d796409950e3be0bf88ae7f30455fa2392e064c9.tar.zst
freebsd-ports-gnome-d796409950e3be0bf88ae7f30455fa2392e064c9.zip
- Add missing BUILD_DEPENDS and RUN_DEPENDS so the module works
- Add TEST_DEPENDS to enable testing
-rw-r--r--www/p5-Catalyst-Controller-HTML-FormFu/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/p5-Catalyst-Controller-HTML-FormFu/Makefile b/www/p5-Catalyst-Controller-HTML-FormFu/Makefile
index b3a6bd0aabf4..e3da27426e9d 100644
--- a/www/p5-Catalyst-Controller-HTML-FormFu/Makefile
+++ b/www/p5-Catalyst-Controller-HTML-FormFu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Catalyst-Controller-HTML-FormFu
PORTVERSION= 0.09003
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,12 +19,16 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= p5-Catalyst-Action-RenderView>=0:${PORTSDIR}/www/p5-Catalyst-Action-RenderView \
+ p5-Catalyst-Component-InstancePerContext>=0:${PORTSDIR}/www/p5-Catalyst-Component-InstancePerContext \
p5-Catalyst-Plugin-ConfigLoader>=0.23:${PORTSDIR}/www/p5-Catalyst-Plugin-ConfigLoader \
p5-Catalyst-Plugin-Session>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
p5-Catalyst-Plugin-Session-State-Cookie>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session-State-Cookie \
p5-Catalyst-Plugin-Session-Store-File>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session-Store-File \
p5-Catalyst-View-TT>=0:${PORTSDIR}/www/p5-Catalyst-View-TT \
p5-Config-General>=0:${PORTSDIR}/devel/p5-Config-General \
+ p5-HTML-FormFu>=0.09:${PORTSDIR}/www/p5-HTML-FormFu \
+ p5-MooseX-ChainedAccessors>=0.02:${PORTSDIR}/devel/p5-MooseX-ChainedAccessors \
+ p5-Regexp-Assemble>=0:${PORTSDIR}/devel/p5-Regexp-Assemble \
p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS= p5-Catalyst-Component-InstancePerContext>=0:${PORTSDIR}/www/p5-Catalyst-Component-InstancePerContext \
p5-Catalyst-Runtime>=5.71001:${PORTSDIR}/www/p5-Catalyst-Runtime \
@@ -31,10 +36,13 @@ RUN_DEPENDS= p5-Catalyst-Component-InstancePerContext>=0:${PORTSDIR}/www/p5-Cata
p5-HTML-FormFu>=0.09:${PORTSDIR}/www/p5-HTML-FormFu \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-ChainedAccessors>=0.02:${PORTSDIR}/devel/p5-MooseX-ChainedAccessors \
+ p5-PathTools>=3.12:${PORTSDIR}/devel/p5-PathTools \
p5-Regexp-Assemble>=0:${PORTSDIR}/devel/p5-Regexp-Assemble \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
-TEST_DEPENDS= p5-Test-WWW-Mechanize>=1.16:${PORTSDIR}/devel/p5-Test-WWW-Mechanize \
+TEST_DEPENDS= p5-Test-Simple>=0.92:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-WWW-Mechanize>=1.16:${PORTSDIR}/devel/p5-Test-WWW-Mechanize \
p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst
PERL_CONFIGURE= yes