aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-07-15 02:01:46 +0800
committersobomax <sobomax@FreeBSD.org>2003-07-15 02:01:46 +0800
commitd7b627f0b1817dd9c75f2391628281429b1d9a16 (patch)
tree4cd5ae949f81fd43d55cadcfbc30575d64169ec5
parentf3a9c245cbaa6bc4d2471076d72e907d139a2ba2 (diff)
downloadfreebsd-ports-gnome-d7b627f0b1817dd9c75f2391628281429b1d9a16.tar.gz
freebsd-ports-gnome-d7b627f0b1817dd9c75f2391628281429b1d9a16.tar.zst
freebsd-ports-gnome-d7b627f0b1817dd9c75f2391628281429b1d9a16.zip
Fix auto-kill option.
PR: 49733 Submitted by: Yoshiyuki NAKAMICHI <nakamiti-sendpr@emergence.jp>
-rw-r--r--net/linphone-base/Makefile2
-rw-r--r--net/linphone-base/files/patch-coreapi::misc.c34
-rw-r--r--net/linphone/Makefile2
-rw-r--r--net/linphone/files/patch-coreapi::misc.c34
4 files changed, 44 insertions, 28 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index cc0c9c2bf586..0abc569ad603 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linphone
PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://simon.morlat.free.fr/download/${PORTVERSION}/source/
diff --git a/net/linphone-base/files/patch-coreapi::misc.c b/net/linphone-base/files/patch-coreapi::misc.c
index 0f778af50c58..dfeef28b9376 100644
--- a/net/linphone-base/files/patch-coreapi::misc.c
+++ b/net/linphone-base/files/patch-coreapi::misc.c
@@ -1,15 +1,23 @@
-$FreeBSD$
+
---- coreapi/misc.c 2003/06/13 12:59:10 1.1
-+++ coreapi/misc.c 2003/06/13 12:59:39
-@@ -249,8 +249,7 @@
- hints.ai_family = PF_UNSPEC;
- hints.ai_flags = AI_NUMERICHOST;
- getaddrinfo(lc->net_conf.sel_if->ipaddr, NULL, &hints, &res);
-- if ( (strcmp(lc->net_conf.sel_if->ipaddr,"127.0.0.1")!=0)
-- && !IN6_IS_ADDR_LINKLOCAL(res->ai_addr) && !IN6_IS_ADDR_LOOPBACK(res->ai_addr))
-+ if ( (strcmp(lc->net_conf.sel_if->ipaddr,"127.0.0.1")!=0))
- #else
- if (strcmp(lc->net_conf.sel_if->ip4addr,"127.0.0.1")!=0)
- #endif
+--- coreapi/misc.c.orig Wed Mar 12 09:52:05 2003
++++ coreapi/misc.c Wed Mar 12 09:52:39 2003
+@@ -87,7 +87,7 @@
+ pid_t pid;
+
+ /* try to kill all artsd*/
+- command=g_strdup_printf("ps -u %s |grep artsd",getenv("LOGNAME"));
++ command=g_strdup_printf("ps -c %s |grep artsd",getenv("LOGNAME"));
+ out=popen(command,"r");
+ if (out!=NULL)
+ {
+@@ -102,7 +102,7 @@
+ }
+ g_free(command);
+ /* do the same with esd*/
+- command=g_strdup_printf("ps -u %s |grep esd",getenv("LOGNAME"));
++ command=g_strdup_printf("ps -c %s |grep esd",getenv("LOGNAME"));
+ out=popen(command,"r");
+ if (out!=NULL)
+ {
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index cc0c9c2bf586..0abc569ad603 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linphone
PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://simon.morlat.free.fr/download/${PORTVERSION}/source/
diff --git a/net/linphone/files/patch-coreapi::misc.c b/net/linphone/files/patch-coreapi::misc.c
index 0f778af50c58..dfeef28b9376 100644
--- a/net/linphone/files/patch-coreapi::misc.c
+++ b/net/linphone/files/patch-coreapi::misc.c
@@ -1,15 +1,23 @@
-$FreeBSD$
+
---- coreapi/misc.c 2003/06/13 12:59:10 1.1
-+++ coreapi/misc.c 2003/06/13 12:59:39
-@@ -249,8 +249,7 @@
- hints.ai_family = PF_UNSPEC;
- hints.ai_flags = AI_NUMERICHOST;
- getaddrinfo(lc->net_conf.sel_if->ipaddr, NULL, &hints, &res);
-- if ( (strcmp(lc->net_conf.sel_if->ipaddr,"127.0.0.1")!=0)
-- && !IN6_IS_ADDR_LINKLOCAL(res->ai_addr) && !IN6_IS_ADDR_LOOPBACK(res->ai_addr))
-+ if ( (strcmp(lc->net_conf.sel_if->ipaddr,"127.0.0.1")!=0))
- #else
- if (strcmp(lc->net_conf.sel_if->ip4addr,"127.0.0.1")!=0)
- #endif
+--- coreapi/misc.c.orig Wed Mar 12 09:52:05 2003
++++ coreapi/misc.c Wed Mar 12 09:52:39 2003
+@@ -87,7 +87,7 @@
+ pid_t pid;
+
+ /* try to kill all artsd*/
+- command=g_strdup_printf("ps -u %s |grep artsd",getenv("LOGNAME"));
++ command=g_strdup_printf("ps -c %s |grep artsd",getenv("LOGNAME"));
+ out=popen(command,"r");
+ if (out!=NULL)
+ {
+@@ -102,7 +102,7 @@
+ }
+ g_free(command);
+ /* do the same with esd*/
+- command=g_strdup_printf("ps -u %s |grep esd",getenv("LOGNAME"));
++ command=g_strdup_printf("ps -c %s |grep esd",getenv("LOGNAME"));
+ out=popen(command,"r");
+ if (out!=NULL)
+ {