aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-09-25 04:55:01 +0800
committerohauer <ohauer@FreeBSD.org>2012-09-25 04:55:01 +0800
commitd80afa5e36c55e83de58fd8f2bff1059b9a15daa (patch)
tree002bf6e0f9e61f8e33052eb665b1ef0837b1d210
parenta35a73c92132743fd5df545427f4964010c0e6da (diff)
downloadfreebsd-ports-gnome-d80afa5e36c55e83de58fd8f2bff1059b9a15daa.tar.gz
freebsd-ports-gnome-d80afa5e36c55e83de58fd8f2bff1059b9a15daa.tar.zst
freebsd-ports-gnome-d80afa5e36c55e83de58fd8f2bff1059b9a15daa.zip
- USE_APACHE s/22+/22/
some additional cleanups/fixes - adopt new Makefile header - convert to optionsNG - use BROKEN instead IGNORE in bsd.apache.mk with hat apache@
-rw-r--r--Mk/bsd.apache.mk2
-rw-r--r--www/mod_amazon_proxy/Makefile8
-rw-r--r--www/mod_asn/Makefile8
-rw-r--r--www/mod_dnssd/Makefile2
-rw-r--r--www/mod_fcgid/Makefile8
-rw-r--r--www/mod_log_mysql/Makefile8
-rw-r--r--www/mod_pagespeed/Makefile8
-rw-r--r--www/mod_perl2/Makefile5
-rw-r--r--www/mod_spdy/Makefile8
-rw-r--r--www/mod_vhost_ldap/Makefile8
-rw-r--r--www/mod_whatkilledus/Makefile8
-rw-r--r--www/mod_xml2enc/Makefile10
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile18
13 files changed, 35 insertions, 66 deletions
diff --git a/Mk/bsd.apache.mk b/Mk/bsd.apache.mk
index c725fffbd932..0a87f6162359 100644
--- a/Mk/bsd.apache.mk
+++ b/Mk/bsd.apache.mk
@@ -310,7 +310,7 @@ _APACHE_VERSION_NONSUPPORTED= ${_APACHE_VERSION_MAXIMUM} at most
. endif
. if defined(_APACHE_VERSION_NONSUPPORTED) && !defined(AP_IGNORE_VERSION_CHECK)
-IGNORE= ${_ERROR_MSG} apache${_APACHE_VERSION} is installed (or APACHE_PORT is defined) and port requires apache${_APACHE_VERSION_NONSUPPORTED}
+BROKEN= ${_ERROR_MSG} apache${_APACHE_VERSION} is installed (or APACHE_PORT is defined) and port requires apache${_APACHE_VERSION_NONSUPPORTED}
. endif
.else # defined(_APACHE_VERSION)
. for ver in ${APACHE_SUPPORTED_VERSION}
diff --git a/www/mod_amazon_proxy/Makefile b/www/mod_amazon_proxy/Makefile
index acfc273760c5..67b6104693e6 100644
--- a/www/mod_amazon_proxy/Makefile
+++ b/www/mod_amazon_proxy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_amazon_proxy
-# Date created: 2011-09-24
-# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
-#
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mod_amazon_proxy
PORTVERSION= 20100913
@@ -16,7 +12,7 @@ COMMENT= Amazon Auth Proxy for Product Advertising API
LIB_DEPENDS= apreq2:${PORTSDIR}/www/libapreq2
-USE_APACHE= 22+
+USE_APACHE= 22
CONFFILE= httpd-amazon-proxy.conf
CONFDIR= ${PREFIX}/${APACHEETCDIR}/Includes
diff --git a/www/mod_asn/Makefile b/www/mod_asn/Makefile
index b86e94d3652a..93dc603c2d91 100644
--- a/www/mod_asn/Makefile
+++ b/www/mod_asn/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_asn
-# Date created: 24 Apr 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
+# Created by: Jun Kuriyama <kuriyama@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mod_asn
PORTVERSION= 1.5
@@ -17,7 +13,7 @@ COMMENT= Look up the AS and network prefix of IP address
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1
-USE_APACHE= 22+
+USE_APACHE= 22
AP_FAST_BUILD= yes
MANUAL_PACKAGE_BUILD= devel/apr1 with pgsql option required
diff --git a/www/mod_dnssd/Makefile b/www/mod_dnssd/Makefile
index b0994be59946..769870e7cafd 100644
--- a/www/mod_dnssd/Makefile
+++ b/www/mod_dnssd/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= avahi-client.3:${PORTSDIR}/net/avahi-app
MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
-USE_APACHE= 22+
+USE_APACHE= 22
GNU_CONFIGURE= yes
CONFIGURE_ENV= APR_CFLAGS="`${LOCALBASE}/bin/apr-1-config --cflags --cppflags --includes`" \
APR_LIBS="`${LOCALBASE}/bin/apr-1-config --ldflags`"
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index d8ae582aca4f..4e05b15d6da9 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_fcgid for Apache2
-# Date created: 13 August 2004
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= mod_fcgid
PORTVERSION= 2.3.6
@@ -32,7 +28,7 @@ PLIST_SUB+= APACHEMODDIR=${APACHEMODDIR}
MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION} -I${LOCALBASE}/include/apr-1"
INSTALL_TARGET= install-modules-yes
-DOCSDIR= ${PREFIX}/share/doc/apache22/mod
+DOCSDIR= ${PREFIX}/share/doc/apache${APACHE_VERSION}/mod
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/mod_log_mysql/Makefile b/www/mod_log_mysql/Makefile
index 9211e5d2d173..2886ac822915 100644
--- a/www/mod_log_mysql/Makefile
+++ b/www/mod_log_mysql/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_mod_mysql
-# Date created: Sun May 2 2004
-# Whom: Clement Laforet <clement@FreeBSD.org>
-#
+# Created by: Clement Laforet <clement@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mod_log_mysql
PORTVERSION= 1.0
@@ -25,7 +21,7 @@ RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_log_config-st.so:${PORTSDIR}/www/
MAKE_JOBS_SAFE= yes
-USE_APACHE= 22+
+USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
USE_MYSQL= yes
diff --git a/www/mod_pagespeed/Makefile b/www/mod_pagespeed/Makefile
index 5629c1a878c5..0cbbc3afc870 100644
--- a/www/mod_pagespeed/Makefile
+++ b/www/mod_pagespeed/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_pagespeed
-# Date created: 2011-09-27
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mod_pagespeed
PORTVERSION= 0.10.22.6
@@ -29,7 +25,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
USE_XZ= yes
USE_BINUTILS= yes
-USE_APACHE= 22+
+USE_APACHE= 22
USE_PYTHON= 2.6+
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 12a04014bbd1..cf5108ad19c4 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -65,10 +65,13 @@ MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
.include <bsd.port.pre.mk>
+.if ${APACHE_VERSION} > 22
+BROKEN= Does not build with apache24
+.endif
+
# Using apxs in this way is problematic if apache2 is installed under a
# different PREFIX than mod_perl2, because the mod_perl2 installation will
# use paths returned by apxs to install some components. Fixes welcome.
-#CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs PREFIX=${PREFIX}
CONFIGURE_ARGS= PREFIX=${PREFIX} MP_APXS=${APXS} MP_APR_CONFIG=${LOCALBASE}/bin/apr-1-config
.if exists(${LOCALBASE}/include/apr-1/apr.h)
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 878892efac50..f8825b37d2e6 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_spdy
-# Date created: 1 April 2012
-# Whom: Masaki TAGAWA
-#
+# Created by: Masaki TAGAWA
# $FreeBSD$
-#
PORTNAME= mod_spdy
PORTVERSION= 0.9.3.2
@@ -28,7 +24,7 @@ BUILD_DEPENDS= greadlink:${PORTSDIR}/sysutils/coreutils \
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
USE_XZ= yes
-USE_APACHE= 22+
+USE_APACHE= 22
USE_PYTHON= 2.6+
USE_GMAKE= yes
ONLY_FOR_ARCHS= amd64 i386
diff --git a/www/mod_vhost_ldap/Makefile b/www/mod_vhost_ldap/Makefile
index 4ec5929caea1..fa19564654ba 100644
--- a/www/mod_vhost_ldap/Makefile
+++ b/www/mod_vhost_ldap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_vhost_ldap
-# Date created: Sep 10 2005
-# Whom: Clement Laforet <clement@FreeBSD.org>
-#
+# Created by: Clement Laforet <clement@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mod_vhost_ldap
PORTVERSION= 1.0
@@ -21,7 +17,7 @@ MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
USE_OPENLDAP= yes
-USE_APACHE= 22+
+USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
AP_LIB+= ${LOCALBASE}/lib -lldap
diff --git a/www/mod_whatkilledus/Makefile b/www/mod_whatkilledus/Makefile
index eb24c5af5304..f89d8893d3d3 100644
--- a/www/mod_whatkilledus/Makefile
+++ b/www/mod_whatkilledus/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_whatkilledus
-# Date created: Thu Nov 4 10:08:27 CET 2010
-# Whom: Frank Wall <fw@moov.de>
-#
+# Created by: Frank Wall <fw@moov.de>
# $FreeBSD$
-#
PORTNAME= mod_whatkilledus
PORTVERSION= 2.0
@@ -19,7 +15,7 @@ COMMENT= Logs a report when a child process crashes
MAKE_JOBS_SAFE= yes
MANUAL_PACKAGE_BUILD= yes
-USE_APACHE= 22+
+USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SHORTMODNAME= whatkilledus
diff --git a/www/mod_xml2enc/Makefile b/www/mod_xml2enc/Makefile
index 3cadf519eb82..5a64147d4776 100644
--- a/www/mod_xml2enc/Makefile
+++ b/www/mod_xml2enc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_xml2enc
-# Date created: 02 March 2011
-# Whom: Marin Atanasov Nikolov <dnaeon@gmail.com>
-#
+# Created by: Marin Atanasov Nikolov <dnaeon@gmail.com>
# $FreeBSD$
-#
PORTNAME= mod_xml2enc
PORTVERSION= 1.0.3
@@ -17,7 +13,9 @@ COMMENT= Apache module for converting encoding before and/or after a filter run
MAKE_JOBS_SAFE= yes
-USE_APACHE= 22+
+# included in apache24
+# http://httpd.apache.org/docs/2.4/mod/mod_xml2enc.html
+USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SHORTMODNAME= xml2enc
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index c73cd11c8c4c..ed72f2550ca2 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: CGI-SpeedyCGI
-# Date created: Sun Mar 10 16:44:06 CET 2002
-# Whom: Lars Thegler <lars@thegler.dk>
-#
+# Created by: Lars Thegler <lars@thegler.dk>
# $FreeBSD$
-#
PORTNAME= CGI-SpeedyCGI
PORTVERSION= 2.22
@@ -18,18 +14,22 @@ COMMENT= Speed up perl CGI scripts by running them persistently
MAKE_JOBS_UNSAFE= yes
PERL_CONFIGURE= yes
-OPTIONS= APACHE "Enable mod_speedycgi" On
+OPTIONS_DEFINE= APACHE
+OPTIONS_DEFAULT=APACHE
+APACHE_DESC= Build mod_speedycgi
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_APACHE)
-USE_APACHE= 22+
+.if ${PORT_OPTIONS:MAPACHE}
+USE_APACHE= 22
PLIST_SUB+= APACHE=""
.else
PLIST_SUB+= APACHE="@comment "
CONFIGURE_ENV+= WITHOUT_APACHE=yes
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
@${PERL} -pi -e 's,apxs -q,${APXS} -q,;' \
${WRKSRC}/src/SpeedyMake.pl