diff options
author | sem <sem@FreeBSD.org> | 2004-12-07 04:47:17 +0800 |
---|---|---|
committer | sem <sem@FreeBSD.org> | 2004-12-07 04:47:17 +0800 |
commit | d8397355c975d6205f0e57ad26ede1a6b80e4de4 (patch) | |
tree | 8b62fcd7903221f77ffc505ce8834e46fdbc1d79 | |
parent | fca982e719e9ca78a4ef1189201dd88ec389eda7 (diff) | |
download | freebsd-ports-gnome-d8397355c975d6205f0e57ad26ede1a6b80e4de4.tar.gz freebsd-ports-gnome-d8397355c975d6205f0e57ad26ede1a6b80e4de4.tar.zst freebsd-ports-gnome-d8397355c975d6205f0e57ad26ede1a6b80e4de4.zip |
A command line idea encryption and decryption utility written by
Dr. Richard De Moliner.
Permission by the Author Dr. Richard De Moliner has been granted.
PR: ports/72337
Submitted by: Emanuel Haupt <ehaupt@critical.ch>
-rw-r--r-- | LEGAL | 2 | ||||
-rw-r--r-- | security/Makefile | 1 | ||||
-rw-r--r-- | security/idea/Makefile | 48 | ||||
-rw-r--r-- | security/idea/distinfo | 2 | ||||
-rw-r--r-- | security/idea/pkg-descr | 11 | ||||
-rw-r--r-- | security/idea/pkg-message | 11 | ||||
-rw-r--r-- | security/idea/pkg-plist | 6 |
7 files changed, 81 insertions, 0 deletions
@@ -279,6 +279,8 @@ ICON-Slick.* ports/x11-themes/gnome-icons-slick Author rights unclear ICON-Snow-Apple.* ports/x11-themes/gnome-icons-snow-apple Author rights unclear ICON-Stylish.* ports/x11-themes/gnome-icons-stylish Author rights unclear ICON-Ximian-South-* ports/x11-themes/gnome-icons-ximian-south Author rights unclear +idea.V*.tar.Z ports/security/idea a patented algorithm that + requires proper licensing idled-*.tar.gz ports/sysutils/idled non-profit use and distribution only invitationtoruby.tgz ports/devel/invitation_to_ruby no commercial use diff --git a/security/Makefile b/security/Makefile index 65466ba80b7b..84c776fe547f 100644 --- a/security/Makefile +++ b/security/Makefile @@ -132,6 +132,7 @@ SUBDIR += hpn-ssh SUBDIR += hunch SUBDIR += hydra + SUBDIR += idea SUBDIR += ident2 SUBDIR += identify SUBDIR += ifd-devkit diff --git a/security/idea/Makefile b/security/idea/Makefile new file mode 100644 index 000000000000..9f9efb6e3aac --- /dev/null +++ b/security/idea/Makefile @@ -0,0 +1,48 @@ +# New ports collection makefile for: idea +# Date created: 4 September 2004 +# Whom: Emanuel Haupt <ehaupt@critical.ch> +# +# $FreeBSD$ +# + +PORTNAME= idea +PORTVERSION= 1.2 +CATEGORIES= security +MASTER_SITES= http://www.funet.fi/pub/org/CERT/ftp.cert.dfn.de/pub/tools/crypt/idea/ \ + http://www.de-moliner.ch/richard/downloads/ \ + http://ftp.at.linuxfromscratch.org/infosys/security/dfn/tools/crypt/idea/ +DISTNAME= ${PORTNAME}.V${PORTVERSION} +EXTRACT_SUFX= .tar.Z + +MAINTAINER= ehaupt@critical.ch +COMMENT= A command line idea encryption and decryption utility + +RESTRICTED= "Crypto; IDEA is a patented algorithm that requires proper licensing" + +WRKSRC= ${WRKDIR}/${PORTNAME} + +MANL= idea.l +MANCOMPRESSED= no + +.if !defined(MAKE_IDEA) || ${MAKE_IDEA} == "no" || ${MAKE_IDEA} == "NO" +IGNORE= "you chose not to use idea related code" +.endif + +do-build: + ${CC} ${WRKSRC}/idea.c ${WRKSRC}/idea_cmd.c ${CFLAGS} -o ${WRKSRC}/${PORTNAME} + +do-install: + ${INSTALL_MAN} ${WRKSRC}/manl/idea.l ${PREFIX}/man/manl + ${INSTALL_PROGRAM} -m 0555 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin + @${MKDIR} ${EXAMPLESDIR} + ${INSTALL_DATA} ${WRKSRC}/Examples ${EXAMPLESDIR} + +.if !defined(NOPORTDOCS) + ${MKDIR} ${DOCSDIR} + ${INSTALL_DATA} ${WRKSRC}/byte_ord.ps ${WRKSRC}/idea_cmd.txt ${DOCSDIR} +.endif + +post-install: + @${CAT} ${PKGMESSAGE} + +.include <bsd.port.mk> diff --git a/security/idea/distinfo b/security/idea/distinfo new file mode 100644 index 000000000000..86249bccbb38 --- /dev/null +++ b/security/idea/distinfo @@ -0,0 +1,2 @@ +MD5 (idea.V1.2.tar.Z) = 2aacefa036c7df2144ae8aa5a0e413fe +SIZE (idea.V1.2.tar.Z) = 142835 diff --git a/security/idea/pkg-descr b/security/idea/pkg-descr new file mode 100644 index 000000000000..de3650577aed --- /dev/null +++ b/security/idea/pkg-descr @@ -0,0 +1,11 @@ +A command line idea encryption and decryption utility written by +Dr. Richard De Moliner. + +IDEA (International Data Encryption Algorithm) is a block cipher devel- +oped by Dr. Xuejia Lai and Prof. Dr. J. L. Massey at the Swiss Federal +Institute of Technology. + +WWW: http://www.de-moliner.ch/richard/ + +- ehaupt +ehaupt@critical.ch diff --git a/security/idea/pkg-message b/security/idea/pkg-message new file mode 100644 index 000000000000..73ef78ae5e65 --- /dev/null +++ b/security/idea/pkg-message @@ -0,0 +1,11 @@ +========================================================================== + +IDEA is registered as the international patent WO 91/18459 "Device for +Converting a Digital Block and the Use thereof". For commercial use of +IDEA, one should contact + +ASCOM TECH AG +Freiburgstrasse 370 +CH-3018 Bern, Switzerland + +========================================================================== diff --git a/security/idea/pkg-plist b/security/idea/pkg-plist new file mode 100644 index 000000000000..caec515e858c --- /dev/null +++ b/security/idea/pkg-plist @@ -0,0 +1,6 @@ +bin/idea +%%PORTDOCS%%%%DOCSDIR%%/idea_cmd.txt +%%PORTDOCS%%%%DOCSDIR%%/byte_ord.ps +%%EXAMPLESDIR%%/Examples +%%PORTDOCS%%@dirrm %%DOCSDIR%% +@dirrm %%EXAMPLESDIR%% |