aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-09-17 21:34:41 +0800
committerMathieu Arnold <mat@FreeBSD.org>2014-09-17 21:34:41 +0800
commitd85123353f5e33268dd689184394193259f17880 (patch)
treea81275677c90d0e9b4dab0c24e9deaa24f5fb508
parent6cf5fa4d5bb89ff8dbf73661ba5e3b1bf12e5d43 (diff)
downloadfreebsd-ports-gnome-d85123353f5e33268dd689184394193259f17880.tar.gz
freebsd-ports-gnome-d85123353f5e33268dd689184394193259f17880.tar.zst
freebsd-ports-gnome-d85123353f5e33268dd689184394193259f17880.zip
Update to USES=python, and use correct depends style for python packages.
Sponsored by: Absolight
-rw-r--r--dns/bind10/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/dns/bind10/Makefile b/dns/bind10/Makefile
index 39d4be191be1..6d0b3286468b 100644
--- a/dns/bind10/Makefile
+++ b/dns/bind10/Makefile
@@ -20,21 +20,20 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= ${LOCALBASE}/include/boost/interprocess/sync/interprocess_upgradable_mutex.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/log4cplus/logger.h:${PORTSDIR}/devel/log4cplus \
sqlite3>=3.3.9:${PORTSDIR}/databases/sqlite3 \
- ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
LIB_DEPENDS= libbotan-1.10.so:${PORTSDIR}/security/botan110 \
liblog4cplus.so:${PORTSDIR}/devel/log4cplus \
libicuuc.so:${PORTSDIR}/devel/icu \
libgmp.so:${PORTSDIR}/math/gmp \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
-RUN_DEPENDS= ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
DEPRECATED= Is not developed any more, use dns/bundy
EXPIRATION_DATE= 2015-12-31
-USE_PYTHON= 3
USE_OPENSSL= yes
USE_LDCONFIG= yes
-USES= compiler:c++11-lang pathfix pkgconfig
+USES= compiler:c++11-lang pathfix pkgconfig python:3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \