aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2010-08-02 14:15:08 +0800
committerhrs <hrs@FreeBSD.org>2010-08-02 14:15:08 +0800
commitd905fd5460edc03a3930887e7c62ea345b61b7f0 (patch)
tree683296e19d45107409c5a9d4cbca201f98b44eb7
parent0810ec06b84674880fad90a0280ddb8ee5bdea9e (diff)
downloadfreebsd-ports-gnome-d905fd5460edc03a3930887e7c62ea345b61b7f0.tar.gz
freebsd-ports-gnome-d905fd5460edc03a3930887e7c62ea345b61b7f0.tar.zst
freebsd-ports-gnome-d905fd5460edc03a3930887e7c62ea345b61b7f0.zip
- Fix compile errors when vgalib and lvga256 drivers are enabled.
- Use external libraries instead of bundled old ones[1]. - Fix WITHOUT_FOO handling[2]. Submitted by: mi[1], dinoex[2] PR: ports/126513 PR: ports/148960
-rw-r--r--print/ghostscript8/Makefile13
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post8
-rw-r--r--print/ghostscript8/files/patch-base-configure.ac20
-rw-r--r--print/ghostscript8/files/patch-base-gdevl256.c17
-rw-r--r--print/ghostscript8/files/patch-base-gdevvglb.c17
-rw-r--r--print/ghostscript8/files/patch-base-sjpx.c36
6 files changed, 99 insertions, 12 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 209eb6863e0b..80523a5f5cda 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript8
PORTVERSION= 8.71
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= http://ghostscript.com/releases/:gs_srcs \
SF/ghostscript/files/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -18,13 +18,16 @@ DISTNAME= ${PORTNAME:S,8$,,}-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:gs_srcs ${EPAG_SRCS}:epag
DIST_SUBDIR= ${PORTNAME:S,8$,,}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+EXTRACT_AFTER_ARGS= | ${TAR} -xpf - ${EXCLUDE_DIRS:S/^/--exclude /}
MAINTAINER= doceng@FreeBSD.org
COMMENT= Ghostscript 8.x PostScript interpreter
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
+ jasper:${PORTSDIR}/graphics/jasper \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME:S,8,,}/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
CONFLICTS= gambc-[0-9]* ghostscript7-[0-9]* ghostscript7-*-[0-9]*
@@ -33,6 +36,7 @@ USE_XZ= yes
USE_GMAKE= yes
WANT_GNOME= yes
USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf:262
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
@@ -80,6 +84,7 @@ MLINKS= gslp.1 gsbj.1 \
ps2ps.1 eps2eps.1
CIDFONTDIR= ${DATADIR}/${PORTVERSION}/Resource
+EXCLUDE_DIRS= jpeg expat jasper libpng tiff zlib
.include "Makefile.drivers"
.include <bsd.port.pre.mk>
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index 20634c5c43d5..226b26fa36fc 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -59,7 +59,7 @@ CUPS_DEVS= cups
.undef _CUPS_DEVS
.for D in ${CUPS_DEVS}
-.if defined(WITHOUT_CUPS)
+.if defined(WITHOUT_CUPS) || defined(WITHOUT_GS_${D})
.undef WITH_GS_${D}
.elif defined(WITH_GS_${D})
_CUPS_DEVS+= ${D}
@@ -78,7 +78,7 @@ VGA_DEVS= lvga256 vgalib
.undef _VGA_DEVS
.for D in ${VGA_DEVS}
-.if defined(WITHOUT_SVGALIB)
+.if defined(WITHOUT_SVGALIB) || defined(WITHOUT_GS_${D})
.undef WITH_GS_${D}
.elif defined(WITH_GS_${D})
_VGA_DEVS+= ${D}
@@ -95,7 +95,7 @@ X11_DEVS= x11 x11alpha x11cmyk x11cmyk2 x11cmyk4 x11cmyk8 x11gray2 \
.undef _X11_DEVS
.for D in ${X11_DEVS}
-.if defined(WITHOUT_X11)
+.if defined(WITHOUT_X11) || defined(WITHOUT_GS_${D})
. undef WITH_GS_${D}
.elif defined(WITH_GS_${D})
_X11_DEVS+= ${D}
@@ -121,7 +121,7 @@ ICONV_DEVS= oprp opvp
.undef _ICONV_DEVS
.for D in ${ICONV_DEVS}
-.if defined(WITHOUT_ICONV)
+.if defined(WITHOUT_ICONV) || defined(WITHOUT_GS_${D})
.undef WITH_GS_${D}
.elif defined(WITH_GS_${D})
_ICONV_DEVS+= ${D}
diff --git a/print/ghostscript8/files/patch-base-configure.ac b/print/ghostscript8/files/patch-base-configure.ac
new file mode 100644
index 000000000000..07bc58242f70
--- /dev/null
+++ b/print/ghostscript8/files/patch-base-configure.ac
@@ -0,0 +1,20 @@
+--- base/configure.ac.orig 2010-08-01 22:37:05.000000000 +0900
++++ base/configure.ac 2010-08-01 22:41:12.000000000 +0900
+@@ -402,7 +402,7 @@
+ PNGDEVS="$PNGDEVS_ALL"
+ else
+ AC_MSG_RESULT([no])
+- AC_CHECK_LIB(png, png_check_sig, [
++ AC_CHECK_LIB(png, png_sig_cmp, [
+ AC_CHECK_HEADERS(png.h, [
+ SHARE_LIBPNG=1
+ PNGDEVS="$PNGDEVS_ALL"
+@@ -434,7 +434,7 @@
+ AC_CHECK_LIB(tiff, TIFFOpen,
+ [AC_CHECK_HEADERS(tiff.h, [HAVE_SYSTEM_LIBTIFF=1;SHARE_LIBTIFF=1])],
+ [], [-ljpeg])
+- if test -z $LOCAL_LIBTIFF_VERSION && test "x$HAVE_SYSTEM_LIBTIFF" == x; then
++ if test -z $LOCAL_LIBTIFF_VERSION && test "x$HAVE_SYSTEM_LIBTIFF" = x; then
+ AC_MSG_NOTICE([Could not find a copy of libtiff on your system.
+ Disabling tiff output devices.])
+ else
diff --git a/print/ghostscript8/files/patch-base-gdevl256.c b/print/ghostscript8/files/patch-base-gdevl256.c
index 26201906c1d4..60be4a072b51 100644
--- a/print/ghostscript8/files/patch-base-gdevl256.c
+++ b/print/ghostscript8/files/patch-base-gdevl256.c
@@ -1,5 +1,5 @@
---- base/gdevl256.c.orig Mon Jun 4 00:54:57 2007
-+++ base/gdevl256.c Mon Jun 4 01:13:56 2007
+--- base/gdevl256.c.orig 2007-09-25 22:31:24.000000000 +0900
++++ base/gdevl256.c 2010-08-01 23:05:56.000000000 +0900
@@ -143,9 +143,12 @@
/* for compatibility with the older display modes: */
/* these are indexed as 0.0.R0.G0.B0.R1.G1.B1. */
@@ -15,3 +15,16 @@
#define cv_bits(v,n) (v >> (gx_color_value_bits - n))
ushort r5 = cv_bits(r, 5), g5 = cv_bits(g, 5), b5 = cv_bits(b, 5);
static const byte cube_bits[32] =
+@@ -301,12 +304,3 @@
+ gl_line(x0, y0, x1, y1, color);
+ return 0;
+ }
+-
+-#ifdef GS_DEVS_SHARED
+-extern void gs_lib_register_device(const gx_device *dev);
+-void
+-gs_shared_init(void)
+-{
+- gs_lib_register_device(&gs_lvga256_device);
+-}
+-#endif
diff --git a/print/ghostscript8/files/patch-base-gdevvglb.c b/print/ghostscript8/files/patch-base-gdevvglb.c
index a67ad581daf5..b0f061ff3a66 100644
--- a/print/ghostscript8/files/patch-base-gdevvglb.c
+++ b/print/ghostscript8/files/patch-base-gdevvglb.c
@@ -1,5 +1,5 @@
---- base/gdevvglb.c.orig Tue Sep 25 22:31:24 2007
-+++ base/gdevvglb.c Sat Nov 24 23:00:49 2007
+--- base/gdevvglb.c.orig 2007-09-25 22:31:24.000000000 +0900
++++ base/gdevvglb.c 2010-08-01 23:08:53.000000000 +0900
@@ -149,10 +149,13 @@
}
@@ -17,3 +17,16 @@
}
static int
+@@ -368,12 +371,3 @@
+ }
+ return 0;
+ }
+-
+-#ifdef GS_DEVS_SHARED
+-extern void gs_lib_register_device(const gx_device *dev);
+-void
+-gs_shared_init(void)
+-{
+- gs_lib_register_device(&gs_vgalib_device);
+-}
+-#endif
diff --git a/print/ghostscript8/files/patch-base-sjpx.c b/print/ghostscript8/files/patch-base-sjpx.c
new file mode 100644
index 000000000000..761f1423b700
--- /dev/null
+++ b/print/ghostscript8/files/patch-base-sjpx.c
@@ -0,0 +1,36 @@
+Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
+Date: 2009-02-11
+Initial Package Version: 8.63 (well, it's needed for 8.63, obviously ex 8.61)
+Upstream Status: unknown
+Origin: fedora
+Description: Allows gnu-ghostscript to compile against external libjasper.
+ To do that, you need to remove the jasper/ directory. The included version
+is 1.701 which is somewhat old. Forward-ported to 8.64 (the structure of
+the file source tree has changed) by km.
+
+diff -Naur ghostscript-8.64.orig/base/sjpx.c ghostscript-8.64/base/sjpx.c
+--- base/sjpx.c 2008-08-21 00:22:49.000000000 +0100
++++ base/sjpx.c 2009-02-10 21:59:41.000000000 +0000
+@@ -34,14 +34,6 @@
+ private_st_jpxd_state(); /* creates a gc object for our state,
+ defined in sjpx.h */
+
+-/* error reporting callback for the jpx library */
+-static void
+-s_jpx_jas_error_cb(jas_error_t err, char *msg)
+-{
+- dprintf2("jasper (code %d) %s", (int)err, msg);
+-}
+-
+-
+ /* initialize the steam.
+ this involves allocating the stream and image structures, and
+ initializing the decoder.
+@@ -59,7 +51,6 @@
+ }
+
+ status = jas_init();
+- jas_set_error_cb(s_jpx_jas_error_cb);
+ #ifdef JPX_DEBUG
+ /* raise the error reporting threshold from the default (0) */
+ jas_setdbglevel(1);