aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2016-05-04 20:52:33 +0800
committerskreuzer <skreuzer@FreeBSD.org>2016-05-04 20:52:33 +0800
commitd989dfa69c3160a79d458f34415707ab66dc7ffa (patch)
tree4a2092e19af74cd8541a746bae0ba17ed0a5eb89
parentd0affdaf2e006272897fd76c16d8e7f41a92c46d (diff)
downloadfreebsd-ports-gnome-d989dfa69c3160a79d458f34415707ab66dc7ffa.tar.gz
freebsd-ports-gnome-d989dfa69c3160a79d458f34415707ab66dc7ffa.tar.zst
freebsd-ports-gnome-d989dfa69c3160a79d458f34415707ab66dc7ffa.zip
Add a patch to address upstream bug CFE-1803 (Storage promises do not unmount
the filesystem as promised) Reviewed by: cy@, gjb@ Approved by: cy@ Differential Revision: D6186
-rw-r--r--sysutils/cfengine38/Makefile1
-rw-r--r--sysutils/cfengine38/files/patch-cf-agent_verify__storage.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/cfengine38/Makefile b/sysutils/cfengine38/Makefile
index a4ed6dcb067b..effc5c230313 100644
--- a/sysutils/cfengine38/Makefile
+++ b/sysutils/cfengine38/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cfengine
PORTVERSION= 3.8.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://s3.amazonaws.com/cfengine-package-repos/tarballs/
diff --git a/sysutils/cfengine38/files/patch-cf-agent_verify__storage.c b/sysutils/cfengine38/files/patch-cf-agent_verify__storage.c
new file mode 100644
index 000000000000..92b02b0d08fd
--- /dev/null
+++ b/sysutils/cfengine38/files/patch-cf-agent_verify__storage.c
@@ -0,0 +1,11 @@
+--- cf-agent/verify_storage.c.orig 2016-05-03 13:42:49 UTC
++++ cf-agent/verify_storage.c
+@@ -132,7 +132,7 @@ PromiseResult VerifyStoragePromise(EvalC
+ PromiseResult result = PROMISE_RESULT_NOOP;
+
+ #ifndef __MINGW32__
+- if ((SeqLength(GetGlobalMountedFSList())) && (!LoadMountInfo(GetGlobalMountedFSList())))
++ if ((!SeqLength(GetGlobalMountedFSList())) && (!LoadMountInfo(GetGlobalMountedFSList())))
+ {
+ Log(LOG_LEVEL_ERR, "Couldn't obtain a list of mounted filesystems - aborting");
+ YieldCurrentLock(thislock);