aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-24 20:00:23 +0800
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-24 20:00:23 +0800
commitdadda5a5634a9e2ef566df4d16e655ad8eb0363e (patch)
tree53a7bb37859843794784f422c42911cc87f9e052
parentf090b6faccb6e85d71cfcc78a9cdef3e31a4728b (diff)
downloadfreebsd-ports-gnome-dadda5a5634a9e2ef566df4d16e655ad8eb0363e.tar.gz
freebsd-ports-gnome-dadda5a5634a9e2ef566df4d16e655ad8eb0363e.tar.zst
freebsd-ports-gnome-dadda5a5634a9e2ef566df4d16e655ad8eb0363e.zip
- Update to 12.5.0 [1]
- Install with ${INSTALL_*} - Remove -O from vendor ${CFLAGS} - Remove -s from vendor ${LDFLAGS} - Polish the Makefile [1]: PR: ports/87887 Submitted by: maintainer
-rw-r--r--math/mathomatic/Makefile19
-rw-r--r--math/mathomatic/distinfo4
-rw-r--r--math/mathomatic/files/patch-makefile20
3 files changed, 14 insertions, 29 deletions
diff --git a/math/mathomatic/Makefile b/math/mathomatic/Makefile
index 3c2d0515101d..69cb10d25f2a 100644
--- a/math/mathomatic/Makefile
+++ b/math/mathomatic/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mathomatic
-PORTVERSION= 12.4.11
+PORTVERSION= 12.5.0
CATEGORIES= math
MASTER_SITES= http://www.panix.com/~gesslein/
EXTRACT_SUFX= .tgz
@@ -15,20 +15,25 @@ EXTRACT_SUFX= .tgz
MAINTAINER= neuhauser@sigpipe.cz
COMMENT= Highly portable, general purpose CAS (Computer Algebra System)
-DISTVERSION= ${PORTVERSION:C/\.([[:alpha:]]+)/\1/}
-WRKSRC= ${WRKDIR}/${DISTNAME}
MAKEFILE= makefile
-MAKE_ARGS+= -DREADLINE prefix=${PREFIX} docdir='$$(prefix)/share/doc'
+MAKE_ARGS= -DREADLINE
USE_REINPLACE= yes
PLIST_FILES= bin/mathomatic
-PORTDOCS= am.htm ctips.html index.html manual.htm notes.html changes.txt
+PORTDOCS= *
MAN1= mathomatic.1
-pre-configure:
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/ s|-O||; /^LDFLAGS/ s|-s||' \
+ ${WRKSRC}/makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/mathomatic.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e "s|#%%PORTDOCS%%| |" ${WRKSRC}/makefile
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/changes.txt ${WRKSRC}/doc/* ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/math/mathomatic/distinfo b/math/mathomatic/distinfo
index 94dbf56bf933..610860edc67e 100644
--- a/math/mathomatic/distinfo
+++ b/math/mathomatic/distinfo
@@ -1,2 +1,2 @@
-MD5 (mathomatic-12.4.11.tgz) = ee54e976e1a99f8e08fa6c4a4e7924ad
-SIZE (mathomatic-12.4.11.tgz) = 128156
+MD5 (mathomatic-12.5.0.tgz) = cefebb73893dd55e7ecadff33464ee18
+SIZE (mathomatic-12.5.0.tgz) = 128893
diff --git a/math/mathomatic/files/patch-makefile b/math/mathomatic/files/patch-makefile
deleted file mode 100644
index ae516952dd2a..000000000000
--- a/math/mathomatic/files/patch-makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- makefile.orig Sat Sep 10 23:21:26 2005
-+++ makefile Fri Oct 7 15:03:27 2005
-@@ -10,7 +10,7 @@
-
- prefix = /usr
- bindir = /usr/local/bin
--mandir = $(prefix)/share/man
-+mandir = $(prefix)/man
- docdir = $(prefix)/share/doc
-
- AOUT =mathomatic
-@@ -42,7 +42,7 @@
- install -d $(docdir)/mathomatic
- install -m 0755 $(AOUT) $(bindir)
- install -m 0644 doc/mathomatic.1 $(mandir)/man1
-- install -m 0644 changes.txt doc/*.htm doc/*.html $(docdir)/mathomatic
-+#%%PORTDOCS%%install -m 0644 changes.txt doc/*.htm doc/*.html $(docdir)/mathomatic
- @echo Install completed.
-
- uninstall: