aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-04 21:55:11 +0800
committerrafan <rafan@FreeBSD.org>2006-08-04 21:55:11 +0800
commitdb8dc00ae1f9e0efc33f12de21f7d38f619203d2 (patch)
treec5d55ab6b63c1510276d27121ad166e36762f274
parent1e13a0168ef314a99217bd29a0fe0aca4968d58b (diff)
downloadfreebsd-ports-gnome-db8dc00ae1f9e0efc33f12de21f7d38f619203d2.tar.gz
freebsd-ports-gnome-db8dc00ae1f9e0efc33f12de21f7d38f619203d2.tar.zst
freebsd-ports-gnome-db8dc00ae1f9e0efc33f12de21f7d38f619203d2.zip
- Fix building of module.eap under some circumstancies
(reported by Michael Metzger <MMetzger@marketvisionresearch.com>) - Fix bug with no icon in e17 menu. - Add missing ewl dependency (reported by Rainer Alves <rainer.alves@gmail.com>) PR: ports/101326 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru> (maintainer)
-rw-r--r--x11/e17-module-engage/Makefile4
-rw-r--r--x11/e17-module-engage/files/patch-src_module_e_mod_config.c21
-rw-r--r--x11/e17-module-engage/files/patch-src_module_e_mod_main.c10
-rw-r--r--x11/e17-module-engage/files/patch-src_module_e_mod_main.h13
-rw-r--r--x11/e17-module-engage/files/patch-src_module_module_icon.edc11
5 files changed, 58 insertions, 1 deletions
diff --git a/x11/e17-module-engage/Makefile b/x11/e17-module-engage/Makefile
index 22e748dae2d6..9ccc1763fc3d 100644
--- a/x11/e17-module-engage/Makefile
+++ b/x11/e17-module-engage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= engage
PORTVERSION= 20060719
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://mbsd.msk.ru/dist/
PKGNAMEPREFIX= e17-module-
@@ -16,7 +17,8 @@ MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= Alternative e17 application launcher with tray support
BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
-LIB_DEPENDS= esmart_trans_x11.0:${PORTSDIR}/graphics/esmart
+LIB_DEPENDS= esmart_trans_x11.0:${PORTSDIR}/graphics/esmart \
+ ewl.0:${PORTSDIR}/x11-toolkits/ewl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
diff --git a/x11/e17-module-engage/files/patch-src_module_e_mod_config.c b/x11/e17-module-engage/files/patch-src_module_e_mod_config.c
new file mode 100644
index 000000000000..6d4c395957ba
--- /dev/null
+++ b/x11/e17-module-engage/files/patch-src_module_e_mod_config.c
@@ -0,0 +1,21 @@
+--- src/module/e_mod_config.c.orig Thu Jul 20 00:20:27 2006
++++ src/module/e_mod_config.c Thu Aug 3 23:24:37 2006
+@@ -35,6 +35,8 @@
+ v = E_NEW(E_Config_Dialog_View, 1);
+ if (v)
+ {
++ char buf[4096];
++
+ v->create_cfdata = _create_data;
+ v->free_cfdata = _free_data;
+ v->basic.apply_cfdata = _basic_apply_data;
+@@ -42,7 +44,8 @@
+ v->advanced.apply_cfdata = _advanced_apply_data;
+ v->advanced.create_widgets = _advanced_create_widgets;
+
+- cfd = e_config_dialog_new(con, "Engage Configuration", NULL, 0, v, eb);
++ snprintf(buf, sizeof(buf), "%s/module.eap", e_module_dir_get(eb->engage->module));
++ cfd = e_config_dialog_new(con, "Engage Configuration", buf, 0, v, eb);
+ eb->cfd = cfd;
+ }
+ }
diff --git a/x11/e17-module-engage/files/patch-src_module_e_mod_main.c b/x11/e17-module-engage/files/patch-src_module_e_mod_main.c
new file mode 100644
index 000000000000..8d1375a872f8
--- /dev/null
+++ b/x11/e17-module-engage/files/patch-src_module_e_mod_main.c
@@ -0,0 +1,10 @@
+--- src/module/e_mod_main.c.orig Thu Jul 20 00:20:27 2006
++++ src/module/e_mod_main.c Thu Aug 3 23:24:37 2006
+@@ -151,6 +151,7 @@
+ /* actually init engage */
+ e = _engage_new();
+ // m->config_menu = e->config_menu;
++ e->module = m;
+ return e;
+ }
+
diff --git a/x11/e17-module-engage/files/patch-src_module_e_mod_main.h b/x11/e17-module-engage/files/patch-src_module_e_mod_main.h
new file mode 100644
index 000000000000..19ed2172ffdf
--- /dev/null
+++ b/x11/e17-module-engage/files/patch-src_module_e_mod_main.h
@@ -0,0 +1,13 @@
+--- src/module/e_mod_main.h.orig Thu Jul 20 00:20:27 2006
++++ src/module/e_mod_main.h Thu Aug 3 23:24:37 2006
+@@ -38,8 +38,9 @@
+ E_App *apps;
+ Evas_List *bars;
+ E_Menu *config_menu;
+-
++
+ Config *conf;
++ E_Module *module;
+ };
+
+ struct _Engage_Tray
diff --git a/x11/e17-module-engage/files/patch-src_module_module_icon.edc b/x11/e17-module-engage/files/patch-src_module_module_icon.edc
new file mode 100644
index 000000000000..5c4d55f8e72f
--- /dev/null
+++ b/x11/e17-module-engage/files/patch-src_module_module_icon.edc
@@ -0,0 +1,11 @@
+--- src/module/module_icon.edc.orig Thu Aug 3 23:23:25 2006
++++ src/module/module_icon.edc Thu Aug 3 23:23:43 2006
+@@ -4,7 +4,7 @@
+ collections {
+ group {
+ name: "icon";
+- max: %d %d;
++ max: 24 24;
+ parts {
+ part {
+ name: "image";