aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-02-27 23:39:12 +0800
committerlioux <lioux@FreeBSD.org>2005-02-27 23:39:12 +0800
commitdc32b88bbc0274f6aebed74ad621a03beeaa15af (patch)
treeddbed1ff32ce1b556aee3b3b8dd88098fd768568
parentd45da1b79c13bfd1ef63693204c56bea682c74f4 (diff)
downloadfreebsd-ports-gnome-dc32b88bbc0274f6aebed74ad621a03beeaa15af.tar.gz
freebsd-ports-gnome-dc32b88bbc0274f6aebed74ad621a03beeaa15af.tar.zst
freebsd-ports-gnome-dc32b88bbc0274f6aebed74ad621a03beeaa15af.zip
o Update to 4.0.4
o Update WWW tag PR: 77996 Submitted by: Linh Pham <question+fbsdports@closedsrc.org>
-rw-r--r--sysutils/memtest/Makefile17
-rw-r--r--sysutils/memtest/distinfo4
-rw-r--r--sysutils/memtest/files/patch-aa21
-rw-r--r--sysutils/memtest/files/patch-ab27
-rw-r--r--sysutils/memtest/pkg-descr2
5 files changed, 10 insertions, 61 deletions
diff --git a/sysutils/memtest/Makefile b/sysutils/memtest/Makefile
index bd43d5fc6301..bc7786d3e6e8 100644
--- a/sysutils/memtest/Makefile
+++ b/sysutils/memtest/Makefile
@@ -6,28 +6,25 @@
#
PORTNAME= memtest
-PORTVERSION= 2.93.1
-PORTREVISION= 1
+PORTVERSION= 4.0.4
CATEGORIES= sysutils
-MASTER_SITES= http://www.qcc.sk.ca/~charlesc/software/memtester/
+MASTER_SITES= http://pyropus.ca/software/${PORTNAME}er/
DISTNAME= ${PORTNAME}er-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Utility to test for faulty memory subsystem
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_REINPLACE= yes
-MAN1= ${PORTNAME}.1
+MAN8= ${PORTNAME}.8
PLIST_FILES= bin/memtest
post-patch:
- @${REINPLACE_CMD} -e 's|gcc|${CC}|' \
- ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|cc|${CC}|' \
+ ${WRKSRC}/conf-cc
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}er ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${MAN8:S/./er./g} ${PREFIX}/man/man8/${MAN8}
.include <bsd.port.mk>
diff --git a/sysutils/memtest/distinfo b/sysutils/memtest/distinfo
index 2b1e1850597b..e07f34f5dd0a 100644
--- a/sysutils/memtest/distinfo
+++ b/sysutils/memtest/distinfo
@@ -1,2 +1,2 @@
-MD5 (memtester-2.93.1.tar.bz2) = 3c971e11ca71cc8cd9d43b247170c243
-SIZE (memtester-2.93.1.tar.bz2) = 22665
+MD5 (memtester-4.0.4.tar.gz) = 7bd4d278419811236753fb69894caacf
+SIZE (memtester-4.0.4.tar.gz) = 16202
diff --git a/sysutils/memtest/files/patch-aa b/sysutils/memtest/files/patch-aa
deleted file mode 100644
index e7aabad83438..000000000000
--- a/sysutils/memtest/files/patch-aa
+++ /dev/null
@@ -1,21 +0,0 @@
---- memtest.c.orig Thu Dec 19 13:43:09 2002
-+++ memtest.c Thu Dec 19 13:42:49 2002
-@@ -20,6 +20,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <time.h>
-+#include <sys/types.h>
- #include <sys/mman.h>
- #include <signal.h>
- #include <unistd.h>
-@@ -249,6 +250,10 @@
- if (!strcmp (argv[i], "all"))
- {
- membytes = 4095 << MB;
-+ fprintf (stderr, "%s: ATTENTION: option '%s' might cause a segmentation"
-+ " fault crash on %s because it will try to test as much"
-+ " as 4G of memory even if your system does not have as much"
-+ " memory.\n", argv[0], argv[i], argv[0]);
- continue;
- }
- t = (ui32) strtol (argv[i], &endptr, 0);
diff --git a/sysutils/memtest/files/patch-ab b/sysutils/memtest/files/patch-ab
deleted file mode 100644
index 53e606475459..000000000000
--- a/sysutils/memtest/files/patch-ab
+++ /dev/null
@@ -1,27 +0,0 @@
---- memtest.1.orig Wed Apr 26 19:58:23 2000
-+++ memtest.1 Thu Dec 19 13:45:32 2002
-@@ -196,7 +196,12 @@
- faulty memory modules in Linux, or any Unix-like environment.
- .Sh "Invoking memtest"
- \fBmemtest\fR takes the first supplied argument as the amount of memory to test.
--The value \fB'all\*(R'\fR means to test all available memory. A specific amount of
-+.PP
-+The value \fB'all\*(R'\fR means testing all available memory.
-+However, the value \fB'all\*(R'\fR may not work on all systems, so
-+a specific amount of memory might have to be specified.
-+.PP
-+A specific amount of
- memory can be supplied as a number, followed by a letter to indicate units:
- .Ip "\(bu" 4
- \fBB\fR or \fBb\fR \- bytes
-@@ -332,6 +337,10 @@
- .Sh "Known Bugs"
- The output examples in this manpage have fallen out of sync with the software
- in minor ways.
-+.PP
-+The memory size value \fB'all\*(R'\fR means testing all available
-+memory. However, the value \fB'all\*(R'\fR may not work on all
-+systems, so a specific amount of memory might have to be specified.
- .Sh "How To Report Bugs"
- Bugs should be reported to <memtest@discworld.dyndns.org>.
- .PP
diff --git a/sysutils/memtest/pkg-descr b/sysutils/memtest/pkg-descr
index f51fc22d684d..97c7f0c3615d 100644
--- a/sysutils/memtest/pkg-descr
+++ b/sysutils/memtest/pkg-descr
@@ -6,4 +6,4 @@ memory. He also rewrote the original tests (which catch mainly
memory bits which are stuck permanently high or low) so that they
run approximately an order of magnitude faster.
-WWW: http://www.qcc.sk.ca/~charlesc/software/memtester/
+WWW: http://pyropus.ca/software/memtester/