aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-19 05:09:51 +0800
committermiwi <miwi@FreeBSD.org>2008-02-19 05:09:51 +0800
commitdc61c642e9f08e2715bf127adcd56c3461702f05 (patch)
tree4db24d35c332f30204d6737af472f3f8dc18e562
parent56d3f88a2fd0631cff4c6173d5f4374ad23766a3 (diff)
downloadfreebsd-ports-gnome-dc61c642e9f08e2715bf127adcd56c3461702f05.tar.gz
freebsd-ports-gnome-dc61c642e9f08e2715bf127adcd56c3461702f05.tar.zst
freebsd-ports-gnome-dc61c642e9f08e2715bf127adcd56c3461702f05.zip
When using this module in a test script, it goes through all the modules
in your distribution, checks their POD, checks that they compile ok and checks that they all define a $VERSION. WWW: http://search.cpan.org/dist/Test-Distribution/ PR: ports/120812 Submitted by: Felippe de Meirelles Motta <lippemail at gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Distribution/Makefile30
-rw-r--r--devel/p5-Test-Distribution/distinfo3
-rw-r--r--devel/p5-Test-Distribution/pkg-descr5
-rw-r--r--devel/p5-Test-Distribution/pkg-plist2
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 77d26378853b..63856f0f9b2b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1617,6 +1617,7 @@
SUBDIR += p5-Test-Deep
SUBDIR += p5-Test-Dependencies
SUBDIR += p5-Test-Differences
+ SUBDIR += p5-Test-Distribution
SUBDIR += p5-Test-Exception
SUBDIR += p5-Test-Expect
SUBDIR += p5-Test-File
diff --git a/devel/p5-Test-Distribution/Makefile b/devel/p5-Test-Distribution/Makefile
new file mode 100644
index 000000000000..970840702963
--- /dev/null
+++ b/devel/p5-Test-Distribution/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Test-Distribution
+# Date created: 2008-02-11
+# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Distribution
+PORTVERSION= 2.00
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lippemail@gmail.com
+COMMENT= Test::Distribution - Perform tests on all modules of a distribution
+
+BUILD_DEPENDS+= ${SITE_PERL}/ExtUtils/Manifest.pm:${PORTSDIR}/devel/p5-ExtUtils-Manifest \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/Module/CoreList.pm:${PORTSDIR}/devel/p5-Module-CoreList \
+ ${SITE_PERL}/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Pod-Coverage \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Test::Distribution.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Distribution/distinfo b/devel/p5-Test-Distribution/distinfo
new file mode 100644
index 000000000000..8d69d69e1927
--- /dev/null
+++ b/devel/p5-Test-Distribution/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Distribution-2.00.tar.gz) = 7b7f905605f60a786f2ece2d76230fd1
+SHA256 (Test-Distribution-2.00.tar.gz) = 50ecd07fb6cab7b2b2a73b5526ee43b90e77734c9bcec95ce8822b9c0a912b68
+SIZE (Test-Distribution-2.00.tar.gz) = 11326
diff --git a/devel/p5-Test-Distribution/pkg-descr b/devel/p5-Test-Distribution/pkg-descr
new file mode 100644
index 000000000000..3cff078507fc
--- /dev/null
+++ b/devel/p5-Test-Distribution/pkg-descr
@@ -0,0 +1,5 @@
+When using this module in a test script, it goes through all the modules
+in your distribution, checks their POD, checks that they compile ok and
+checks that they all define a $VERSION.
+
+WWW: http://search.cpan.org/dist/Test-Distribution/
diff --git a/devel/p5-Test-Distribution/pkg-plist b/devel/p5-Test-Distribution/pkg-plist
new file mode 100644
index 000000000000..f4f07fc89a90
--- /dev/null
+++ b/devel/p5-Test-Distribution/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Test/Distribution.pm
+@dirrmtry %%SITE_PERL%%/Test