aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 09:26:57 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 09:26:57 +0800
commitdecec8e343b0a2f5d5eac7e0a04845400ae545a3 (patch)
tree374345d13954be3d4fc34652849d6c4acd1d3f0f
parent26ccc3c643e1508caa2a6162ddfac21ff6ec48e7 (diff)
downloadfreebsd-ports-gnome-decec8e343b0a2f5d5eac7e0a04845400ae545a3.tar.gz
freebsd-ports-gnome-decec8e343b0a2f5d5eac7e0a04845400ae545a3.tar.zst
freebsd-ports-gnome-decec8e343b0a2f5d5eac7e0a04845400ae545a3.zip
[PATCH] textproc/tth: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54954 Submitted by: Jens Rehsack <rehsack@liwing.de>
-rw-r--r--textproc/tth/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/textproc/tth/Makefile b/textproc/tth/Makefile
index 51ae6b4f86d5..60d9b32ed48b 100644
--- a/textproc/tth/Makefile
+++ b/textproc/tth/Makefile
@@ -17,12 +17,26 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A TeX to HTML translator
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
latex:${PORTSDIR}/print/teTeX \
ppmtogif:${PORTSDIR}/graphics/netpbm
MAN1= tth.1
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
do-build:
cd ${WRKSRC}; ${CC} ${CFLAGS} tth.c -o tth -ll