aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-10-02 09:50:00 +0800
committermarino <marino@FreeBSD.org>2016-10-02 09:50:00 +0800
commitdee9e4168afdf5ccb3e3d5c9e166c608d5804dcb (patch)
treec08195fa600ca1d7c9dcea70868be856119ceda6
parent1125fa911a76096c2bc64b3de846dcd44f269540 (diff)
downloadfreebsd-ports-gnome-dee9e4168afdf5ccb3e3d5c9e166c608d5804dcb.tar.gz
freebsd-ports-gnome-dee9e4168afdf5ccb3e3d5c9e166c608d5804dcb.tar.zst
freebsd-ports-gnome-dee9e4168afdf5ccb3e3d5c9e166c608d5804dcb.zip
databases/mariadb101: Fix OPSYS logic
The intent was to check for GSSAPI BASE option set on FreeBSD 9, but the effect was an IGNORE set for all non-FreeBSD platforms. Fix the logic to its original intent under the just-fix-it blanket.
-rw-r--r--databases/mariadb101-server/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 6054b4694584..629455f9c7c0 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -154,13 +154,15 @@ IGNORE= BASE_GSSAPI is not compatible with OpenSSL from ports. Use other GSSAPI
CMAKE_ARGS+= -DWITHOUT_TOKUDB
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000012
+.if ${OPSYS} == FreeBSD
+. if ${OSVERSION} >= 1000012
CMAKE_ARGS+= -DWITH_JEMALLOC="system"
-.else
+. else
CMAKE_ARGS+= -DWITH_JEMALLOC="no"
-.if ${PORT_OPTIONS:MGSSAPI_BASE}
+. if ${PORT_OPTIONS:MGSSAPI_BASE}
IGNORE= requires a Kerberos implementation from ports on FreeBSD < 10. Select GSSAPI_HEIMDAL or GSSAPI_MIT option
-.endif
+. endif
+. endif
.endif
post-patch: