aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-11 14:02:40 +0800
committerbapt <bapt@FreeBSD.org>2013-07-11 14:02:40 +0800
commitdf17a20183feb5ae101ba3f3c770512d2739a945 (patch)
tree55bda2380d0321e2a4ee84d9b44c8cce8058b295
parent20fc0082bc387a0c5d7f22216de1bb605e83b8a1 (diff)
downloadfreebsd-ports-gnome-df17a20183feb5ae101ba3f3c770512d2739a945.tar.gz
freebsd-ports-gnome-df17a20183feb5ae101ba3f3c770512d2739a945.tar.zst
freebsd-ports-gnome-df17a20183feb5ae101ba3f3c770512d2739a945.zip
Mark job unsafe (fails with -j24)
Use options helpers
-rw-r--r--x11-wm/ede/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/x11-wm/ede/Makefile b/x11-wm/ede/Makefile
index fdffabcdf51c..c274cc586cdc 100644
--- a/x11-wm/ede/Makefile
+++ b/x11-wm/ede/Makefile
@@ -36,7 +36,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-edelib_path=${EDELIB_WRKSRC} \
--with-fltk-path=${LOCALBASE}
INSTALL_ICONS= yes
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -49,13 +49,8 @@ EDELIB_DISTNAME=${EDELIB_NAME}-${EDELIB_VERSION}
EDELIB_DISTFILE=${EDELIB_DISTNAME}${EXTRACT_SUFX}
EDELIB_WRKSRC= ${WRKDIR}/${EDELIB_DISTNAME}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MHAL}
-LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
-.else
-CONFIGURE_ARGS+=--disable-hal
-.endif
+HAL_LIB_DEPENDS= libhal.so.1:${PORTSDIR}/sysutils/hal
+HAL_CONFIGURE_OFF= --disable-hal
# use multiple make jobs
_make_jobs= -j${MAKE_JOBS_NUMBER}