aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-29 19:41:11 +0800
committeredwin <edwin@FreeBSD.org>2003-08-29 19:41:11 +0800
commitdf5725818c67cc327e5913cd7b766c6072a73757 (patch)
tree941a52c3dca32416209499055062131d5b3948cf
parent9b2601818fbf665047b334115483f85badcc6fb8 (diff)
downloadfreebsd-ports-gnome-df5725818c67cc327e5913cd7b766c6072a73757.tar.gz
freebsd-ports-gnome-df5725818c67cc327e5913cd7b766c6072a73757.tar.zst
freebsd-ports-gnome-df5725818c67cc327e5913cd7b766c6072a73757.zip
New port: finance/grisbi, a personal finance manager.
Grisbi is a personnal accounting application, written with Gnome and Gtk, and is released under the GPL licence. Its aim is to provide you with the most simple and intuitive software for basic use, although it can be very powerful if you spend a little time on the setup. Grisbi is an application written by french developpers, so it perfectly respects french accounting rules. Grisbi can manage multiple accounts, currencies and users. It manages third parties, expenditures and receipts categories, and also budgetary lines, financial years, and other information that make Grisbi adapted for associations (except those that require double entry accounting). WWW: http://www.grisbi.org/ PR: ports/54675 Submitted by: Thierry Thomas <thierry@pompo.net>
-rw-r--r--finance/Makefile1
-rw-r--r--finance/grisbi/Makefile37
-rw-r--r--finance/grisbi/distinfo1
-rw-r--r--finance/grisbi/files/patch-aclocal.m426
-rw-r--r--finance/grisbi/files/patch-help_Makefile.in22
-rw-r--r--finance/grisbi/pkg-descr15
-rw-r--r--finance/grisbi/pkg-message3
-rw-r--r--finance/grisbi/pkg-plist26
8 files changed, 131 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 4387a46c502a..daccfbffee6b 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -3,6 +3,7 @@
SUBDIR += aqmoney
SUBDIR += gnucash
SUBDIR += gnucash-docs
+ SUBDIR += grisbi
SUBDIR += khacc
SUBDIR += libofx
SUBDIR += openhbci
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
new file mode 100644
index 000000000000..00b87fe25321
--- /dev/null
+++ b/finance/grisbi/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: grisbi
+# Date created: 19 November 2002
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grisbi
+PORTVERSION= 0.4.1
+CATEGORIES= finance
+MASTER_SITES= http://grisbi.gegeweb.net/packages/src/
+
+MAINTAINER= thierry@pompo.net
+COMMENT= A personnal accounting application
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 libcapplet libxml gnomepanel orbit gdkpixbuf gnomelibs gnomeprint
+USE_BISON= yes
+USE_BZIP2= yes
+USE_AUTOCONF= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ AUTOHEADER="${AUTOHEADER}" \
+ AUTOCONF="${AUTOCONF}"
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:"
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/finance/grisbi/distinfo b/finance/grisbi/distinfo
new file mode 100644
index 000000000000..f1a43db36191
--- /dev/null
+++ b/finance/grisbi/distinfo
@@ -0,0 +1 @@
+MD5 (grisbi-0.4.1.tar.bz2) = ab912d91b9125de0ac00be362baba686
diff --git a/finance/grisbi/files/patch-aclocal.m4 b/finance/grisbi/files/patch-aclocal.m4
new file mode 100644
index 000000000000..7da0f914b79d
--- /dev/null
+++ b/finance/grisbi/files/patch-aclocal.m4
@@ -0,0 +1,26 @@
+--- aclocal.m4.orig Thu Oct 24 11:02:25 2002
++++ aclocal.m4 Tue Nov 26 19:28:10 2002
+@@ -60,10 +60,10 @@
+ AC_REQUIRE([AC_ARG_PROGRAM])
+ dnl FIXME This is truly gross.
+ missing_dir=`cd $ac_aux_dir && pwd`
+-AM_MISSING_PROG(ACLOCAL, aclocal-${am__api_version}, $missing_dir)
+-AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
+-AM_MISSING_PROG(AUTOMAKE, automake-${am__api_version}, $missing_dir)
+-AM_MISSING_PROG(AUTOHEADER, autoheader, $missing_dir)
++AM_MISSING_PROG(ACLOCAL, aclocal${am__api_version}, $missing_dir)
++AM_MISSING_PROG(AUTOCONF, $AUTOCONF, $missing_dir)
++AM_MISSING_PROG(AUTOMAKE, automake${am__api_version}, $missing_dir)
++AM_MISSING_PROG(AUTOHEADER, $AUTOHEADER, $missing_dir)
+ AM_MISSING_PROG(MAKEINFO, makeinfo, $missing_dir)
+ AC_REQUIRE([AC_PROG_MAKE_SET])])
+
+@@ -87,7 +87,7 @@
+ # ----------------------------
+ # Automake X.Y traces this macro to ensure aclocal.m4 has been
+ # generated from the m4 files accompanying Automake X.Y.
+-AC_DEFUN([AM_AUTOMAKE_VERSION],[am__api_version="1.4"])
++AC_DEFUN([AM_AUTOMAKE_VERSION],[am__api_version="14"])
+
+ # AM_SET_CURRENT_AUTOMAKE_VERSION
+ # -------------------------------
diff --git a/finance/grisbi/files/patch-help_Makefile.in b/finance/grisbi/files/patch-help_Makefile.in
new file mode 100644
index 000000000000..cd21cddac1b8
--- /dev/null
+++ b/finance/grisbi/files/patch-help_Makefile.in
@@ -0,0 +1,22 @@
+--- help/Makefile.in.orig Sat Feb 15 23:19:45 2003
++++ help/Makefile.in Sun Feb 16 21:21:17 2003
+@@ -238,7 +238,8 @@
+ distdir=`cd $(distdir) && pwd`; \
+ cd $(top_srcdir) \
+ && $(AUTOMAKE) --include-deps --build-dir=$$here --srcdir-name=$(top_srcdir) --output-dir=$$top_distdir --gnu help/Makefile
+- @for file in $(DISTFILES); do \
++ @if test "x$(srcdir)" != "x$(DISTFILES)"; then \
++ for file in $(DISTFILES); do \
+ d=$(srcdir); \
+ if test -d $$d/$$file; then \
+ cp -pr $$d/$$file $(distdir)/$$file; \
+@@ -247,7 +248,8 @@
+ || ln $$d/$$file $(distdir)/$$file 2> /dev/null \
+ || cp -p $$d/$$file $(distdir)/$$file || :; \
+ fi; \
+- done
++ done; \
++ fi
+ for subdir in $(SUBDIRS); do \
+ if test "$$subdir" = .; then :; else \
+ test -d $(distdir)/$$subdir \
diff --git a/finance/grisbi/pkg-descr b/finance/grisbi/pkg-descr
new file mode 100644
index 000000000000..fb69ac607ff1
--- /dev/null
+++ b/finance/grisbi/pkg-descr
@@ -0,0 +1,15 @@
+Grisbi is a personnal accounting application, written with Gnome and Gtk,
+and is released under the GPL licence.
+
+Its aim is to provide you with the most simple and intuitive software for
+basic use, although it can be very powerful if you spend a little time on the
+setup.
+
+Grisbi is an application written by french developpers, so it perfectly
+respects french accounting rules. Grisbi can manage multiple accounts,
+currencies and users. It manages third parties, expenditures and receipts
+categories, and also budgetary lines, financial years, and other information
+that make Grisbi adapted for associations (except those that require double
+entry accounting).
+
+WWW: http://www.grisbi.org/
diff --git a/finance/grisbi/pkg-message b/finance/grisbi/pkg-message
new file mode 100644
index 000000000000..603b9b0d435a
--- /dev/null
+++ b/finance/grisbi/pkg-message
@@ -0,0 +1,3 @@
+************************************************************************
+Documentation has been installed in %%PREFIX%%/share/gnome/help/grisbi/.
+************************************************************************
diff --git a/finance/grisbi/pkg-plist b/finance/grisbi/pkg-plist
new file mode 100644
index 000000000000..fc162909c454
--- /dev/null
+++ b/finance/grisbi/pkg-plist
@@ -0,0 +1,26 @@
+bin/grisbi
+share/gnome/apps/Applications/grisbi.desktop
+share/gnome/help/grisbi/C/contents_motif.gif
+share/gnome/help/grisbi/C/grisbi-manuel.html
+share/gnome/help/grisbi/C/next_motif.gif
+share/gnome/help/grisbi/C/previous_motif.gif
+share/gnome/help/grisbi/C/quickstart.html
+share/gnome/help/grisbi/C/translation.html
+share/gnome/help/grisbi/C/topic.dat
+share/gnome/help/grisbi/fr/contents_motif.gif
+share/gnome/help/grisbi/fr/grisbi-manuel.html
+share/gnome/help/grisbi/fr/next_motif.gif
+share/gnome/help/grisbi/fr/previous_motif.gif
+share/gnome/help/grisbi/fr/quickstart.html
+share/gnome/help/grisbi/fr/topic.dat
+share/gnome/help/grisbi/fr/translation.html
+share/locale/fr/LC_MESSAGES/grisbi.mo
+share/mime-info/grisbi.keys
+share/mime-info/grisbi.mime
+share/pixmaps/grisbi.png
+share/pixmaps/logo_grisbi.xpm
+@dirrm share/gnome/help/grisbi/C
+@dirrm share/gnome/help/grisbi/fr
+@dirrm share/gnome/help/grisbi
+@dirrm share/mime-info
+@dirrm share/pixmaps