aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2006-07-19 05:52:28 +0800
committersobomax <sobomax@FreeBSD.org>2006-07-19 05:52:28 +0800
commitdf65ea258d7c283fb810ff69b695f09107deffc6 (patch)
tree351da7d5cca5ef98117bd7be5e451dbb61dee848
parentae29296f51dd6e01417edac2794d3ca7ff088a54 (diff)
downloadfreebsd-ports-gnome-df65ea258d7c283fb810ff69b695f09107deffc6.tar.gz
freebsd-ports-gnome-df65ea258d7c283fb810ff69b695f09107deffc6.tar.zst
freebsd-ports-gnome-df65ea258d7c283fb810ff69b695f09107deffc6.zip
Make buildable on 7.x and 6.x after addition of getXXX_r() functions.
Submitted by: ume
-rw-r--r--net/b2bua/files/patch-contrib::libcext_lgpl::Makefile14
-rw-r--r--net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h21
2 files changed, 35 insertions, 0 deletions
diff --git a/net/b2bua/files/patch-contrib::libcext_lgpl::Makefile b/net/b2bua/files/patch-contrib::libcext_lgpl::Makefile
new file mode 100644
index 000000000000..b3f6b82371fd
--- /dev/null
+++ b/net/b2bua/files/patch-contrib::libcext_lgpl::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- contrib/libcext_lgpl/Makefile
++++ contrib/libcext_lgpl/Makefile
+@@ -12,7 +12,7 @@
+ # Darwin
+
+ AR=libtool -static -o
+-OBJS = poll.o pthread_adds.o gethostby_r.o getnetby_r.o getprotoby_r.o getpw_r.o getservby_r.o
++OBJS = getpw_r.o
+
+ HEADERS = poll.h pthread_adds.h
+ else
diff --git a/net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h b/net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h
new file mode 100644
index 000000000000..96c215960a96
--- /dev/null
+++ b/net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- contrib/libcext_lgpl/netdb_r.h
++++ contrib/libcext_lgpl/netdb_r.h
+@@ -2,6 +2,7 @@
+ extern "C" {
+ #endif
+
++#if !defined(__FreeBSD__)
+ struct hostent *
+ gethostbyaddr_r (const char *addr, int length, int type,
+ struct hostent *result, char *buffer, int buflen,
+@@ -15,6 +16,7 @@
+ struct hostent *
+ gethostent_r (struct hostent *result, char *buffer, int buflen,
+ int *h_errnop);
++#endif
+
+ #ifdef __cplusplus
+ }