aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-10-31 05:20:29 +0800
committeradamw <adamw@FreeBSD.org>2016-10-31 05:20:29 +0800
commitdff23b02b242227326d2551ef32a8a8c726a7623 (patch)
treec7cc30868142ff3e9ecd1ba5c5b250782a18c590
parent9c675f6f0f07bcff8fd31e2c75d7b90411f70e27 (diff)
downloadfreebsd-ports-gnome-dff23b02b242227326d2551ef32a8a8c726a7623.tar.gz
freebsd-ports-gnome-dff23b02b242227326d2551ef32a8a8c726a7623.tar.zst
freebsd-ports-gnome-dff23b02b242227326d2551ef32a8a8c726a7623.zip
A number of simplifications and improvements.
- Don't download the unusued signature - Use the standard ICONV knob instead of LIBICONV - Improve option descriptions and proper capitalization - Handle the SUID chmod in the plist instead of the Makefile - Simplify CFLAGS modification and skip the unnecessary -std=c89 addition - Don't patch docs installation out, just let pkg DTRT - Switch WWW to https No PORTREVISION bump because most of these changes are NOOPs, except the WWW change which isn't worth forcing a rebuild for.
-rw-r--r--security/gnupg1/Makefile28
-rw-r--r--security/gnupg1/files/patch-doc_Makefile.in29
-rw-r--r--security/gnupg1/files/patch-g10_Makefile.in29
-rw-r--r--security/gnupg1/pkg-descr13
-rw-r--r--security/gnupg1/pkg-plist2
5 files changed, 17 insertions, 84 deletions
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 4d942058c003..b9a81672c730 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -5,8 +5,6 @@ PORTVERSION= 1.4.21
CATEGORIES= security
MASTER_SITES= GNUPG
PKGNAMESUFFIX= 1
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= adamw@FreeBSD.org
COMMENT= The GNU Privacy Guard
@@ -25,23 +23,22 @@ PORTDOCS= *
TEST_TARGET= check
-OPTIONS_DEFINE= CURL DOCS LDAP LIBICONV LIBUSB NLS SUID_GPG
+OPTIONS_DEFINE= CURL DOCS LDAP ICONV LIBUSB NLS SUID_GPG
OPTIONS_DEFAULT=CURL
OPTIONS_SUB= yes
-CURL_DESC= use libcurl for the keyserver interface
+CURL_DESC= Use libcurl for the keyserver interface
LDAP_DESC= LDAP keyserver interface
-LIBICONV_DESC= use libiconv
-LIBUSB_DESC= use libusb
-SUID_GPG_DESC= install GPG with suid
+LIBUSB_DESC= Support for USB smart cards
+SUID_GPG_DESC= Install GPG setuid
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_WITH= libcurl=${LOCALBASE}
# Work around a GnuPG configure buglet
CURL_CONFIGURE_ENV= _libcurl_config=${LOCALBASE}/bin/curl-config
-LIBICONV_USES= iconv
-LIBICONV_CONFIGURE_ENABLE= gnupg-iconv
+ICONV_USES= iconv
+ICONV_CONFIGURE_ENABLE= gnupg-iconv
LIBUSB_CONFIGURE_WITH= libusb=${LOCALBASE}
@@ -51,13 +48,13 @@ LDAP_CONFIGURE_WITH= ldap=${LOCALBASE}
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+SUID_GPG_PLIST_SUB= GPGMODE=4555
+SUID_GPG_PLIST_SUB_OFF= GPGMODE=
+
.include <bsd.port.options.mk>
-.if ${CC} == "clang" || ${OSVERSION} >= 1000024
-CFLAGS:= ${CFLAGS:S/$/ -std=c89/}
-.if (${ARCH} == "i386")
-CFLAGS:= ${CFLAGS:S/$/ -fheinous-gnu-extensions/}
-.endif
+.if ${ARCH} == "i386" && (${CC} == "clang" || ${OSVERSION} >= 1000024)
+CFLAGS+= -fheinous-gnu-extensions
.endif
post-install-DOCS-on:
@@ -70,7 +67,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-post-install-SUID_GPG-on:
- ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/gpg
-
.include <bsd.port.mk>
diff --git a/security/gnupg1/files/patch-doc_Makefile.in b/security/gnupg1/files/patch-doc_Makefile.in
index ee587f84b295..0bab57c64159 100644
--- a/security/gnupg1/files/patch-doc_Makefile.in
+++ b/security/gnupg1/files/patch-doc_Makefile.in
@@ -9,32 +9,3 @@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkglibexecdir = $(libexecdir)/@PACKAGE@
-@@ -422,7 +422,11 @@ gnupg1_TEXINFOS = gnupg1.texi
-
- # Need this to avoid building of dvis with automake 1.4
- DVIS =
-+ifdef NOPORTDOCS
-+pkgdata_DATA =
-+else
- pkgdata_DATA = FAQ
-+endif
-
- # we can't add gpg.texi gpgv.texi here because automake does not like them to
- # be built files.
-@@ -670,6 +674,8 @@ uninstall-man1:
- -e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
- dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
- install-pkgdataDATA: $(pkgdata_DATA)
-+ifdef NOPORTDOCS
-+else
- @$(NORMAL_INSTALL)
- @list='$(pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
- if test -n "$$list"; then \
-@@ -684,6 +690,7 @@ install-pkgdataDATA: $(pkgdata_DATA)
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgdatadir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgdatadir)" || exit $$?; \
- done
-+endif
-
- uninstall-pkgdataDATA:
- @$(NORMAL_UNINSTALL)
diff --git a/security/gnupg1/files/patch-g10_Makefile.in b/security/gnupg1/files/patch-g10_Makefile.in
index fa656a6e9861..7a98d5e8ce91 100644
--- a/security/gnupg1/files/patch-g10_Makefile.in
+++ b/security/gnupg1/files/patch-g10_Makefile.in
@@ -9,32 +9,3 @@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkglibexecdir = $(libexecdir)/@PACKAGE@
-@@ -465,7 +465,11 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I
- @LIBUSB_CPPFLAGS@ $(am__append_1)
- needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
- other_libs = $(LIBICONV) $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
-+ifdef NOPORTDOCS
-+dist_pkgdata_DATA =
-+else
- dist_pkgdata_DATA = options.skel
-+endif
- @ENABLE_BZIP2_SUPPORT_FALSE@bzip2_source =
- @ENABLE_BZIP2_SUPPORT_TRUE@bzip2_source = compress-bz2.c
- common_source = \
-@@ -731,6 +735,8 @@ distclean-compile:
- @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
- @am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
- install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
-+ifdef NOPORTDOCS
-+else
- @$(NORMAL_INSTALL)
- @list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
- if test -n "$$list"; then \
-@@ -745,6 +751,7 @@ install-dist_pkgdataDATA: $(dist_pkgdata
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgdatadir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgdatadir)" || exit $$?; \
- done
-+endif
-
- uninstall-dist_pkgdataDATA:
- @$(NORMAL_UNINSTALL)
diff --git a/security/gnupg1/pkg-descr b/security/gnupg1/pkg-descr
index 4ad9fb265d00..1475d5075de2 100644
--- a/security/gnupg1/pkg-descr
+++ b/security/gnupg1/pkg-descr
@@ -1,9 +1,6 @@
-GnuPG is a complete and free replacement for PGP.
+GnuPG is a complete and free replacement for PGP. The security/gnupg
+port is the modern 2.x branch with support for newer algorithms, but
+the 1.x branch has few dependencies and is sufficient for most PGP
+operations using common algorithms.
-Because it does not use the patented IDEA algorithm, it can be used
-without any restrictions. GnuPG is an RFC2440 (OpenPGP) compliant
-application.
-
-WWW: http://www.gnupg.org/
-
-kuriyama@FreeBSD.org
+WWW: https://www.gnupg.org/
diff --git a/security/gnupg1/pkg-plist b/security/gnupg1/pkg-plist
index b74ed0accd7e..f37ca9bf0677 100644
--- a/security/gnupg1/pkg-plist
+++ b/security/gnupg1/pkg-plist
@@ -1,4 +1,4 @@
-bin/gpg
+@(,,%%GPGMODE%%) bin/gpg
bin/gpg-zip
bin/gpgsplit
bin/gpgv