aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-05-30 05:16:54 +0800
committerknu <knu@FreeBSD.org>2001-05-30 05:16:54 +0800
commite0affbdfbd1c37b9ac7fea06b6bfc66e78968e0e (patch)
tree069ecf3af697b25acbbc71634da779add5aabcf3
parentaf988803b6b719fec0672974d3875f9833f1adf8 (diff)
downloadfreebsd-ports-gnome-e0affbdfbd1c37b9ac7fea06b6bfc66e78968e0e.tar.gz
freebsd-ports-gnome-e0affbdfbd1c37b9ac7fea06b6bfc66e78968e0e.tar.zst
freebsd-ports-gnome-e0affbdfbd1c37b9ac7fea06b6bfc66e78968e0e.zip
As some people including me are seeing reproduceable coredump,
temporarily stop linking ruby with libc_r. This will break such extension modules as ruby-qt, but we have to investigate the annoying problems we are seeing, present in both ruby and our libc_r. Once suggested by: green
-rw-r--r--lang/ruby-devel/Makefile4
-rw-r--r--lang/ruby/Makefile4
-rw-r--r--lang/ruby16/Makefile4
-rw-r--r--lang/ruby18/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/lang/ruby-devel/Makefile b/lang/ruby-devel/Makefile
index 9750862c02ce..b63cca701637 100644
--- a/lang/ruby-devel/Makefile
+++ b/lang/ruby-devel/Makefile
@@ -32,6 +32,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 1f8a1ddd12aa..320e62366c30 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 1f8a1ddd12aa..320e62366c30 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 9750862c02ce..b63cca701637 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -32,6 +32,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)