aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-08-03 02:59:01 +0800
committerpi <pi@FreeBSD.org>2015-08-03 02:59:01 +0800
commite1bd9af32fe95c56ba7719b35eb3f57558161356 (patch)
tree2991b6e0c22127fe5f1753af9062de552f02498b
parent48dc93ac249622328585abc7b110608fc9090b80 (diff)
downloadfreebsd-ports-gnome-e1bd9af32fe95c56ba7719b35eb3f57558161356.tar.gz
freebsd-ports-gnome-e1bd9af32fe95c56ba7719b35eb3f57558161356.tar.zst
freebsd-ports-gnome-e1bd9af32fe95c56ba7719b35eb3f57558161356.zip
net/librdkafka: fix build on 9.3-i386
- Adding -march=pentium to CFLAGS on this arch PR: 201521 Submitted by: Victor Yagofarov <xnasx@yandex.ru> (maintainer)
-rw-r--r--net/librdkafka/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/librdkafka/Makefile b/net/librdkafka/Makefile
index a1697ef9188d..f1b115510644 100644
--- a/net/librdkafka/Makefile
+++ b/net/librdkafka/Makefile
@@ -22,6 +22,12 @@ USE_LDCONFIG= yes
USES= gmake perl5
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 && ${ARCH} == "i386"
+CFLAGS+= -march=pentium
+.endif
+
post-install:
${INSTALL_DATA} ${WRKSRC}/rdkafka.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/librdkafka.pc
@@ -29,4 +35,4 @@ post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librdkafka.so.1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librdkafka++.so.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>