aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-11-25 07:02:36 +0800
committermiwi <miwi@FreeBSD.org>2006-11-25 07:02:36 +0800
commite287a1920ce08b5b641d8a60fa3fa0b822b07f38 (patch)
tree9ea049cb5fae1e1e79761b3b036d8916198f0c71
parentda2ac4bb0c7d46310ac62e65615d25a1c8cac0c2 (diff)
downloadfreebsd-ports-gnome-e287a1920ce08b5b641d8a60fa3fa0b822b07f38.tar.gz
freebsd-ports-gnome-e287a1920ce08b5b641d8a60fa3fa0b822b07f38.tar.zst
freebsd-ports-gnome-e287a1920ce08b5b641d8a60fa3fa0b822b07f38.zip
- Update to 1.7
PR: ports/105803 Submitted by: user@blg.akavia.ru (maintainer)
-rw-r--r--www/lightsquid/Makefile52
-rw-r--r--www/lightsquid/distinfo6
-rw-r--r--www/lightsquid/files/pkg-message.in2
-rw-r--r--www/lightsquid/pkg-plist74
4 files changed, 75 insertions, 59 deletions
diff --git a/www/lightsquid/Makefile b/www/lightsquid/Makefile
index 5834aec8ca0b..8f89e384d2f6 100644
--- a/www/lightsquid/Makefile
+++ b/www/lightsquid/Makefile
@@ -6,44 +6,64 @@
#
PORTNAME= lightsquid
-PORTVERSION= 1.6
-PORTREVISION= 1
+PORTVERSION= 1.7
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-beta
EXTRACT_SUFX= .tgz
MAINTAINER= ports@logvinov.com
COMMENT= A light and fast web based squid proxy traffic analyser
-.if !defined(WITHOUT_GD)
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
-.endif
+OPTIONS= GDSUPPORT "Graphics report support" on
NO_BUILD= yes
USE_PERL5= yes
-DSTDIR?= ${PREFIX}/www/${PORTNAME}
-SUB_LIST= DSTDIR=${DSTDIR}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+DSTDIR= ${PREFIX}/www/${PORTNAME}
+.if !defined(NOPORTDOCS)
+SUB_LIST= DOCSDIR=${DOCSDIR}
SUB_FILES= pkg-message
+.endif
+CONFIGS= lightsquid.cfg realname.cfg skipuser.cfg group.cfg
+REINPLACE_ARGS= -i ""
+PORTDOCS= gnugpl.txt install.txt readme.txt thanks.txt graph.txt logformat.txt \
+ templates.txt version.txt
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GDSUPPORT)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+.endif
do-patch:
- @${MV} ${WRKSRC}/lightsquid.cfg ${WRKSRC}/lightsquid.cfg.dist
- @${MV} ${WRKSRC}/group.cfg ${WRKSRC}/group.cfg.dist
- @${MV} ${WRKSRC}/realname.cfg ${WRKSRC}/realname.cfg.dist
+ @${REINPLACE_CMD} "s|/var/www/html/${PORTNAME}|${DSTDIR}|" ${WRKSRC}/lightsquid.cfg
+ @${MV} ${WRKSRC}/group.cfg.src ${WRKSRC}/group.cfg
+.for i in ${CONFIGS}
+ @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.dist
+.endfor
do-install:
@${MKDIR} ${DSTDIR}
- @${CP} -R ${WRKSRC}/ ${DSTDIR}
- @${CP} -n ${DSTDIR}/lightsquid.cfg.dist ${DSTDIR}/lightsquid.cfg
- @${CP} -n ${DSTDIR}/group.cfg.dist ${DSTDIR}/group.cfg
- @${CP} -n ${WRKSRC}/realname.cfg.dist ${DSTDIR}/realname.cfg
+ ${CP} -R ${WRKSRC}/ ${DSTDIR}
+ @${RM} -r ${DSTDIR}/doc
+.for i in ${CONFIGS}
+ @${CP} -n ${DSTDIR}/${i}.dist ${DSTDIR}/${i}
+.endfor
@${CHMOD} +x ${DSTDIR}/*.cgi
@${CHMOD} +x ${DSTDIR}/*.pl
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DSTDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.endif
post-install:
+.if !defined(NOPORTDOCS)
@${CAT} ${PKGMESSAGE}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/lightsquid/distinfo b/www/lightsquid/distinfo
index b2bf0f48759a..057d5a892e69 100644
--- a/www/lightsquid/distinfo
+++ b/www/lightsquid/distinfo
@@ -1,3 +1,3 @@
-MD5 (lightsquid-1.6-beta.tgz) = 7902c7eaa821cfc092f7c78f0db22f71
-SHA256 (lightsquid-1.6-beta.tgz) = f90a841c415859138cd717314e394320e613e68491a24f8c2303920c9c1c0ad3
-SIZE (lightsquid-1.6-beta.tgz) = 45727
+MD5 (lightsquid-1.7.tgz) = f97aa46d48e18879cf2dc0d358fd5fec
+SHA256 (lightsquid-1.7.tgz) = 01b8cbaaa49f441c3148525c47145ce2119aab40b63a575a9a04dd5fa561e7d9
+SIZE (lightsquid-1.7.tgz) = 53125
diff --git a/www/lightsquid/files/pkg-message.in b/www/lightsquid/files/pkg-message.in
index a1ae9383c01c..7d78106d2ed2 100644
--- a/www/lightsquid/files/pkg-message.in
+++ b/www/lightsquid/files/pkg-message.in
@@ -1,3 +1,3 @@
**************************************************************************
-Read the %%DSTDIR%%/doc/install.txt to configure lightsquid
+Read the %%DOCSDIR%%/install.txt to configure lightsquid
**************************************************************************
diff --git a/www/lightsquid/pkg-plist b/www/lightsquid/pkg-plist
index c66f19be82dd..edbc45710269 100644
--- a/www/lightsquid/pkg-plist
+++ b/www/lightsquid/pkg-plist
@@ -1,28 +1,30 @@
@unexec if cmp -s %D/www/lightsquid/group.cfg %D/www/lightsquid/group.cfg.dist; then rm -f %D/www/lightsquid/group.cfg; fi
@unexec if cmp -s %D/www/lightsquid/realname.cfg %D/www/lightsquid/realname.cfg.dist; then rm -f %D/www/lightsquid/realname.cfg; fi
+@unexec if cmp -s %D/www/lightsquid/skipuser.cfg %D/www/lightsquid/skipuser.cfg.dist; then rm -f %D/www/lightsquid/skipuser.cfg; fi
@unexec if cmp -s %D/www/lightsquid/lightsquid.cfg %D/www/lightsquid/lightsquid.cfg.dist; then rm -f %D/www/lightsquid/lightsquid.cfg; fi
-www/lightsquid/doc/graph.txt
-www/lightsquid/doc/install.txt
-www/lightsquid/doc/logformat.txt
-www/lightsquid/doc/readme.txt
-www/lightsquid/doc/templates.txt
-www/lightsquid/doc/thanks.txt
-www/lightsquid/doc/version.txt
www/lightsquid/ip2name/ip2name.demo
+www/lightsquid/ip2name/ip2name.dhcp
www/lightsquid/ip2name/ip2name.dns
+www/lightsquid/ip2name/ip2name.ip
www/lightsquid/ip2name/ip2name.list
www/lightsquid/ip2name/ip2name.simple
+www/lightsquid/ip2name/ip2name.smb
+www/lightsquid/ip2name/ip2name.squidauth
www/lightsquid/ip2name/ip2name.squidlist
www/lightsquid/ip2name/ip2name.squidlist2
www/lightsquid/lang/bg.lng
+www/lightsquid/lang/check_lng.pl
+www/lightsquid/lang/check_tpl_lng.pl
+www/lightsquid/lang/cz.lng
www/lightsquid/lang/eng.lng
www/lightsquid/lang/fr.lng
www/lightsquid/lang/hu.lng
www/lightsquid/lang/it.lng
www/lightsquid/lang/pt_br.lng
+www/lightsquid/lang/ru-koi8.lng
www/lightsquid/lang/ru.lng
www/lightsquid/lang/sp.lng
-www/lightsquid/lang/check_lng.pl
+www/lightsquid/lang/ua.lng
www/lightsquid/tpl/base/bigfiles.html
www/lightsquid/tpl/base/day_detail.html
www/lightsquid/tpl/base/graph.html
@@ -35,38 +37,35 @@ www/lightsquid/tpl/base/user_month.html
www/lightsquid/tpl/base/user_time.html
www/lightsquid/tpl/base/whousesite.html
www/lightsquid/tpl/base/images/datetime.png
+www/lightsquid/tpl/base/images/flag_red.png
www/lightsquid/tpl/base/images/graph.png
-www/lightsquid/tpl/base/images/groups.png
-www/lightsquid/tpl/base/images/users.png
-www/lightsquid/tpl/ric_1.6b-0.2/print.css
-www/lightsquid/tpl/ric_1.6b-0.2/screen.css
-www/lightsquid/tpl/ric_1.6b-0.2/bigfiles.html
-www/lightsquid/tpl/ric_1.6b-0.2/day_detail.html
-www/lightsquid/tpl/ric_1.6b-0.2/graph.html
-www/lightsquid/tpl/ric_1.6b-0.2/group_detail.html
-www/lightsquid/tpl/ric_1.6b-0.2/index.html
-www/lightsquid/tpl/ric_1.6b-0.2/month_detail.html
-www/lightsquid/tpl/ric_1.6b-0.2/topsites.html
-www/lightsquid/tpl/ric_1.6b-0.2/user_detail.html
-www/lightsquid/tpl/ric_1.6b-0.2/user_month.html
-www/lightsquid/tpl/ric_1.6b-0.2/user_time.html
-www/lightsquid/tpl/ric_1.6b-0.2/whousesite.html
-www/lightsquid/tpl/ric_1.6b-0.2/images/datetime.png
-www/lightsquid/tpl/ric_1.6b-0.2/images/graph.png
-www/lightsquid/tpl/ric_1.6b-0.2/images/groups.png
-www/lightsquid/tpl/ric_1.6b-0.2/images/month.png
-www/lightsquid/tpl/ric_1.6b-0.2/images/users.png
+www/lightsquid/tpl/base/images/printer.png
+www/lightsquid/tpl/text/bigfiles.html
+www/lightsquid/tpl/text/user_detail.html
+www/lightsquid/tpl/text/index.html
+www/lightsquid/tpl/text/group_detail.html
+www/lightsquid/tpl/text/user_month.html
+www/lightsquid/tpl/text/whousesite.html
+www/lightsquid/tpl/text/topsites.html
+www/lightsquid/tpl/text/month_detail.html
+www/lightsquid/tpl/text/day_detail.html
www/lightsquid/report/delete.me
www/lightsquid/group.cfg.dist
+@exec [ -f %B/group.cfg ] || cp %B/%f %B/group.cfg
www/lightsquid/lightsquid.cfg.dist
+@exec [ -f %B/lightsquid.cfg ] || cp %B/%f %B/lightsquid.cfg
www/lightsquid/realname.cfg.dist
+@exec [ -f %B/realname.cfg ] || cp %B/%f %B/realname.cfg
www/lightsquid/bigfiles.cgi
www/lightsquid/day_detail.cgi
+www/lightsquid/fixreport.pl
www/lightsquid/get.cgi
www/lightsquid/graph.cgi
www/lightsquid/group_detail.cgi
www/lightsquid/index.cgi
www/lightsquid/month_detail.cgi
+www/lightsquid/skipuser.cfg.dist
+@exec [ -f %B/skipuser.cfg ] || cp %B/%f %B/skipuser.cfg
www/lightsquid/topsites.cgi
www/lightsquid/user_detail.cgi
www/lightsquid/user_month.cgi
@@ -76,14 +75,11 @@ www/lightsquid/.htaccess
www/lightsquid/check-setup.pl
www/lightsquid/common.pl
www/lightsquid/lightparser.pl
-www/lightsquid/lightparser.pl.src
-@dirrm www/lightsquid/doc
-@dirrm www/lightsquid/tpl/base/images
-@dirrm www/lightsquid/tpl/base
-@dirrm www/lightsquid/tpl/ric_1.6b-0.2/images
-@dirrm www/lightsquid/tpl/ric_1.6b-0.2
-@dirrm www/lightsquid/tpl
-@dirrm www/lightsquid/lang
-@dirrm www/lightsquid/ip2name
-@dirrm www/lightsquid/report
-@dirrm www/lightsquid
+@dirrmtry www/lightsquid/tpl/base/images
+@dirrmtry www/lightsquid/tpl/base
+@dirrmtry www/lightsquid/tpl/text
+@dirrmtry www/lightsquid/tpl
+@dirrmtry www/lightsquid/lang
+@dirrmtry www/lightsquid/ip2name
+@dirrmtry www/lightsquid/report
+@dirrmtry www/lightsquid