aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-01-25 07:13:30 +0800
committerarved <arved@FreeBSD.org>2003-01-25 07:13:30 +0800
commite3411d327ac045d8e222ff967bc782dfddf5b9c8 (patch)
treeefdede920181f45e8167274e3dfd1d6a2e1be3b5
parente240cb08772dee63648c35ea9f9245cbeb0bf0d6 (diff)
downloadfreebsd-ports-gnome-e3411d327ac045d8e222ff967bc782dfddf5b9c8.tar.gz
freebsd-ports-gnome-e3411d327ac045d8e222ff967bc782dfddf5b9c8.tar.zst
freebsd-ports-gnome-e3411d327ac045d8e222ff967bc782dfddf5b9c8.zip
Unbreak on CURRENT. Re-sort MASTER_SITES
PR: 47439 Submitted by: Sergei Kolobov <sergei@kolobov.com>
-rw-r--r--security/opencdk/Makefile17
-rw-r--r--security/opencdk/files/patch-tests::Makefile.in11
2 files changed, 21 insertions, 7 deletions
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index 25def0547c6b..071574da24c8 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -9,24 +9,27 @@ PORTNAME= opencdk
PORTVERSION= 0.4.1
CATEGORIES= security
MASTER_SITES= http://gd.tuwien.ac.at/privacy/gnupg/alpha/gnutls/opencdk/ \
- ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
- ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
- ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
+ ftp://ftp.gnutls.org/pub/gnutls/opencdk/
MAINTAINER= sergei@kolobov.com
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
+USE_REINPLACE= yes
DOCS= AUTHORS NEWS README THANKS
+post-patch:
+ ${REINPLACE_CMD} -e 's,#include <malloc.h>,#include<stdlib.h>,' \
+ ${WRKSRC}/src/encrypt.c ${WRKSRC}/src/main.c
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/tests/*.c ${EXAMPLESDIR}
diff --git a/security/opencdk/files/patch-tests::Makefile.in b/security/opencdk/files/patch-tests::Makefile.in
new file mode 100644
index 000000000000..c43a54e4f418
--- /dev/null
+++ b/security/opencdk/files/patch-tests::Makefile.in
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig Fri Jan 24 19:06:07 2003
++++ tests/Makefile.in Fri Jan 24 19:06:36 2003
+@@ -97,6 +97,8 @@
+
+ EXTRA_DIST = pub.gpg sec.gpg sec-with-pwd.gpg ts.gpg wkold.gpg
+
++AM_CPPFLAGS = $(LIBGCRYPT_CFLAGS)
++
+ INCLUDES = -I$(top_srcdir)/src
+
+ LDADD = ../src/libopencdk.la $(LIBGCRYPT_LIBS)