aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-01 17:20:32 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-01 17:20:32 +0800
commite371d0f5f20b6fc7bc30a2630ee85cc7cdd9353b (patch)
treeee33102152d489d1e60fe0d1d4dd04cc74fc2d43
parent22f0a5c13218ae30ba57e75938ad67b188a3afbf (diff)
downloadfreebsd-ports-gnome-e371d0f5f20b6fc7bc30a2630ee85cc7cdd9353b.tar.gz
freebsd-ports-gnome-e371d0f5f20b6fc7bc30a2630ee85cc7cdd9353b.tar.zst
freebsd-ports-gnome-e371d0f5f20b6fc7bc30a2630ee85cc7cdd9353b.zip
gecko: backport r427388 to ESR
Suggested by: Tobias Kortkamp
-rw-r--r--mail/thunderbird/files/patch-bug132099143
-rw-r--r--www/firefox-esr/files/patch-bug132099143
-rw-r--r--www/firefox/files/patch-bug132099137
-rw-r--r--www/libxul/files/patch-bug132099143
-rw-r--r--www/seamonkey/files/patch-bug132099137
5 files changed, 197 insertions, 6 deletions
diff --git a/mail/thunderbird/files/patch-bug1320991 b/mail/thunderbird/files/patch-bug1320991
new file mode 100644
index 000000000000..2290a4c2020a
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1320991
@@ -0,0 +1,43 @@
+commit 454e2dbe1b4f
+Author: Mike Shal <mshal@mozilla.com>
+Date: Tue Dec 20 16:37:18 2016 -0500
+
+ Bug 1320991 - Support --with-system-{nss,nspr} in modules/libmar; r?glandium
+
+ The problem with the modules/libmar/tests/moz.build file when building
+ --with-system-nspr and --with-system-nss is that the nss libraries don't
+ exist in the tree, so they fail when trying to copy into the test
+ directory.
+
+ However, it turns out that the libraries copied into the test directory
+ aren't even used when building with an in-tree copy, because the
+ xpcshell launcher sets LD_LIBRARY_PATH to point to dist/bin. Since we
+ use the dist/bin copies anyway for an in-tree build, we can stop copying
+ them into the test directory and simultaneously fix the --with-system
+ build.
+
+ The DEFINES can also go away since this directory doesn't actually build
+ anything.
+
+ MozReview-Commit-ID: Bk2f28wc9ZJ
+---
+ modules/libmar/tests/moz.build | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git modules/libmar/tests/moz.build modules/libmar/tests/moz.build
+index ee72571b0c6b..9642553e8aa2 100644
+--- mozilla/modules/libmar/tests/Makefile.in
++++ mozilla/modules/libmar/tests/Makefile.in
+@@ -10,12 +10,5 @@ ifneq ($(OS_TARGET),Android)
+ ifndef MOZ_PROFILE_GENERATE
+ libs::
+ $(INSTALL) ../tool/signmar$(BIN_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nss3$(DLL_SUFFIX) $(TESTROOT)/unit
+-ifndef MOZ_FOLD_LIBS
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nssutil3$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plc4$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nspr4$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plds4$(DLL_SUFFIX) $(TESTROOT)/unit
+-endif
+ endif
+ endif # Not Android
diff --git a/www/firefox-esr/files/patch-bug1320991 b/www/firefox-esr/files/patch-bug1320991
new file mode 100644
index 000000000000..6b9ccb5a1c3d
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1320991
@@ -0,0 +1,43 @@
+commit 454e2dbe1b4f
+Author: Mike Shal <mshal@mozilla.com>
+Date: Tue Dec 20 16:37:18 2016 -0500
+
+ Bug 1320991 - Support --with-system-{nss,nspr} in modules/libmar; r?glandium
+
+ The problem with the modules/libmar/tests/moz.build file when building
+ --with-system-nspr and --with-system-nss is that the nss libraries don't
+ exist in the tree, so they fail when trying to copy into the test
+ directory.
+
+ However, it turns out that the libraries copied into the test directory
+ aren't even used when building with an in-tree copy, because the
+ xpcshell launcher sets LD_LIBRARY_PATH to point to dist/bin. Since we
+ use the dist/bin copies anyway for an in-tree build, we can stop copying
+ them into the test directory and simultaneously fix the --with-system
+ build.
+
+ The DEFINES can also go away since this directory doesn't actually build
+ anything.
+
+ MozReview-Commit-ID: Bk2f28wc9ZJ
+---
+ modules/libmar/tests/moz.build | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git modules/libmar/tests/moz.build modules/libmar/tests/moz.build
+index ee72571b0c6b..9642553e8aa2 100644
+--- modules/libmar/tests/Makefile.in
++++ modules/libmar/tests/Makefile.in
+@@ -10,12 +10,5 @@ ifneq ($(OS_TARGET),Android)
+ ifndef MOZ_PROFILE_GENERATE
+ libs::
+ $(INSTALL) ../tool/signmar$(BIN_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nss3$(DLL_SUFFIX) $(TESTROOT)/unit
+-ifndef MOZ_FOLD_LIBS
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nssutil3$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plc4$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nspr4$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plds4$(DLL_SUFFIX) $(TESTROOT)/unit
+-endif
+ endif
+ endif # Not Android
diff --git a/www/firefox/files/patch-bug1320991 b/www/firefox/files/patch-bug1320991
index cb93f8c0d451..3c2daff9428f 100644
--- a/www/firefox/files/patch-bug1320991
+++ b/www/firefox/files/patch-bug1320991
@@ -1,8 +1,39 @@
---- modules/libmar/tests/moz.build.orig 2016-10-31 20:15:26 UTC
+commit 454e2dbe1b4f
+Author: Mike Shal <mshal@mozilla.com>
+Date: Tue Dec 20 16:37:18 2016 -0500
+
+ Bug 1320991 - Support --with-system-{nss,nspr} in modules/libmar; r?glandium
+
+ The problem with the modules/libmar/tests/moz.build file when building
+ --with-system-nspr and --with-system-nss is that the nss libraries don't
+ exist in the tree, so they fail when trying to copy into the test
+ directory.
+
+ However, it turns out that the libraries copied into the test directory
+ aren't even used when building with an in-tree copy, because the
+ xpcshell launcher sets LD_LIBRARY_PATH to point to dist/bin. Since we
+ use the dist/bin copies anyway for an in-tree build, we can stop copying
+ them into the test directory and simultaneously fix the --with-system
+ build.
+
+ The DEFINES can also go away since this directory doesn't actually build
+ anything.
+
+ MozReview-Commit-ID: Bk2f28wc9ZJ
+---
+ modules/libmar/tests/moz.build | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git modules/libmar/tests/moz.build modules/libmar/tests/moz.build
+index ee72571b0c6b..9642553e8aa2 100644
+--- modules/libmar/tests/moz.build
+++ modules/libmar/tests/moz.build
-@@ -9,21 +9,6 @@ XPCSHELL_TESTS_MANIFESTS += ['unit/xpcsh
- DEFINES['BIN_SUFFIX'] = CONFIG['BIN_SUFFIX']
+@@ -6,24 +6,7 @@
+ XPCSHELL_TESTS_MANIFESTS += ['unit/xpcshell.ini']
+
+-DEFINES['BIN_SUFFIX'] = CONFIG['BIN_SUFFIX']
+-
if CONFIG['OS_TARGET'] != 'Android':
- nss_files = ['nss3']
- if not CONFIG['MOZ_FOLD_LIBS']:
diff --git a/www/libxul/files/patch-bug1320991 b/www/libxul/files/patch-bug1320991
new file mode 100644
index 000000000000..6b9ccb5a1c3d
--- /dev/null
+++ b/www/libxul/files/patch-bug1320991
@@ -0,0 +1,43 @@
+commit 454e2dbe1b4f
+Author: Mike Shal <mshal@mozilla.com>
+Date: Tue Dec 20 16:37:18 2016 -0500
+
+ Bug 1320991 - Support --with-system-{nss,nspr} in modules/libmar; r?glandium
+
+ The problem with the modules/libmar/tests/moz.build file when building
+ --with-system-nspr and --with-system-nss is that the nss libraries don't
+ exist in the tree, so they fail when trying to copy into the test
+ directory.
+
+ However, it turns out that the libraries copied into the test directory
+ aren't even used when building with an in-tree copy, because the
+ xpcshell launcher sets LD_LIBRARY_PATH to point to dist/bin. Since we
+ use the dist/bin copies anyway for an in-tree build, we can stop copying
+ them into the test directory and simultaneously fix the --with-system
+ build.
+
+ The DEFINES can also go away since this directory doesn't actually build
+ anything.
+
+ MozReview-Commit-ID: Bk2f28wc9ZJ
+---
+ modules/libmar/tests/moz.build | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git modules/libmar/tests/moz.build modules/libmar/tests/moz.build
+index ee72571b0c6b..9642553e8aa2 100644
+--- modules/libmar/tests/Makefile.in
++++ modules/libmar/tests/Makefile.in
+@@ -10,12 +10,5 @@ ifneq ($(OS_TARGET),Android)
+ ifndef MOZ_PROFILE_GENERATE
+ libs::
+ $(INSTALL) ../tool/signmar$(BIN_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nss3$(DLL_SUFFIX) $(TESTROOT)/unit
+-ifndef MOZ_FOLD_LIBS
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nssutil3$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plc4$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nspr4$(DLL_SUFFIX) $(TESTROOT)/unit
+- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plds4$(DLL_SUFFIX) $(TESTROOT)/unit
+-endif
+ endif
+ endif # Not Android
diff --git a/www/seamonkey/files/patch-bug1320991 b/www/seamonkey/files/patch-bug1320991
index 400b8ad43e8d..ed0ed3be32ff 100644
--- a/www/seamonkey/files/patch-bug1320991
+++ b/www/seamonkey/files/patch-bug1320991
@@ -1,8 +1,39 @@
---- mozilla/modules/libmar/tests/moz.build.orig 2016-10-31 20:15:26 UTC
+commit 454e2dbe1b4f
+Author: Mike Shal <mshal@mozilla.com>
+Date: Tue Dec 20 16:37:18 2016 -0500
+
+ Bug 1320991 - Support --with-system-{nss,nspr} in modules/libmar; r?glandium
+
+ The problem with the modules/libmar/tests/moz.build file when building
+ --with-system-nspr and --with-system-nss is that the nss libraries don't
+ exist in the tree, so they fail when trying to copy into the test
+ directory.
+
+ However, it turns out that the libraries copied into the test directory
+ aren't even used when building with an in-tree copy, because the
+ xpcshell launcher sets LD_LIBRARY_PATH to point to dist/bin. Since we
+ use the dist/bin copies anyway for an in-tree build, we can stop copying
+ them into the test directory and simultaneously fix the --with-system
+ build.
+
+ The DEFINES can also go away since this directory doesn't actually build
+ anything.
+
+ MozReview-Commit-ID: Bk2f28wc9ZJ
+---
+ modules/libmar/tests/moz.build | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git modules/libmar/tests/moz.build modules/libmar/tests/moz.build
+index ee72571b0c6b..9642553e8aa2 100644
+--- mozilla/modules/libmar/tests/moz.build
+++ mozilla/modules/libmar/tests/moz.build
-@@ -9,21 +9,6 @@ XPCSHELL_TESTS_MANIFESTS += ['unit/xpcsh
- DEFINES['BIN_SUFFIX'] = CONFIG['BIN_SUFFIX']
+@@ -6,24 +6,7 @@
+ XPCSHELL_TESTS_MANIFESTS += ['unit/xpcshell.ini']
+
+-DEFINES['BIN_SUFFIX'] = CONFIG['BIN_SUFFIX']
+-
if CONFIG['OS_TARGET'] != 'Android':
- nss_files = ['nss3']
- if not CONFIG['MOZ_FOLD_LIBS']: