aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-13 19:52:06 +0800
committerJan Beich <jbeich@FreeBSD.org>2020-11-13 19:52:06 +0800
commite379690328aa44292633f1ca4533e21c74260ab3 (patch)
treed736cf9af46d7f3ed8e8087eb56346d04c63146d
parent101a9f7a84d3ea1188c6c1590e6efc09bcf59aa6 (diff)
downloadfreebsd-ports-gnome-e379690328aa44292633f1ca4533e21c74260ab3.tar.gz
freebsd-ports-gnome-e379690328aa44292633f1ca4533e21c74260ab3.tar.zst
freebsd-ports-gnome-e379690328aa44292633f1ca4533e21c74260ab3.zip
gecko: bump LLVM_DEFAULT to 11
Detach from tree-wide default as coordinating with other maintainers is expensive for little gain. User's choice is still respected. llvm11 has better Tier2 support, more optimizations, reduces package size and aligns with what contributors dogfood.
-rw-r--r--Mk/bsd.gecko.mk4
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox/Makefile2
4 files changed, 7 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 498c9f0bee3f..b58e697c52a9 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -92,6 +92,10 @@ MOZ_OPTIONS+= --with-libclang-path="${LOCALBASE}/llvm${LLVM_DEFAULT}/lib"
.if !exists(/usr/bin/llvm-objdump)
MOZ_EXPORT+= LLVM_OBJDUMP="${LOCALBASE}/bin/llvm-objdump${LLVM_DEFAULT}"
.endif
+# Ignore Mk/bsd.default-versions.mk but respect make.conf(5)
+.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mllvm*}
+LLVM_DEFAULT= 11 # bump if not latest release
+.endif
# Require newer Clang than what's in base system unless user opted out
. if ${CC} == cc && ${CXX} == c++ && exists(/usr/lib/libc++.so)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 1577b209ac02..2337eb630be7 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 78.4.3
+PORTREVISION= 1
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 849f7f9fd344..af4be2c8af81 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 78.5.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 99e9750995f7..0f9f77b4bfd9 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 83.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \