aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2004-05-25 22:28:00 +0800
committernetchild <netchild@FreeBSD.org>2004-05-25 22:28:00 +0800
commite379e8a0e075ea32ff735a6516a434341c1a090a (patch)
treea538aec6693719897deadf1421280cb4ec19c221
parent0871ae9bf9186414d4843700ace3e17a947f845f (diff)
downloadfreebsd-ports-gnome-e379e8a0e075ea32ff735a6516a434341c1a090a.tar.gz
freebsd-ports-gnome-e379e8a0e075ea32ff735a6516a434341c1a090a.tar.zst
freebsd-ports-gnome-e379e8a0e075ea32ff735a6516a434341c1a090a.zip
- Fix installation when CC is not set to "cc". Inspired by PR 66925.
- Use ARCH instead of MACHINE_ARCH to please portlint >= 2.5.9. Submitted by: marius
-rw-r--r--sysutils/sformat/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/sysutils/sformat/Makefile b/sysutils/sformat/Makefile
index 004d98ec6094..530b805cd106 100644
--- a/sysutils/sformat/Makefile
+++ b/sysutils/sformat/Makefile
@@ -21,14 +21,17 @@ USE_REINPLACE= yes
MAN1= sformat.1
MAKE_ENV= CCOM=${CC}
+SFMTTARGET= ${ARCH}-freebsd-${CC}
+
+.include <bsd.port.pre.mk>
post-extract:
.for i in config.guess config.sub
@${CP} ${PORTSDIR}/Templates/${i} ${WRKSRC}/conf
.endfor
-.if ${MACHINE_ARCH} != "i386" || ${CC} != "cc"
- @${LN} -s ${WRKSRC}/RULES/i386-freebsd-cc.rul \
- ${WRKSRC}/RULES/${MACHINE_ARCH}-freebsd-${CC}.rul
+.if ${ARCH} != "i386" || ${CC} != "cc"
+ @${LN} -sf ${WRKSRC}/RULES/i386-freebsd-cc.rul \
+ ${WRKSRC}/RULES/${SFMTTARGET}.rul
.endif
post-patch:
@@ -38,10 +41,10 @@ post-patch:
.endfor
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sformat/OBJ/${ARCH}-freebsd-cc/sformat \
+ @${INSTALL_PROGRAM} ${WRKSRC}/sformat/OBJ/${SFMTTARGET}/sformat \
${PREFIX}/bin
@${MKDIR} ${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/sformat/sformat.dat ${DATADIR}
@${INSTALL_MAN} ${WRKSRC}/sformat/sformat.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>