aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-10-12 14:57:34 +0800
committerlinimon <linimon@FreeBSD.org>2004-10-12 14:57:34 +0800
commite380106fe46813682fece951ddd5cb9c4346b684 (patch)
treec93d8245da6fc1df0d8a72001eb02dd9b48ad7cf
parent8936b92aca420e37cd653f3283a282ad1df8655c (diff)
downloadfreebsd-ports-gnome-e380106fe46813682fece951ddd5cb9c4346b684.tar.gz
freebsd-ports-gnome-e380106fe46813682fece951ddd5cb9c4346b684.tar.zst
freebsd-ports-gnome-e380106fe46813682fece951ddd5cb9c4346b684.zip
Update from version 1.2 to 1.3. For a list of changes see:
http://tclpad.sourceforge.net/docs/ChangeLog. PR: ports/71368 Submitted by: Antonio Bonifati <ant at venus dot deis dot unical dot it> (maintainer)
-rw-r--r--editors/tpad/Makefile33
-rw-r--r--editors/tpad/distinfo4
-rw-r--r--editors/tpad/pkg-descr11
-rw-r--r--editors/tpad/pkg-plist15
4 files changed, 48 insertions, 15 deletions
diff --git a/editors/tpad/Makefile b/editors/tpad/Makefile
index 2affc5c2ad59..81224f5a4a38 100644
--- a/editors/tpad/Makefile
+++ b/editors/tpad/Makefile
@@ -6,26 +6,44 @@
#
PORTNAME= tpad
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= editors tcl84 tk84
-MASTER_SITES= http://monitor.deis.unical.it/ant/tpad/ \
- http://queen.rett.polimi.it/~ant/tcl/script/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://monitor.deis.unical.it/ant/tpad/ \
+ http://queen.rett.polimi.it/~ant/tcl/script/ \
+ http://sarovar.org/download.php/382/
+MASTER_SITE_SUBDIR= tclpad
MAINTAINER= ant@monitor.deis.unical.it
-COMMENT= Windows XP (TM) Notepad clone written in Tcl/Tk
+COMMENT= Windows XP (TM) enhanced Notepad clone written in Tcl/Tk
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/MESSAGE
-PORTDOCS= ChangeLog conf.html index.html intro.html keys.html \
- log.html mouse.html todo tpad.html
+PORTDOCS= ChangeLog bug.html conf.html embed.html index.html intro.html \
+ keys.html log.html mouse.html tidy.html tidy.png todo tpad.html
MAN1= tpad.1
MLINKS= tpad.1 tview.1
+PLIST_SUB= LIBDIR=lib/tpad${PORTVERSION}
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/bin/tpad ${PREFIX}/bin/tpad
+ @${MKDIR} ${PREFIX}/lib/tpad${PORTVERSION}/msgs
+ cd ${WRKDIR}/lib/tpad${PORTVERSION}; \
+ for libfile in *.tcl; do \
+ ${INSTALL_DATA} $$libfile ${PREFIX}/lib/tpad${PORTVERSION}; \
+ done
+ cd ${WRKDIR}/lib/tpad${PORTVERSION}/msgs; \
+ for msgfile in *.msg; do \
+ ${INSTALL_DATA} $$msgfile ${PREFIX}/lib/tpad${PORTVERSION}/msgs; \
+ done
+ @${MKDIR} ${DATADIR}
+ cd ${WRKDIR}/share/tpad/; \
+ for datafile in *; do \
+ ${INSTALL_DATA} $$datafile ${DATADIR}; \
+ done
post-install:
${TEST} -e ${PREFIX}/bin/tview || (cd ${PREFIX}/bin ; ${LN} -s tpad tview)
@@ -38,8 +56,7 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/share/doc/tpad/${docfile} ${DOCSDIR}
.endfor
.endif
- ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf \
- ${PREFIX}/etc/tpad.conf.sample
+ ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf ${PREFIX}/etc/tpad.conf.sample
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/tpad/distinfo b/editors/tpad/distinfo
index 366779facb1d..4b6de71fd0f2 100644
--- a/editors/tpad/distinfo
+++ b/editors/tpad/distinfo
@@ -1,2 +1,2 @@
-MD5 (tpad-1.2.tar.gz) = 95a5d1b74866a5268696ac97d9698255
-SIZE (tpad-1.2.tar.gz) = 21451
+MD5 (tpad-1.3.tar.gz) = 8ddb7a2511ed98c71aa43a19b284efd8
+SIZE (tpad-1.3.tar.gz) = 61217
diff --git a/editors/tpad/pkg-descr b/editors/tpad/pkg-descr
index fd3874ff290e..6b2c6aaaa72a 100644
--- a/editors/tpad/pkg-descr
+++ b/editors/tpad/pkg-descr
@@ -1,10 +1,11 @@
-The executable tpad is a wish(1) shell script.
+Apart from all the features Notepad has, tpad adds
+plugins to invoke some common text utilities without
+leaving the editor, an Ascii table, a tip database
+and support for regexps. It also is fully configurable.
-I think the only difference with Notepad
-is that it doesn't limit the size of the
-file to edit :-)
+The executable `tpad' is a wish(1) shell script.
WWW: http://monitor.deis.unical.it/ant/tpad/
- Antonio Bonifati
-ant@monitor.deis.unical.it
+ant at monitor.deis.unical.it
diff --git a/editors/tpad/pkg-plist b/editors/tpad/pkg-plist
index c8656438f985..080a5701d452 100644
--- a/editors/tpad/pkg-plist
+++ b/editors/tpad/pkg-plist
@@ -1,3 +1,18 @@
bin/tpad
bin/tview
etc/tpad.conf.sample
+%%DATADIR%%/Makefile
+%%DATADIR%%/tpad-tips
+%%DATADIR%%/tpad-tips.dat
+%%LIBDIR%%/BSDfmt.tcl
+%%LIBDIR%%/GNUfmt.tcl
+%%LIBDIR%%/ascii.tcl
+%%LIBDIR%%/msgs/en.msg
+%%LIBDIR%%/msgs/it.msg
+%%LIBDIR%%/pkgIndex.tcl
+%%LIBDIR%%/tidy.tcl
+%%LIBDIR%%/tpad.tcl
+%%LIBDIR%%/xmlwf.tcl
+@dirrm %%DATADIR%%
+@dirrm %%LIBDIR%%/msgs
+@dirrm %%LIBDIR%%