aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-31 17:02:06 +0800
committermiwi <miwi@FreeBSD.org>2014-01-31 17:02:06 +0800
commite3ccb3658ae129fa973133d21f29c4e2ed2eac46 (patch)
treed8a3a6bbd10800d25976b2cee85241a90fda39d2
parent53246de6086541b85fdaaedd4eef475415e75c83 (diff)
downloadfreebsd-ports-gnome-e3ccb3658ae129fa973133d21f29c4e2ed2eac46.tar.gz
freebsd-ports-gnome-e3ccb3658ae129fa973133d21f29c4e2ed2eac46.tar.zst
freebsd-ports-gnome-e3ccb3658ae129fa973133d21f29c4e2ed2eac46.zip
- Stage support
- Convert to USES
-rw-r--r--devel/ossp-ex/Makefile13
-rw-r--r--devel/ossp-ex/pkg-plist1
-rw-r--r--net/arp-scan/Makefile4
-rw-r--r--net/arp-scan/pkg-plist5
-rw-r--r--net/libtrace/Makefile9
-rw-r--r--net/libtrace/pkg-plist16
-rw-r--r--net/urelay/Makefile6
7 files changed, 27 insertions, 27 deletions
diff --git a/devel/ossp-ex/Makefile b/devel/ossp-ex/Makefile
index 1f97da323700..49711d4ac438 100644
--- a/devel/ossp-ex/Makefile
+++ b/devel/ossp-ex/Makefile
@@ -11,20 +11,11 @@ PKGNAMEPREFIX= ossp-
MAINTAINER= ports@FreeBSD.org
COMMENT= OSSP ex is a small exception handling library for use in C
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAN3= ex.3
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha"
-BROKEN= Does not compile on alpha
-.endif
-
check: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ossp-ex/pkg-plist b/devel/ossp-ex/pkg-plist
index 295b087cc41f..b8abd5221082 100644
--- a/devel/ossp-ex/pkg-plist
+++ b/devel/ossp-ex/pkg-plist
@@ -4,3 +4,4 @@ lib/libex.a
lib/libex.la
lib/libex.so
lib/libex.so.10
+man/man3/ex.3.gz
diff --git a/net/arp-scan/Makefile b/net/arp-scan/Makefile
index e33aa30bf350..2d8c80590cf8 100644
--- a/net/arp-scan/Makefile
+++ b/net/arp-scan/Makefile
@@ -12,8 +12,4 @@ COMMENT= ARP Scanning and Fingerprinting Tool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAN1= arp-scan.1 get-oui.1 get-iab.1 arp-fingerprint.1
-MAN5= mac-vendor.5
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/arp-scan/pkg-plist b/net/arp-scan/pkg-plist
index e059ab3fc2cb..8ce70ee6d4fe 100644
--- a/net/arp-scan/pkg-plist
+++ b/net/arp-scan/pkg-plist
@@ -5,4 +5,9 @@ bin/arp-fingerprint
%%DATADIR%%/ieee-oui.txt
%%DATADIR%%/ieee-iab.txt
%%DATADIR%%/mac-vendor.txt
+man/man1/arp-fingerprint.1.gz
+man/man1/arp-scan.1.gz
+man/man1/get-iab.1.gz
+man/man1/get-oui.1.gz
+man/man5/mac-vendor.5.gz
@dirrm %%DATADIR%%
diff --git a/net/libtrace/Makefile b/net/libtrace/Makefile
index be3794759995..e75bf5c0bdef 100644
--- a/net/libtrace/Makefile
+++ b/net/libtrace/Makefile
@@ -15,16 +15,9 @@ CONFIGURE_ARGS= --with-libpcap=${LOCALBASE}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GMAKE= yes
-
-MAN1= traceanon.1 traceconvert.1 tracefilter.1 tracemerge.1 \
- tracereport.1 tracertstats.1 tracesplit.1 tracepktdump.1 \
- tracesplit_dir.1 tracestats.1 tracesummary.1 tracereplay.1 \
- tracediff.1 traceends.1 tracetop.1 tracetopends.1
-
+USES= gmake
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
${WRKSRC}/configure
diff --git a/net/libtrace/pkg-plist b/net/libtrace/pkg-plist
index d95e3237b7a9..9722cd291426 100644
--- a/net/libtrace/pkg-plist
+++ b/net/libtrace/pkg-plist
@@ -188,4 +188,20 @@ lib/libwandio.a
lib/libwandio.la
lib/libwandio.so
lib/libwandio.so.1
+man/man1/traceanon.1.gz
+man/man1/traceconvert.1.gz
+man/man1/tracediff.1.gz
+man/man1/traceends.1.gz
+man/man1/tracefilter.1.gz
+man/man1/tracemerge.1.gz
+man/man1/tracepktdump.1.gz
+man/man1/tracereplay.1.gz
+man/man1/tracereport.1.gz
+man/man1/tracertstats.1.gz
+man/man1/tracesplit.1.gz
+man/man1/tracesplit_dir.1.gz
+man/man1/tracestats.1.gz
+man/man1/tracesummary.1.gz
+man/man1/tracetop.1.gz
+man/man1/tracetopends.1.gz
@dirrm lib/libpacketdump
diff --git a/net/urelay/Makefile b/net/urelay/Makefile
index e0cfb1873b9b..a327fe59d628 100644
--- a/net/urelay/Makefile
+++ b/net/urelay/Makefile
@@ -9,9 +9,7 @@ MASTER_SITES= http://devel.ringlet.net/net/urelay/
MAINTAINER= ports@FreeBSD.org
COMMENT= An UCSPI-based TCP forwarder
-MAN1= urelay.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/urelay
+PLIST_FILES= bin/urelay \
+ man/man1/urelay.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>