aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-03 03:48:03 +0800
committerpav <pav@FreeBSD.org>2004-07-03 03:48:03 +0800
commite3e947d79a9fb166ea4adc4cf86aa5fdb1b699b5 (patch)
treeb1530bf54d38907731bc67ac6255ca5f8a7165e9
parent7cd62bec681dd86c9e14fe9a58e10c4edffa9018 (diff)
downloadfreebsd-ports-gnome-e3e947d79a9fb166ea4adc4cf86aa5fdb1b699b5.tar.gz
freebsd-ports-gnome-e3e947d79a9fb166ea4adc4cf86aa5fdb1b699b5.tar.zst
freebsd-ports-gnome-e3e947d79a9fb166ea4adc4cf86aa5fdb1b699b5.zip
Add polypuzzle, a small polygon puzzle written in Tk.
PR: ports/68510 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
-rw-r--r--games/Makefile1
-rw-r--r--games/polypuzzle/Makefile43
-rw-r--r--games/polypuzzle/distinfo2
-rw-r--r--games/polypuzzle/files/patch-polypuzzle13
-rw-r--r--games/polypuzzle/pkg-descr5
-rw-r--r--games/polypuzzle/pkg-plist25
6 files changed, 89 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b67eb8529163..ed56cbc7a6a1 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -344,6 +344,7 @@
SUBDIR += pinball
SUBDIR += pipenightdreams
SUBDIR += pmars
+ SUBDIR += polypuzzle
SUBDIR += powermanga
SUBDIR += powerpak
SUBDIR += pp
diff --git a/games/polypuzzle/Makefile b/games/polypuzzle/Makefile
new file mode 100644
index 000000000000..72322a82057a
--- /dev/null
+++ b/games/polypuzzle/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: polypuzzle
+# Date created: 30 June 2004
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= polypuzzle
+PORTVERSION= 1.5.1
+CATEGORIES= games tcl84 tk84
+MASTER_SITES= ftp://ibiblio.org/pub/Linux/games/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Tessellation puzzle game
+
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+DOC_FILES= About Bugs Changelog Copyright Install Math Readme Thanks Todo
+DATA_FILES= menus pieces.3x20 pieces.783 pieces.bonus pieces.colours \
+ pieces.flower pieces.large pieces.medium pieces.monster \
+ pieces.small pieces.square pieces.star pieces.triangle
+
+pre-install:
+ @${REINPLACE_CMD} -e "s:%%DATADIR%%:${DATADIR}:g" ${WRKSRC}/polypuzzle
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/polypuzzle ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for f in ${DATA_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/polypuzzle/distinfo b/games/polypuzzle/distinfo
new file mode 100644
index 000000000000..b216513cb8a8
--- /dev/null
+++ b/games/polypuzzle/distinfo
@@ -0,0 +1,2 @@
+MD5 (polypuzzle-1.5.1.tgz) = 02c8d6ed7ff40930cf9362b88fbf9f8d
+SIZE (polypuzzle-1.5.1.tgz) = 14385
diff --git a/games/polypuzzle/files/patch-polypuzzle b/games/polypuzzle/files/patch-polypuzzle
new file mode 100644
index 000000000000..6d4bf4e8a3c2
--- /dev/null
+++ b/games/polypuzzle/files/patch-polypuzzle
@@ -0,0 +1,13 @@
+--- polypuzzle.orig Fri Jun 18 11:51:04 2004
++++ polypuzzle Wed Jun 30 13:46:07 2004
+@@ -1,8 +1,8 @@
+ #/bin/sh
+ # the next line restarts using tclsh \
+-exec wish "$0" "$@"
++exec wish8.4 "$0" "$@"
+
+-if {[file isdirectory /usr/local/lib/polypuzzle]} {cd /usr/local/lib/polypuzzle}
++if {[file isdirectory %%DATADIR%%]} {cd %%DATADIR%%}
+
+ source pieces.colours
+ set colour(bg) azure3 ;# background colour
diff --git a/games/polypuzzle/pkg-descr b/games/polypuzzle/pkg-descr
new file mode 100644
index 000000000000..b19e65738dee
--- /dev/null
+++ b/games/polypuzzle/pkg-descr
@@ -0,0 +1,5 @@
+Tessellation puzzle inspired by Beat The Computer.
+Puzzles implemented include several based on
+squares, hexagons and equilateral triangles.
+
+WWW: ftp://ibiblio.org/pub/Linux/games/
diff --git a/games/polypuzzle/pkg-plist b/games/polypuzzle/pkg-plist
new file mode 100644
index 000000000000..34fc6615a755
--- /dev/null
+++ b/games/polypuzzle/pkg-plist
@@ -0,0 +1,25 @@
+bin/polypuzzle
+%%DATADIR%%/menus
+%%DATADIR%%/pieces.3x20
+%%DATADIR%%/pieces.783
+%%DATADIR%%/pieces.bonus
+%%DATADIR%%/pieces.colours
+%%DATADIR%%/pieces.flower
+%%DATADIR%%/pieces.large
+%%DATADIR%%/pieces.medium
+%%DATADIR%%/pieces.monster
+%%DATADIR%%/pieces.small
+%%DATADIR%%/pieces.square
+%%DATADIR%%/pieces.star
+%%DATADIR%%/pieces.triangle
+%%PORTDOCS%%%%DOCSDIR%%/About
+%%PORTDOCS%%%%DOCSDIR%%/Bugs
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/Copyright
+%%PORTDOCS%%%%DOCSDIR%%/Install
+%%PORTDOCS%%%%DOCSDIR%%/Math
+%%PORTDOCS%%%%DOCSDIR%%/Readme
+%%PORTDOCS%%%%DOCSDIR%%/Thanks
+%%PORTDOCS%%%%DOCSDIR%%/Todo
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%