aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-10-20 09:16:16 +0800
committercpm <cpm@FreeBSD.org>2016-10-20 09:16:16 +0800
commite43132fe7b5fcb83472b4cc4d96e5fd41ddc810d (patch)
treedf5e6113ace4d070ea7221c52ffe49eae350ddea
parent1d0a495e26b0f149e48fb1fe7dbdb6a79814b609 (diff)
downloadfreebsd-ports-gnome-e43132fe7b5fcb83472b4cc4d96e5fd41ddc810d.tar.gz
freebsd-ports-gnome-e43132fe7b5fcb83472b4cc4d96e5fd41ddc810d.tar.zst
freebsd-ports-gnome-e43132fe7b5fcb83472b4cc4d96e5fd41ddc810d.zip
security/keepassx2: Update to 2.0.3
- Update to 2.0.3 - Add LICENSE block - Register conflicts between keepassx2 and keepassx-devel - Use CMAKE arguments for ZLIB_SUPPORTS_GZIP instead patch-CMakeLists.txt PR: 212944 Submitted by: Eric Camachat <eric@camachat.org> Approved by: koobs (mentor) MFH: 2016Q4
-rw-r--r--security/keepassx2/Makefile15
-rw-r--r--security/keepassx2/distinfo5
-rw-r--r--security/keepassx2/files/patch-CMakeLists.txt15
3 files changed, 15 insertions, 20 deletions
diff --git a/security/keepassx2/Makefile b/security/keepassx2/Makefile
index 18b3527ff5c4..c94206da69fb 100644
--- a/security/keepassx2/Makefile
+++ b/security/keepassx2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= keepassx
-PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTVERSION= 2.0.3
PORTEPOCH= 2
CATEGORIES= security
MASTER_SITES= https://www.keepassx.org/releases/${PORTVERSION}/
@@ -12,9 +11,18 @@ PKGNAMESUFFIX= 2
MAINTAINER= eric@camachat.org
COMMENT= Cross Platform Password Manager
+LICENSE= BOOST-1.0 BSD3CLAUSE CC0-1.0 GPLv2 GPLv3 LGPL21 LGPL3 NOKIA-LGPL-EXCEPTION
+LICENSE_COMB= multi
+LICENSE_NAME_BOOST-1.0= Boost Software License version 1.0
+LICENSE_NAME_NOKIA-LGPL-EXCEPTION= Nokia Qt LGPL Exception version 1.1
+LICENSE_FILE_BOOST-1.0= ${WRKSRC}/LICENSE.BOOST-1.0
+LICENSE_FILE_NOKIA-LGPL-EXCEPTION= ${WRKSRC}/LICENSE.NOKIA-LGPL-EXCEPTION
+LICENSE_PERMS_BOOST-1.0= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_NOKIA-LGPL-EXCEPTION= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
LIB_DEPENDS= libgcrypt.so:security/libgcrypt
-CONFLICTS_INSTALL= keepassx-0.*
+CONFLICTS_INSTALL= keepassx-0.* keepassx-devel-*
USES= cmake compiler:features desktop-file-utils shared-mime-info
USE_LDCONFIG= yes
@@ -29,5 +37,6 @@ USE_XORG= ice inputproto sm x11 xcursor xext xfixes xi xrandr xrender \
.if !${COMPILER_FEATURES:Mc++0x}
CMAKE_ARGS+= -DWITH_CXX11:BOOL=OFF
.endif
+CMAKE_ARGS+= -DZLIB_SUPPORTS_GZIP:BOOL=ON
.include <bsd.port.post.mk>
diff --git a/security/keepassx2/distinfo b/security/keepassx2/distinfo
index 2f532e44ad9e..09ba5335c9ec 100644
--- a/security/keepassx2/distinfo
+++ b/security/keepassx2/distinfo
@@ -1,2 +1,3 @@
-SHA256 (keepassx-2.0.2.tar.gz) = 204bdcf49c72078cd6f02b4f29b062923cca9e7b2d3551f2bf352763daa236b8
-SIZE (keepassx-2.0.2.tar.gz) = 1532353
+TIMESTAMP = 1476902766
+SHA256 (keepassx-2.0.3.tar.gz) = 23ffb4ae360c58aa139943442d175bc6b8f08e6a876ae76c4543ab983a6647c5
+SIZE (keepassx-2.0.3.tar.gz) = 1540235
diff --git a/security/keepassx2/files/patch-CMakeLists.txt b/security/keepassx2/files/patch-CMakeLists.txt
deleted file mode 100644
index bc28c37c7f8a..000000000000
--- a/security/keepassx2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- CMakeLists.txt.orig 2013-10-29 23:22:19.870422125 +0000
-+++ CMakeLists.txt 2013-10-29 23:22:29.394420605 +0000
-@@ -175,9 +175,9 @@
-
- int main() { return 0; }" ZLIB_SUPPORTS_GZIP)
-
--if(NOT ZLIB_SUPPORTS_GZIP)
-- message(FATAL_ERROR "zlib 1.2.x or higher is required to use the gzip format")
--endif()
-+#if(NOT ZLIB_SUPPORTS_GZIP)
-+# message(FATAL_ERROR "zlib 1.2.x or higher is required to use the gzip format")
-+#endif()
-
- if(UNIX)
- check_cxx_source_compiles("#include <sys/prctl.h>