aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-20 22:35:57 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-20 22:35:57 +0800
commite434a250b6633ad6da96d97eaa211312e17539dc (patch)
treee16428fdb73f48acce12d201399969c6f11a325f
parent226c0ca8b78797c3baad8fcd3e310d1bad2fc9e2 (diff)
downloadfreebsd-ports-gnome-e434a250b6633ad6da96d97eaa211312e17539dc.tar.gz
freebsd-ports-gnome-e434a250b6633ad6da96d97eaa211312e17539dc.tar.zst
freebsd-ports-gnome-e434a250b6633ad6da96d97eaa211312e17539dc.zip
Remove BROKEN on Tier-2 systems statements which no longer true at least
on PowerPC (verified for all of them) and some also on SPARC (whenever I was able to test those on flame.freebsd.org) and even IA64 (which should be OK to remove anyways, because it was never really supported system in ports land and was officially killed in -CURRENT a while ago.
-rw-r--r--audio/snd/Makefile2
-rw-r--r--audio/zynaddsubfx/Makefile4
-rw-r--r--databases/spatialite/Makefile2
-rw-r--r--emulators/advancemame/Makefile2
-rw-r--r--emulators/tpm-emulator/Makefile2
-rw-r--r--games/megaglest/Makefile8
-rw-r--r--games/supertuxkart/Makefile2
-rw-r--r--lang/gauche/Makefile4
-rw-r--r--mail/wmmaiload/Makefile4
-rw-r--r--multimedia/motion/Makefile4
-rw-r--r--net/widentd/Makefile2
-rw-r--r--security/polarssl/Makefile2
-rw-r--r--security/suricata/Makefile4
-rw-r--r--security/zxid/Makefile3
-rw-r--r--sysutils/abgx360/Makefile6
-rw-r--r--textproc/groonga/Makefile4
-rw-r--r--www/gatling/Makefile4
-rw-r--r--www/shellinabox/Makefile2
-rw-r--r--x11-fm/rodent/Makefile8
19 files changed, 4 insertions, 65 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 653b7fd89b85..ca994514e0bb 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -31,8 +31,6 @@ CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-BROKEN_sparc64= does not compile on sparc64
-
FFTW3_LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3
FFTW3_CONFIGURE_WITH= fftw
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index 815365374309..6d68ddf6a642 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -16,10 +16,6 @@ LICENSE= GPLv2
LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
libmxml.so:${PORTSDIR}/textproc/mxml
-BROKEN_ia64= invokes i386 asm
-BROKEN_powerpc= invokes i386 asm
-BROKEN_sparc64= invokes i386 asm
-
USES= tar:bzip2 cmake pkgconfig
OPTIONS_DEFINE= JACK GUI PORTAUDIO LASH LO DOCS EXAMPLES
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 4fec8e1e5187..1e31e66551e7 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -38,6 +38,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/configure
-BROKEN_powerpc= Does not compile on powerpc: invokes i386 assembler
-
.include <bsd.port.mk>
diff --git a/emulators/advancemame/Makefile b/emulators/advancemame/Makefile
index 606421919c53..eb90ef61796a 100644
--- a/emulators/advancemame/Makefile
+++ b/emulators/advancemame/Makefile
@@ -35,8 +35,6 @@ OPTIONS_DEFAULT=FREETYPE
FREETYPE_CONFIGURE_ENABLE= freetype
FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-BROKEN_powerpc= Does not compile on powerpc
-
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|-pthread|' ${WRKSRC}/configure
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index f11e90ee9654..4ba01ff56ef3 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -27,8 +27,6 @@ GROUPS= _tss
SUB_LIST= USERS="${USERS}" GROUPS="${GROUPS}"
PLIST_SUB= USERS="${USERS}" GROUPS="${GROUPS}"
-BROKEN_powerpc= Does not compile on powerpc
-
post-install:
@${MKDIR} ${STAGEDIR}/var/run/tpm
@${MKDIR} ${STAGEDIR}${PREFIX}/var/db/tpm
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 4d6fc3792fc1..70c33fa35215 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -63,10 +63,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/source/glest_map_editor/megaglest_editor ${STAGEDIR}${PREFIX}/bin/megaglest_editor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64: unrecognized compiler flags
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index c509eb3493b9..6d6b638cec01 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -18,8 +18,6 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libcurl.so:${PORTSDIR}/ftp/curl \
libpng.so:${PORTSDIR}/graphics/png
-BROKEN_powerpc= does not configure on powerpc
-
USES= alias cmake compiler:c++11-lib dos2unix gettext \
gmake jpeg openal:al pkgconfig tar:xz
USE_GL= gl glu
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 426aa5fbeace..1730bf634f15 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -31,10 +31,6 @@ MAKE_ENV+= CCACHE_CPP2=1
INFO= gauche-refe gauche-refj
-BROKEN_ia64= Does not build with ${ARCH}
-BROKEN_powerpc= Does not build with ${ARCH}
-BROKEN_sparc= Does not build with ${ARCH}
-
OPTIONS_DEFINE= GDBM THREADS SLIB
OPTIONS_RADIO= MULTIBYTE
OPTIONS_RADIO_MULTIBYTE= EUCJP SJIS UTF8
diff --git a/mail/wmmaiload/Makefile b/mail/wmmaiload/Makefile
index d646bd9be91e..92a02e61cc9c 100644
--- a/mail/wmmaiload/Makefile
+++ b/mail/wmmaiload/Makefile
@@ -40,10 +40,6 @@ MAKE_ENV+= GTK_CFLAGS="pkg-config --cflags gtk+" \
GTK_LIBS="pkg-config --libs gtk+"
.endif
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
's| =| ?=|'
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index abbbc1520f56..cf588bb4dc46 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -80,10 +80,6 @@ CONFIGURE_ARGS+=--without-pgsql
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure.in
diff --git a/net/widentd/Makefile b/net/widentd/Makefile
index 10718dd393d2..fc8309a29471 100644
--- a/net/widentd/Makefile
+++ b/net/widentd/Makefile
@@ -18,6 +18,4 @@ MAKE_ENV+= NO_WERROR="defined"
PLIST_FILES= sbin/widentd man/man8/widentd.8.gz
USE_RC_SUBR= widentd
-BROKEN_powerpc= Does not compile on powerpc
-
.include <bsd.port.mk>
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index bcbf6f0d7165..a4a643704a96 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -57,6 +57,4 @@ post-install-DOCS-on:
TEST_USES= perl5
-BROKEN_powerpc= Does not compile on powerpc
-
.include <bsd.port.mk>
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index 3c7d592da47d..acea0ec77b3f 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -116,10 +116,6 @@ LOGS_DIR?= /var/log/${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
pre-patch:
${CP} ${FILESDIR}/ax_check_compile_flag.m4 ${WRKSRC}/m4
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index 8e5071ed428d..85b1f23edbca 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -28,9 +28,6 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include -D_LSEEK_DECLARED -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
-BROKEN_powerpc= Does not build on ${ARCH}
-BROKEN_sparc64= Does not build on ${ARCH}
-
OPTIONS_DEFINE= DOCS
ZXID_BINS= smime zxcall zxcot zxdecode zxencdectest zxidhlo \
diff --git a/sysutils/abgx360/Makefile b/sysutils/abgx360/Makefile
index 2c61b555cd56..7071623652f2 100644
--- a/sysutils/abgx360/Makefile
+++ b/sysutils/abgx360/Makefile
@@ -12,14 +12,10 @@ COMMENT= Verify and repair Xbox 360 backup images
BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
-BROKEN_ia64= does not compile
-BROKEN_powerpc= does not compile
-BROKEN_sparc64= does not compile
+GNU_CONFIGURE= yes
PLIST_FILES= bin/abgx360
-GNU_CONFIGURE= yes
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/abgx360 ${STAGEDIR}${PREFIX}/bin
diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile
index a7dda45f4330..0ce9ea3252f1 100644
--- a/textproc/groonga/Makefile
+++ b/textproc/groonga/Makefile
@@ -30,10 +30,6 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-BROKEN_ia64= does not compile on ia64
-BROKEN_powerpc= does not compile on powerpc
-BROKEN_sparc64= does not compile on sparc64
-
OPTIONS_DEFINE= MECAB SUGGEST
OPTIONS_DEFAULT= MECAB SUGGEST
OPTIONS_SUB= yes
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 4881710b8a1f..ad559507faef 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -80,10 +80,6 @@ MAKE_ENV+= DEBUG=1
STRIP=
.endif
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
PLIST_FILES+= ${bin:S,^,bin/,} ${sbin:S,^,sbin/,} sbin/gatling_wrapper
pre-install:
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index 4db8ef306d73..5ffd26104cc5 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -33,8 +33,6 @@ SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
NOLOGIN_CONFIGURE_ON= --disable-login
-BROKEN_powerpc= Does not load on powerpc
-
.include <bsd.port.options.mk>
post-patch:
diff --git a/x11-fm/rodent/Makefile b/x11-fm/rodent/Makefile
index d52428ef2353..7ec8a9d14905 100644
--- a/x11-fm/rodent/Makefile
+++ b/x11-fm/rodent/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= x11-fm
MASTER_SITES= SF/xffm/${PORTVERSION}
MAINTAINER= rodrigo@FreeBSD.org
-COMMENT= Fast, small and powerful file manager
+COMMENT= Fast, small, and powerful file manager
LICENSE= GPLv3
@@ -21,7 +21,7 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
USES= desktop-file-utils gmake libtool:keepla pkgconfig tar:bzip2 shebangfix
USE_GNOME= glib20 gtk20 librsvg2 libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--docdir=${DOCSDIR}
+CONFIGURE_ARGS= --docdir=${DOCSDIR}
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@@ -39,8 +39,4 @@ NLS_CONFIGURE_ENABLE= nls
# ${REINPLACE_CMD} -e 's,^\(docdir = \).*,\1${DOCSDIR},' \
# ${WRKSRC}/Build/share/Makefile.in
-.for a in ia64 powerpc sparc63
-BROKEN_${a}= Does not compile on ia64, powerpc, or sparc64
-.endfor
-
.include <bsd.port.mk>