aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2008-07-21 02:40:24 +0800
committerjohans <johans@FreeBSD.org>2008-07-21 02:40:24 +0800
commite4d01821feaf975737d498e9260a22bb6c68b8e8 (patch)
treed8461fb5119c9d11f34b32dea5687d872755942d
parent2445f3de4c2844c3b0f362e1c82f0dcabcf036d0 (diff)
downloadfreebsd-ports-gnome-e4d01821feaf975737d498e9260a22bb6c68b8e8.tar.gz
freebsd-ports-gnome-e4d01821feaf975737d498e9260a22bb6c68b8e8.tar.zst
freebsd-ports-gnome-e4d01821feaf975737d498e9260a22bb6c68b8e8.zip
- Update to 0.7.3
- Use OCAML macros - Optional install of examples - Claim maintainership
-rw-r--r--devel/ocaml-magic/Makefile62
-rw-r--r--devel/ocaml-magic/distinfo6
-rw-r--r--devel/ocaml-magic/pkg-plist6
3 files changed, 29 insertions, 45 deletions
diff --git a/devel/ocaml-magic/Makefile b/devel/ocaml-magic/Makefile
index 8e711d842adf..007125488eb6 100644
--- a/devel/ocaml-magic/Makefile
+++ b/devel/ocaml-magic/Makefile
@@ -6,60 +6,50 @@
#
PORTNAME= magic
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
PKGNAMEPREFIX= ocaml-
-DISTNAME= OCaml-Magic-${PORTVERSION}
+DISTNAME= ${PKGNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@stack.nl
COMMENT= An OCaml binding for libmagic(3)
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAML_LDCONFIG= yes
-ALL_TARGET= opt
-INSTALL_TARGET= install-opt
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-# This really is overzealous but I work this way
-.if !exists(/usr/lib/libmagic.so)
-LIB_DEPENDS+= magic:${PORTSDIR}/sysutils/file
-.endif
-
.ifndef(NOPORTDOCS)
ALL_TARGET+= doc
-INSTALL_TARGET+= install-doc
-
PORTDOCS= *
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
.endif
-LIB_STUB_FILES= \
- dllmagic_stub.so
-
-post-configure:
-# LIB safeness
- ${REINPLACE_CMD} -E \
- -e's|(-lmagic[[:space:]]+)|\1 -lz |' \
- ${WRKSRC}/Makefile
-# CFLAGS,PREFIX safeness
- @${REINPLACE_CMD} -E \
- -e 's|^PREFIX.+$$||' \
- -e 's|\$$\(shell[[:space:]]+ocamlc[[:space:]]+-version\)||' \
- -e 's|^(DOCDIR).*$$|\1 = ${DOCSDIR}|' \
- -e 's,^((OCAMLC|OCAMLOPT|OCAMLDEP|OCAMLDOC|OCAMLMKLIB)[^=]*)[[:space:]]*=[[:space:]]*(.+)$$,\1 = ${LOCALBASE}/bin/\3,' \
- ${WRKSRC}/Makefile.config
+.ifndef(NOPORTEXAMPLES)
+ALL_TARGET+= examples
+PORTEXAMPLES= *
+EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
+.endif
-post-install:
-# stub files
- @${MKDIR} ${PREFIX}/lib/ocaml/stublibs
-.for file in ${LIB_STUB_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/lib/ocaml/stublibs
-.endfor
+# This really is overzealous but I work this way
+.if !exists(/usr/lib/libmagic.so)
+LIB_DEPENDS+= magic:${PORTSDIR}/sysutils/file
+.endif
.include <bsd.port.pre.mk>
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
+.ifndef(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/ocaml-magic/distinfo b/devel/ocaml-magic/distinfo
index 5e4679830fcb..d606b2e56ff3 100644
--- a/devel/ocaml-magic/distinfo
+++ b/devel/ocaml-magic/distinfo
@@ -1,3 +1,3 @@
-MD5 (OCaml-Magic-0.6.tar.gz) = 121f0e66ff30fe3cf2e2907c674a54b9
-SHA256 (OCaml-Magic-0.6.tar.gz) = 58bf09f68e52c0031ed4fd83162767456d8fe021969f456b269afeb9ae84d78f
-SIZE (OCaml-Magic-0.6.tar.gz) = 16577
+MD5 (ocaml-magic-0.7.3.tar.gz) = 5b8a4d149fe8ce095ab8115f2e49beba
+SHA256 (ocaml-magic-0.7.3.tar.gz) = fd09e2208b1483062919f8aa57d24427584729a6a00b6cdf3133fda425870fbc
+SIZE (ocaml-magic-0.7.3.tar.gz) = 54888
diff --git a/devel/ocaml-magic/pkg-plist b/devel/ocaml-magic/pkg-plist
deleted file mode 100644
index ace69f877e97..000000000000
--- a/devel/ocaml-magic/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-lib/ocaml/magic.cmi
-lib/ocaml/magic.cmxa
-lib/ocaml/magic.mli
-lib/ocaml/stublibs/dllmagic_stub.so
-@dirrmtry lib/ocaml/stublibs
-@dirrmtry lib/ocaml