aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2018-06-29 22:56:15 +0800
committermfechner <mfechner@FreeBSD.org>2018-06-29 22:56:15 +0800
commite5189d79736201e952a4755000658781338da657 (patch)
tree6a679c98eaddbd59697eec3d05a6de02d4d2afc4
parent5fcf49569fb90853f67d925a5165a53c05476f70 (diff)
downloadfreebsd-ports-gnome-e5189d79736201e952a4755000658781338da657.tar.gz
freebsd-ports-gnome-e5189d79736201e952a4755000658781338da657.tar.zst
freebsd-ports-gnome-e5189d79736201e952a4755000658781338da657.zip
Updated to 2.7.1 which is required for gitlab 10.8.5.
Reviewed by: mat, tz (mentor) Approved by: tz (mentor) Differential Revision: https://reviews.freebsd.org/D16032
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/Makefile23
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/distinfo5
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/files/patch-gemspec14
3 files changed, 15 insertions, 27 deletions
diff --git a/textproc/rubygem-html-pipeline-gitlab/Makefile b/textproc/rubygem-html-pipeline-gitlab/Makefile
index 7955fcc6ae4c..1d861945baee 100644
--- a/textproc/rubygem-html-pipeline-gitlab/Makefile
+++ b/textproc/rubygem-html-pipeline-gitlab/Makefile
@@ -1,24 +1,25 @@
# $FreeBSD$
-PORTNAME= html-pipeline-gitlab
-PORTVERSION= 0.2.0
+PORTNAME= html-pipeline
+PORTVERSION= 2.7.1
CATEGORIES= textproc rubygems
MASTER_SITES= RG
+PKGNAMESUFFIX= -gitlab
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Extension filters for html-pipeline used by GitLab
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= GitHub HTML processing filters and utilities used by GitLab
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= rubygem-actionpack4>=4:www/rubygem-actionpack4 \
- rubygem-gitlab_emoji>=0.1:graphics/rubygem-gitlab_emoji \
- rubygem-html-pipeline>=1.11.0:textproc/rubygem-html-pipeline \
- rubygem-mime-types>=0:misc/rubygem-mime-types \
- rubygem-sanitize>=2.1:textproc/rubygem-sanitize
+RUN_DEPENDS= rubygem-activesupport4>=2:devel/rubygem-activesupport4 \
+ rubygem-nokogiri>=1.4:textproc/rubygem-nokogiri
-NO_ARCH= yes
-USE_RUBY= yes
USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^2\.7\.1
.include <bsd.port.mk>
diff --git a/textproc/rubygem-html-pipeline-gitlab/distinfo b/textproc/rubygem-html-pipeline-gitlab/distinfo
index 81cddb0050a9..8221f1121029 100644
--- a/textproc/rubygem-html-pipeline-gitlab/distinfo
+++ b/textproc/rubygem-html-pipeline-gitlab/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rubygem/html-pipeline-gitlab-0.2.0.gem) = 3631eedbf33ff56eda6a6ee898277fe47f188377c19e55b20d4eac8f95208448
-SIZE (rubygem/html-pipeline-gitlab-0.2.0.gem) = 9216
+TIMESTAMP = 1530208902
+SHA256 (rubygem/html-pipeline-2.7.1.gem) = 4d36699cc0fe677a8a90214d43c23e3559a9126c38299b2bb3f6c9983e387d42
+SIZE (rubygem/html-pipeline-2.7.1.gem) = 29184
diff --git a/textproc/rubygem-html-pipeline-gitlab/files/patch-gemspec b/textproc/rubygem-html-pipeline-gitlab/files/patch-gemspec
deleted file mode 100644
index 74f6adc71445..000000000000
--- a/textproc/rubygem-html-pipeline-gitlab/files/patch-gemspec
+++ /dev/null
@@ -1,14 +0,0 @@
---- html-pipeline-gitlab.gemspec.orig 2016-03-31 19:05:43 UTC
-+++ html-pipeline-gitlab.gemspec
-@@ -25,9 +25,9 @@ Gem::Specification.new do |s|
- s.add_development_dependency(%q<bundler>.freeze, ["~> 1.6"])
- s.add_development_dependency(%q<rake>.freeze, ["~> 10.0"])
- s.add_development_dependency(%q<pry>.freeze, ["~> 0.9"])
-- s.add_runtime_dependency(%q<html-pipeline>.freeze, ["~> 1.11.0"])
-+ s.add_runtime_dependency(%q<html-pipeline>.freeze, [">= 1.11.0"])
- s.add_runtime_dependency(%q<gitlab_emoji>.freeze, ["~> 0.1"])
-- s.add_runtime_dependency(%q<sanitize>.freeze, ["~> 2.1"])
-+ s.add_runtime_dependency(%q<sanitize>.freeze, [">= 2.1"])
- s.add_runtime_dependency(%q<actionpack>.freeze, ["~> 4"])
- s.add_runtime_dependency(%q<mime-types>.freeze, [">= 0"])
- else