aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2019-03-02 03:18:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2019-03-02 03:18:57 +0800
commite54407f66e74df9b3b26baed05a75ffb0422a84a (patch)
treeded78871a513d81348ec7f62b964b5bc546c7097
parent4bea1b3a38a4f52941d1bb5438951e1288969492 (diff)
downloadfreebsd-ports-gnome-e54407f66e74df9b3b26baed05a75ffb0422a84a.tar.gz
freebsd-ports-gnome-e54407f66e74df9b3b26baed05a75ffb0422a84a.tar.zst
freebsd-ports-gnome-e54407f66e74df9b3b26baed05a75ffb0422a84a.zip
- Switch sdl_image and sdl2_image from dynamic loading of dependency
libraries to normal shared linking - While here, add USES=sdl and localbase add LICENSE_FILE and strip library PR: 196099 Submitted by: jbeich
-rw-r--r--graphics/sdl2_image/Makefile5
-rw-r--r--graphics/sdl_image/Makefile10
2 files changed, 10 insertions, 5 deletions
diff --git a/graphics/sdl2_image/Makefile b/graphics/sdl2_image/Makefile
index 08e6b3165d9d..dc5943fec92c 100644
--- a/graphics/sdl2_image/Makefile
+++ b/graphics/sdl2_image/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sdl2_image
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL2_image-${PORTVERSION}
@@ -12,9 +13,11 @@ COMMENT= Simple library to load images of various formats as SDL surfaces
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USES= pkgconfig:build pathfix gmake libtool localbase
+USES= gmake libtool localbase pkgconfig pathfix sdl
USE_SDL= sdl2
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-jpg-shared --disable-png-shared \
+ --disable-tif-shared --disable-webp-shared
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 6fe0da1b7dac..acd81538eddc 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sdl_image
PORTVERSION= 1.2.12
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
@@ -12,12 +12,14 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Simple library to load images of various formats as SDL surfaces
LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool pkgconfig pathfix
+USES= gmake libtool localbase pkgconfig pathfix sdl
USE_SDL= sdl
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm
+CONFIGURE_ARGS= --disable-jpg-shared --disable-png-shared \
+ --disable-tif-shared --disable-webp-shared
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
OPTIONS_DEFINE= JPEG PNG TIFF WEBP